MSI mag x570 tomahawk wifi - Big Sur OpenCore 0.7.0

lesnico

New member
Joined
Jun 11, 2021
Messages
15

MSI mag x570 tomahawk wifi


Hey everyone, this is my first hackintosh. I've been working on it for a week. Everything has been done by following the various guides at Dortania and by browsing google.
I'm happy to announce that, so far, everything seems to be working pretty well. No weird issues has been spotted.

bigsur-proof-lesnico.png

My Build:
  • CPU: Ryzen 7 3700x
  • Motherboard: MSI mag x570 tomahawk wifi
  • RAM: DDR4 HyperX Fury - 32 Go (2 x 16 Go) 3200 MHz - CAS 16
  • GPUs: Sapphire RX480 4go (macOS) | Nvidia RTX 380 Founder edition
  • Case: Fractal Design Meshify 2 Compact
  • NVME: 1 Crucial P2 500go (macOS) | 1 samsung 970 evo plus 1to (Windows)
  • PSU: Cooler Master MWE Gold 650 FM
  • Sound: Focusrite Clarett 2pre usb
  • CPU Cooler: Noctua NHD15
  • Case fans: 2 x Noctua NF-S12A PWM + 2 x Noctua NF-A14 PWM
  • Keyboard: Logitech MX Keys
  • Mouse: Logitech MX Master 3
  • OS: Big Sur 11.4 | Windows 10 Pro
  • Bootloader: OpenCore 0.7.0
SSDT:
All SSDTs were built manualy with a dump I personnaly made with opencore.
  • SSDT-EC.aml
  • SSDT-HPET.aml
  • SSDT-SBUS-MCHC.aml
Kexts:
  • AMDRyzenCPUPowerManagement
  • AppleALC
  • AppleMCEReporterDisabler
  • Lilu
  • LucyRTL8125Ethernet
  • NVMeFix
  • RestrictEvents
  • SMCAMDProcessor
  • USBMap
  • VirtualSMC
  • WhateverGreen

Working:
  • Ethernet Port
  • USB
  • iCloud
  • Hardware Acceleration
  • iMessages
  • Sleep & Wake
  • Facetime
  • Sound from the MB (Microphone included!)
  • Wifi & Bluetooth:
    • Wifi & bluetooth are managed by the Intel® Wi-Fi 6 AX200 module which isn't compatible with macOS.
    • Two solutions: Buy a new wifi pcie-card or add those kexts:
      • Wifi (AirportItlwm.kext or itlwm.kext + Heliport app)
      • Bluetooth (IntelBluetoothFirmware.kext)
Not Tested:
  • Because I don't have other apple devices:
    • Handoff
    • Continuity
    • Apple Watch Unlock
  • Because I don't have a Netflix account anymore:
    • Netflix DRM on Safari
Not Working:
  • Sidecar (Amd processor, not tested but it shouldn't work)


So this is where it gets weird. Everything is working apparently except for one thing. I can't disable my RTX3080 fe and I need to do it because it prevents my computer to sleep normally.
I've posted an issue on this topic, any help would be greatly appreciated :) :
https://forum.amd-osx.com/index.php?threads/msi-mag-x570-tomahawk-wifi-cant-disable-rtx3080-fe.1849/
 
Last edited:

lesnico

New member
Joined
Jun 11, 2021
Messages
15
Update:
  • Internal sound now works fine. Mic input also works.
  • I've manualy created my SSDTs for a better stability
  • Removed AirportItlwm.kext & intelBluetoothFirmware.kext as I don't need them and they are quite unstable. I'm waiting for a BCM94360NG wifi m2 module to arrive in order to be able to use AirPort and stable Bluetooth/wifi natively.
 

deutsaz

New member
Joined
Apr 7, 2021
Messages
6

MSI mag x570 tomahawk wifi


Hey everyone, this is my first hackintosh. I've been working on it for a week. Everything has been done by following the various guides at Dortania and by browsing google.
I'm happy to announce that, so far, everything seems to be working pretty well. No weird issues has been spotted.

View attachment 3339

My Build:
  • CPU: Ryzen 7 3700x
  • Motherboard: MSI mag x570 tomahawk wifi
  • RAM: DDR4 HyperX Fury - 32 Go (2 x 16 Go) 3200 MHz - CAS 16
  • GPUs: Sapphire RX480 4go (macOS) | Nvidia RTX 380 Founder edition
  • Case: Fractal Design Meshify 2 Compact
  • NVME: 1 Crucial P2 500go (macOS) | 1 samsung 970 evo plus 1to (Windows)
  • PSU: Cooler Master MWE Gold 650 FM
  • Sound: Focusrite Clarett 2pre usb
  • CPU Cooler: Noctua NHD15
  • Case fans: 2 x Noctua NF-S12A PWM + 2 x Noctua NF-A14 PWM
  • Keyboard: Logitech MX Keys
  • Mouse: Logitech MX Master 3
  • OS: Big Sur 11.4 | Windows 10 Pro
  • Bootloader: OpenCore 0.7.0
SSDT:
All SSDTs were built manualy with a dump I personnaly made with opencore.
  • SSDT-EC.aml
  • SSDT-HPET.aml
  • SSDT-SBUS-MCHC.aml
Kexts:
  • AMDRyzenCPUPowerManagement
  • AppleALC
  • AppleMCEReporterDisabler
  • Lilu
  • LucyRTL8125Ethernet
  • NVMeFix
  • RestrictEvents
  • SMCAMDProcessor
  • USBMap
  • VirtualSMC
  • WhateverGreen

Working:
  • Ethernet Port
  • USB
  • iCloud
  • Hardware Acceleration
  • iMessages
  • Sleep & Wake
  • Facetime
  • Sound from the MB (Microphone included!)
  • Wifi & Bluetooth:
    • Wifi & bluetooth are managed by the Intel® Wi-Fi 6 AX200 module which isn't compatible with macOS.
    • Two solutions:Buy a new wifi pcie-card or add those kexts:
      • Wifi (AirportItlwm.kext or itlwm.kext + Heliport app)
      • Bluetooth (IntelBluetoothFirmware.kext)
Not Tested:
  • Because I don't have other apple devices:
    • Handoff
    • Continuity
    • Apple Watch Unlock
  • Because I don't have a Netflix account anymore:
    • Netflix DRM on Safari
Not Working:
  • Sidecar (Amd processor, not tested but it shouldn't work)


So this is where it gets weird. Everything is working apparently except for one thing. I can't disable my RTX3080 fe and I need to do it because it prevents my computer to sleep normally.
I've posted an issue on this topic, any help would be greatly appreciated :) :
https://forum.amd-osx.com/index.php?threads/msi-mag-x570-tomahawk-wifi-cant-disable-rtx3080-fe.1849/
Great to see someone up and running on same Motherboard as me. While I am up and running with a degree of success, I am struggling to get past 0.6.5. Are you able to share your config, and details on how you generated the SSDT files, so I can mimic your setup please.

Thanks
 

lesnico

New member
Joined
Jun 11, 2021
Messages
15
You should start with a fresh opencore 0.7.0 install.
My config.plist has nothing special to be fair, i've just followed the guide at dortania and it worked like a charm.

For the audio tho, if you're using AppleALC, make sure to use the following boot-arg: alcid=51. I don't know why but by using this number, front and back audio and microphone are working.

About the SSDT files, i've just followed the Dortania guide (manual creation). It's very well explained and even if it seems scary at first, it's very easy to do them.
But with just the mandatory one (SSDT-EC.aml) which can be found on the Dortania guide prebuilt, I was able to boot on macOS Big Sur without any problems.

Can you five me more infos on your build? I'll try to help you ;)
 

deutsaz

New member
Joined
Apr 7, 2021
Messages
6
You should start with a fresh opencore 0.7.0 install.
My config.plist has nothing special to be fair, i've just followed the guide at dortania and it worked like a charm.

For the audio tho, if you're using AppleALC, make sure to use the following boot-arg: alcid=51. I don't know why but by using this number, front and back audio and microphone are working.

About the SSDT files, i've just followed the Dortania guide (manual creation). It's very well explained and even if it seems scary at first, it's very easy to do them.
But with just the mandatory one (SSDT-EC.aml) which can be found on the Dortania guide prebuilt, I was able to boot on macOS Big Sur without any problems.

Can you five me more infos on your build? I'll try to help you ;)
Hello. yes I have the alcid=51. I did follow the Dortania guide (around Dec/Jan) but did get thrown by the SSDT stuff. It all works, but I am stuck on an old build of OC. Just need to take the plunge :). Lets see how it goes... I'll go with the fresh start as you say - at worst I can always default back to where I am....
 

JollyJamma

New member
Joined
Jan 21, 2022
Messages
8
I've tried to get my X570 tomahawk board to get to the install part of a Hackintosh and I just can't.

Trying my best to get it installed but yeah, it's not happy.

Going to get a seperate machine for Mac since I can't keep flicking settings and hardware. I have an RX 580 and a 3080. The 3080 is so bloody fast that I can't not use it for gaming.
 

itrimble

New member
Joined
Aug 24, 2021
Messages
5
I've tried to get my X570 tomahawk board to get to the install part of a Hackintosh and I just can't.

Trying my best to get it installed but yeah, it's not happy.

Going to get a seperate machine for Mac since I can't keep flicking settings and hardware. I have an RX 580 and a 3080. The 3080 is so bloody fast that I can't not use it for gaming.

What do you mean by clicking settings?
I've got the same mb as you with an RX 580. The 3080 unfortunately won't work.
 

JollyJamma

New member
Joined
Jan 21, 2022
Messages
8
What do you mean by clicking settings?
I've got the same mb as you with an RX 580. The 3080 unfortunately won't work.
Yeah, I know. I have an RX 580 and RTX 3080.

I've created a new thread since I can't seem to get an IP address during the installer. The kext injects but it doesn't give me an ethernet connection.
 

itrimble

New member
Joined
Aug 24, 2021
Messages
5
Yeah, I know. I have an RX 580 and RTX 3080.

I've created a new thread since I can't seem to get an IP address during the installer. The kext injects but it doesn't give me an ethernet connection.
What are you using for your network card ?
 

JollyJamma

New member
Joined
Jan 21, 2022
Messages
8
What are you using for your network card ?
The built in Realtek 2.5gig card using the LucyRTL8125Ethernet kext.

 

itrimble

New member
Joined
Aug 24, 2021
Messages
5
The built in Realtek 2.5gig card using the LucyRTL8125Ethernet kext.

I’ll have to try mine when I get home. I’m using Wi-Fi. I’ll let you know the results.
 

Edhawk

Active member
Joined
May 2, 2020
Messages
690
Can you update to Monterrey with MSI B500 Tomahack?
Possibly.

There is a known issue with MSI boards running macOS Monterey, it effects all MSI boards. So it is not something that can be fixed in OpenCore, yet.

The people who have managed to install Monterey on an MSI board have had to downgrade the bios on their motherboards. As the latest bios seems to block the installation. How far back you need to regress the Bios is not stated.

They have also had to accept that their 2.5GB Ethernet ports don't work correctly, if at all. Some have resorted to using USB3 to Ethernet adapters to get a decent Network/Internet connection.
 

itrimble

New member
Joined
Aug 24, 2021
Messages
5
Possibly.

There is a known issue with MSI boards running macOS Monterey, it effects all MSI boards. So it is not something that can be fixed in OpenCore, yet.

The people who have managed to install Monterey on an MSI board have had to downgrade the bios on their motherboards. As the latest bios seems to block the installation. How far back you need to regress the Bios is not stated.

They have also had to accept that their 2.5GB Ethernet ports don't work correctly, if at all. Some have resorted to using USB3 to Ethernet adapters to get a decent Network/Internet connection.
Looks like I will be on Big Sur for a while.
 
Top Bottom