Monterey on AMD FX-6300 hackintosh: 2 issues

jsl2020

Member
Joined
Jun 5, 2020
Messages
30
1. Unable to update to Monterey 12.1 betax from 12.0: It's Macintosh HD always got reboot loop. The only solution is got updated Macintosh HD from other hackintoshs, then it can reboot 3 times successfully to newer version.
[Solved] Please see my post later dated on 2021-11-22.
2. In OpenCore 0.7.3 to 0.7.5 if ProvideCurrentCpuInfo Quirk was enabled it always got KP with red screen. Any fix or solution ? I must apply many extra old kernel patches to boot successfully now.

 

Attachments

  • config.plist
    76.5 KB · Views: 43
Last edited:

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,787
Is the red screen the X64 Exception error? This must be fixed within OC but I can't see it happening. Same issue AMD had with Clover in the early days.
 

jsl2020

Member
Joined
Jun 5, 2020
Messages
30
Is the red screen the X64 Exception error? This must be fixed within OC but I can't see it happening. Same issue AMD had with Clover in the early days.
Yes, the red screen panic is the X64 Exception error. It only occurs ProvideCurrentCpuInfo Quirk was enabled on my FX-6300 hackintosh (legacy boot).
Are there any other AMD CPU users suffered from the same issue with OpenCore ?
At present I can tolerate it because I can use old kernel patches for both Clover 5142 and OpenCore 0.7.5, but the first issue bothered me a lot.
I need got updated Macintosh HD from Z490, Z370, or Ryzen 1700X hackintoshs to complete the update process, otherwise I always got reboot loop on FX-6300.
Do you have any idea or solution to fix it ?
 

jsl2020

Member
Joined
Jun 5, 2020
Messages
30
The patches are updated and maintained for Clover by the macOS86.it team over on our GitHub Clover branch, https://github.com/AMD-OSX/AMD_Vanilla/tree/clover
Thanks.
Without enabled ProvideCurrentCpuInfo quirk I must use older complicated kernel patches in both Clover & OC now.
So I hope this issue can be solved and it maybe also related to the first issue too.


[Solved on 2021-11-22]
The first issue was solved by the following method: (1) OpenCore 0.7.5 (2) SMBIOS=MacPro7,1
(3) SecureBootMode=j160 To get updated Macintosh HD at first
(4) SecureBootMode=Disabled To reboot for 3 times and complete update process without reboot loop now !
I don't know why using the similar method of HWTarget in Clover 5142 did not work for me.
[New finding]
I just found and confirmed that my FX-6300 hackintosh can update successfully by the following simpler method too:
(1)OpenCore 0.7.6
(2)SMBIOS=iMac17,1
(3)SecureBootMode=Disabled To reboot for 3 times and complete update process without reboot loop now !

 

Attachments

  • config.plist
    39.5 KB · Views: 24
Last edited:

dogukan0055

New member
Joined
Nov 27, 2021
Messages
2
Hey man, may i ask how did you install Monterey on legacy system , FX 6300 processor? I do have Fx 6300 and Asus M5A78L-M LX3 mb but can't figure it out. I got gray screen on OC, stuck at end random seed on clover and another failure is waiting for root device on OC. I'm gonna try your EFI right now but I don't think it'll work either. Trying to figure out the problem over a month and got nothing so far.
 

jsl2020

Member
Joined
Jun 5, 2020
Messages
30
Hey man, may i ask how did you install Monterey on legacy system , FX 6300 processor? I do have Fx 6300 and Asus M5A78L-M LX3 mb but can't figure it out. I got gray screen on OC, stuck at end random seed on clover and another failure is waiting for root device on OC.
Because your MB is quite similar to mine I can provide my past experience for your reference to fix yours.
The best solution is change your GPU from Nvidia GTX750 Ti to AMD RX-560/570/580 otherwise you will spent more time and energy to install Monterey in this legacy hackintoshs.
I have another 3 Intel hackintoshs with GPU of Nvidia GeoForce GT710/730 which need legacy booting.
In Clover I can select disable Nvidia to boot and login desktop, then apply chris1111's GeoForce legacy patches to get hardware acceleration.
And since it broke snapshot for later update it need full installer (> 11GB) instead of normal update (2.x GB).
Or you can boot OpenCore successfully with Apple Software Graphics, then apply GeoForce patches later.
Depending upon your booting results.
For update Monterey I must use OpenCore because Clover will got reboot loop forever !
 

Attachments

  • boot.zip
    393.2 KB · Views: 29
  • EFI.zip
    30.5 MB · Views: 84
Last edited:

Mairramer

New member
Joined
Mar 1, 2021
Messages
2
1. Unable to update to Monterey 12.1 betax from 12.0: It's Macintosh HD always got reboot loop. The only solution is got updated Macintosh HD from other hackintoshs, then it can reboot 3 times successfully to newer version.
[Solved] Please see my post later dated on 2021-11-22.
2. In OpenCore 0.7.3 to 0.7.5 if ProvideCurrentCpuInfo Quirk was enabled it always got KP with red screen. Any fix or solution ? I must apply many extra old kernel patches to boot successfully now.

''
Because your MB is quite similar to mine I can provide my past experience for your reference to fix yours.
The best solution is change your GPU from Nvidia GTX750 Ti to AMD RX-560/570/580 otherwise you will spent more time and energy to install Monterey in this legacy hackintoshs.
I have another 3 Intel hackintoshs with GPU of Nvidia GeoForce GT710/730 which need legacy booting.
In Clover I can select disable Nvidia to boot and login desktop, then apply chris1111's GeoForce legacy patches to get hardware acceleration.
And since it broke snapshot for later update it need full installer (> 11GB) instead of normal update (2.x GB).
Or you can boot OpenCore successfully with Apple Software Graphics, then apply GeoForce patches later.
Depending upon your booting results.
For update Monterey I must use OpenCore because Clover will got reboot loop forever !
How you install on the legacy?
I've tried it several times without success, with the same hardware,just my card which is an rx460.
 
Last edited:

cupecups

New member
Joined
Jun 16, 2020
Messages
14
DF1761E2-16DC-4D8D-B157-84C7C7FFD7C9.jpeghi @jsl2020 , i use kernel patch on your config, but unable to boot bigsur 11.6.2 with exitBS kernel patch,

when try boot mojave got kernel panic after verbose

see photo of bigsur boot
 

jsl2020

Member
Joined
Jun 5, 2020
Messages
30
View attachment 4811hi @jsl2020 , i use kernel patch on your config, but unable to boot bigsur 11.6.2 with exitBS kernel patch,

when try boot mojave got kernel panic after verbose

see photo of bigsur boot
The kernel patch was correct even with these errors of "not found" that mean at Big Sur you can disable these kernel patches.
Your panic was due to VoodooHDA.kext which is located at /Kernel/Add
You need disable this kext to boot and get audio solution later.
Please show your hardware signature if you need more help.
 

cupecups

New member
Joined
Jun 16, 2020
Messages
14
i think so, but when i inject voodooHDA on montery can boot without any issue, maybe i will try voodoo injections first to boot bigsur or lower,

here’s my spec

  • amd fx 8150
  • gigabyte Ga-78LMT-Usb3
  • radeon 7850 2gb
 
Top Bottom