macOS Monterey Patches Released

shinningyu55688

New member
Joined
Jun 8, 2021
Messages
2
Patches have now been updated to allow MacOS Monterey Beta 1, 2 and 3 booting. There are still some issues booting beta 3 for some users. Mainly MSI X570 boards.

Patches: https://github.com/AMD-OSX/AMD_Vanilla
Information: https://forum.amd-osx.com/index.php?threads/new-amd-macos-corecount-patch-information.1948



As a MSI motherboard user, I can confirm that on Beta 3 and 4, the installer can't recognize the NVME drive (stuck at NVME assert failed).
Success on Beta 2, but no luck on Beta 3 and 4.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,337
As a MSI motherboard user, I can confirm that on Beta 3 and 4, the installer can't recognize the NVME drive (stuck at NVME assert failed).
Success on Beta 2, but no luck on Beta 3 and 4.
MSI X570 Boards have something Going on in the bios that’s preventing Beta3 and 4 from working.
We can not suss out what on earth is going on though.
 

muifaha

New member
Joined
Jan 4, 2021
Messages
2
MSI X570 Boards have something Going on in the bios that’s preventing Beta3 and 4 from working.
We can not suss out what on earth is going on though.
msi board is really weird, with my board B550 bazooka, had to downgrade from bios A7 to A2 to boot into beta 4, and I found another strange thing, when beta 4 was running fine, I tried to enter monterey recovery, strangely it didn't work, I tried to make big sur recovery it's same, only a glitch appears on the screen, so i flash lastest bios A7 again and can enter big sur recovery
 

Attachments

  • photo_2021-07-31 07.07.58.jpeg
    photo_2021-07-31 07.07.58.jpeg
    252 KB · Views: 20

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,337
msi board is really weird, with my board B550 bazooka, had to downgrade from bios A7 to A2 to boot into beta 4, and I found another strange thing, when beta 4 was running fine, I tried to enter monterey recovery, strangely it didn't work, I tried to make big sur recovery it's same, only a glitch appears on the screen, so i flash lastest bios A7 again and can enter big sur recovery
Try disabling SIP and then try the recovery drive. 👍
Have you tried the new patches with your B550?
Most the MSI B550 users who couldn’t get it working before the new patches seem to be fine now.
MSI X570 is for sure is bios borked for Beta3 and higher and dropping the bios revision back to a working version is not an option for anybody running a 5000 series CPU so the hunt continues for a way around the problem.
 

muifaha

New member
Joined
Jan 4, 2021
Messages
2
Try disabling SIP and then try the recovery drive. 👍
Have you tried the new patches with your B550?
Most the MSI B550 users who couldn’t get it working before the new patches seem to be fine now.
MSI X570 is for sure is bios borked for Beta3 and higher and dropping the bios revision back to a working version is not an option for anybody running a 5000 series CPU so the hunt continues for a way around the problem.
tried disable SIP but no luck, yesterday i update to new patch and also update bios to A3 but same, can't boot to beta 4. I dont know why cant boot recovery with old bios (A2 is my bios when purcase this board and i remember can boot to recovery big sur when i first intall MacOS in AMD). But now i am happy in big sur 😀 with lastest bios
 

tuliodomingos

Member
Joined
May 2, 2020
Messages
78
A próxima versão EFI eu faço quando as versões 0.7.2 terão os patches mais recentes compatíveis com o Beta 12.0 mais recente e eu colocarei notas sobre como torná-lo mais amigável para Monterey. Mas tudo o que você precisa saber pode ser encontrado no GitHub e também no aqui. 👍

Tópico 'Informações sobre o patch AMD macOS CoreCount'
https://forum.amd-osx.com/index.php?threads/new-amd-macos-corecount-patch-information.1948/
eno meu caso que tenho pe=rocessador 4 nucleos quak valor que c=vou usar no novo pach??
 

hiepgia

New member
Joined
Jul 3, 2020
Messages
2
tried disable SIP but no luck, yesterday i update to new patch and also update bios to A3 but same, can't boot to beta 4. I dont know why cant boot recovery with old bios (A2 is my bios when purcase this board and i remember can boot to recovery big sur when i first intall MacOS in AMD). But now i am happy in big sur 😀 with lastest bios
Try set SecureBootModel to Disabled. I am using MSI B550 Tomahawk too.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
Not sure what happened to the formatting on that post but yes it works on all current beta versions of Monterey.
 

tuliodomingos

Member
Joined
May 2, 2020
Messages
78
Não tenho certeza do que aconteceu com a formatação nesse post, mas sim, funciona em todas as versões beta atuais de Monterey.
estou com com montorey beta 1 insatalado open core 0.7.1 funcionanal
criei pen boot monterey beta 4 vom pach novo nao vai nem no beta 1 e nem no beta 4

Captura de tela 2021-08-01 124709.pngIMG_20210801_125207.jpgO que estou fasendo de errado ???
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
@tuliodomingos did you enable the ProvideCurrentCpuInfo quirk?

It's under the Kernel -> Quirks section in your config.
 
Last edited:

Neckbeard

New member
Joined
May 3, 2020
Messages
22
I had Beta 1 running but it kept failing to update to Beta 4 on OC 0.7.1.

I built OC 0.7.2 and did a clean install of Beta 4 and its working better now.

Also getting the incorrect processor and serial number displayed that started with 0.7.2, but It works now at least. About this Mac was crashing on 0.7.1 for me.

7hnOsTs.png
 
Top Bottom