Intel I211-AT Alternative to SmallTree

Status
Not open for further replies.

iGPU

Donator
Donator
Joined
May 5, 2020
Messages
15
Sorry I'm a little late to the party, but today I tried the both the 1st version posted at the start of this thread and the last version.

Neither worked on my MSI TRX40 Creator mobo (3970X CPU). In fact, the I211 port did not even show up when using the AppleIGB kext, let alone become activated.

When using the SmallTree kext, the port shows up but is inactive. I also tried injecting the SmallTree first, followed by the AppleIGB kext, and this too did not work: the port showed up but was inactive; the usual for SmallTree alone.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,341
Sorry I'm a little late to the party, but today I tried the both the 1st version posted at the start of this thread and the last version.

Neither worked on my MSI TRX40 Creator mobo (3970X CPU). In fact, the I211 port did not even show up when using the AppleIGB kext, let alone become activated.

When using the SmallTree kext, the port shows up but is inactive. I also tried injecting the SmallTree first, followed by the AppleIGB kext, and this too did not work: the port showed up but was inactive; the usual for SmallTree alone.
AppleGB needs some special care and attention to make it work correctly by somebody very smart like youself. (Hint Hint) ;) 😂
 
Last edited:

savage001

Active member
Joined
Jun 4, 2020
Messages
135
Unfortunately both kexts posted here fail to work after a short time. Running a ping test it works for about a minute then times out. I’ll get more details like device Id etc tomorrow.
Glad to see this is being looked at.
Gigabyte X570 Aorus Pro Wifi


Sent from my iPhone using Tapatalk
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,341
Unfortunately both kexts posted here fail to work after a short time. Running a ping test it works for about a minute then times out. I’ll get more details like device Id etc tomorrow.
Glad to see this is being looked at.
Gigabyte X570 Aorus Pro Wifi


Sent from my iPhone using Tapatalk
My last post sums up that kext.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
It's above my pay grade lol. Need an actual developer to take a look at and and find out why it'll randomly disconnect.
 

savage001

Active member
Joined
Jun 4, 2020
Messages
135
this kext no bloatware ;) only for i210 and i211: note: this kext from Shaneee's latest posted kext
tested on Big Sur 11.5.2 and Monterey Beta 6

I haven’t tested this one yet but the other 2 drop out. I’ll test this one tonight.


Sent from my iPhone using Tapatalk
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,341
It sure is. That’s why I quoted his post.
Did I provide enough info?


Sent from my iPhone using Tapatalk
Yeah you got it covered.
I will check that version again but it was dropping out too last time I tried it.
One of the major problems with that kext that needs dealing with is it’s not universal meaning what works for one board doesn’t work for a different one and in TR4 land it doesn’t work at all.
This is why it needs somebody with developer skills to do some serious work and magic to it.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
The only difference in that kext is removing some of the PCI match in the plist. The driver it's self has no modification so I can't see how it makes a difference tbh.
 

savage001

Active member
Joined
Jun 4, 2020
Messages
135
I'm not sure about any changes between the kexts, just reporting my finding and mine is that the AppleIGB_i210i211.kext works flawlessly for me as shown by my ping count.

 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,295
The constant ping may be keeping it alive. Don't run ping and leave it idle for a bit and check on it later and see if it's still active.

I've reworked the source for the kext removing what we don't need for i211. So far so good. Here's the updated kext.

 

Attachments

  • AppleI2xx.kext.zip
    70.3 KB · Views: 34
Last edited:

savage001

Active member
Joined
Jun 4, 2020
Messages
135
The constant ping may be keeping it alive. Don't run ping and leave it idle for a bit and check on it later and see if it's still active.

I've reworked the source for the kext removing what we don't need for i211. So far so good. Here's the updated kext.


I’ll give that one a try tomorrow without running ping.
Also great way to flex your internet speed, I’m jealous.


Sent from my iPhone using Tapatalk
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,341
The constant ping may be keeping it alive. Don't run ping and leave it idle for a bit and check on it later and see if it's still active.

I've reworked the source for the kext removing what we don't need for i211. So far so good. Here's the updated kext.
Seems consistent, Im downloading a load of files and running speed tests while doing so and so far so good.
Il leave it idol once what's downloading is finished for a while then do the rest of my downloads and see if its still holding its connection.


Screenshot 2021-09-16 at 16.39.52.png
That ping though...lol
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,341
Update, After finishing up and letting the system drop to sleep then waking it back up a bit later I lost connection. Ive now configured it to 1000mbs manually and the connection went active and steady again. lets see if it holds now its manually set.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,341
Update 2, Let the system goto sleep again and once I woke it up the connection was dead again.
COMPUTER SAYS NO!!!!! :(
 
Status
Not open for further replies.
Top Bottom