Installation with some problems on AMD FX-8350

el_angel_caido

New member
Joined
May 2, 2020
Messages
8
Hi.

The first of all is to apologize for my lousy English (and for the poor Google translation ;) ).

My PC is an AMD FX-8350 with 16GB of RAM and an ASUS M5A97 R2.0 motherboard, plus an nVidia GTX 650TI with 2GB of VRAM.

I have installed macOS Catalina 10.15.4 using OpenCore 0.5.7, for this I have used the opencore guide for desktops and VoodooHDA for audio (because AppleALC is still incompatible with Bulldozers, or not?).

I have made a multiboot with Manjaro and Windows using Grub, for which I have added a custom entry in this one pointed to the disk with macOS and OpenCore.efi as boot loader, in /etc/grub.d/40_custom file:
Code:
#!/bin/sh
exec tail -n +3 $0
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.

#OpenCore macOS Catalina
menuentry 'macOS 10.15 Catalina (opencore)' --class macosx --class efi --class os $menuentry_id_option 'opencore-UUID' {
    insmod part_gpt
    insmod fat
    set root='hdX,gptY'
    search --no-floppy --fs-uuid --set=root UUID
    chainloader /EFI/OC/OpenCore.efi
}
The class options are for Grub Manjaro Theme, they show icons in the Grub menu.
In other distros it would be necessary to see what theme Grub uses and where it has the icons.

As expected the graph is natively supported, and for the SMBios I have used the data from an iMac14,2 (I have tried other combinations such as an iMacPro1,1). I have not activated the iServices because I have not managed to find a valid serial for it, although I do not think that I would use anything beyond the Apple Store either.

USB 3.0 (Asmedia ASM1042 in this case) works correctly using the GenericUSBXHCI.kext; I have not done the mapping of ports and I have disabled the limit of them in the config.list, and for now, at least for the use that I do, I have not found problems of data transfers or corruption of them.

I have disabled hibernation since the computer does not recover on waking and forces me to do a ClearCMOS to be able to use it again. Since I don't use it either, I haven't investigated if there is any way to fix it.

Well, the problem that I have and that I don't find with the key is that the VoodooHDA driver activates 7.1 channels by default and I have 2.0 speakers, plugged into the rear green connector. The microphone on the rear pink connector.
When I try to configure the speakers from the Audio Midi Setup utility it closes and I cannot complete the configuration.
With Youtube or stereo sources I have no problems but, for example, with VLC and multichannel AC3 audio, the sound that is heard corresponds only to the left and right channels, so, generally, the voices are not heard when broadcast on another channel.
I think it's a known problem since Mojave, but would there be a way to configure that part of the sound by modifying some system file using terminal or similar?
Does it work in High Sierra and, if so, is it worth installing today?

Another thing, I have a Logitech Quickam Zoom webcam that in Linux uses the Philips PWC driver (and in Windows 8.x/10 you have to patch the .ini of the driver to recognize it as a Logitech Quickam Pro 4000) ... but that in macOS does not recognize , only see the audio via USB.
I have found an old project called macam and a fork called macam64. The first is for 32 bits, then we discard its use in Catalina, right? The second one I can't compile, and the compiled option offered on GitHub is a .a library I don't know what to do with it.

Any ideas and / or suggestions? Not only for the sound and webcam theme, but also for fine tuning the settings.

Thanks and best regards. 😎

PS: I must add that it would be my first "stable" Hackintosh beyond a proof of concept, years ago, with Clover and Snow Leopard if I remember correctly.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,289
Sleep/Hibernation has always been problematic on AMD and we have no fix for it I'm afraid.
As for your VoodooHDA issues you'd be best asking Slice the developer of the project. I know XLNC is working on getting AppleALC to load on FX systems but no eta of it being completed yet.
As for your webcam what is the device and vendor ID?
 

el_angel_caido

New member
Joined
May 2, 2020
Messages
8
As for your webcam what is the device and vendor ID?
Thanks for the prompt response.

Congratulate you first on the new forum, the new look seems very good to me. Although due to the number of threads that the old forum has, it will still have to be used as an alternative. ;)
There are few forums on Hackintosh and AMD, and less in spanish (not to mention that there is none in that language) and the project and initiative are appreciated.

Well, to the point, I leave you the information obtained in Linux:
lsusb said:
ID 046d:08b3 Logitech, Inc. QuickCam Zoom

hwinfo said:
Hardware Class: camera
Model: "Logitech QuickCam Zoom"
Hotplug: USB
Vendor: usb 0x046d "Logitech, Inc."
Device: usb 0x08b3 "QuickCam Zoom"
Driver: "snd-usb-audio"
Driver Modules: "snd_usb_audio"

Driver Info #0:
Driver Status: pwc is active
Driver Activation Cmd: "modprobe pwc"
From what I have been able to find in Google it seems that this Philips driver for webcams (pwc) is quite problematic and only the Linux kernel supports it, since, as I mentioned, in the last Windows you have to make some changes in the driver files.
For Mac I have only found references to the macam project.
And yes, I know that the webcam is over a decade old, but it works like the first day. 😋
Anyway, do not complicate yourself with it, the few times it is used I can do it from Windows or Linux.

The sound is more "uncomfortable". I will look at contacting this Slice, because he will not be a member of the forum, right?

I have always wanted to have the three operating systems I used to work with on the same computer, and Intel has not entered my house for a long, long time. 😌

Thanks again and best regards. 😎

PS: You don't recommend me to try High Sierra? It is true that I preferred to use the latest available version of Mac, but High Sierra has support until September of this year and is compatible with 32 bits.
 
Last edited:

el_angel_caido

New member
Joined
May 2, 2020
Messages
8
Only for 32 bits.
There is not even official support from Logitech for that webcam under Windows, which I think I remember the last official software was for Windows XP.

Seeing the URL that you have put me has reminded me of the Logitech public FTP server, where I have not found anything for Mac that works, at least not in Catalina.
Thank you anyway. (y)

In Spain we are in confinement for COVID19 and I have created the USB with OC 0.5.7 and High Sierra ... Overall there is nothing better to do today. :giggle:

Regards. :cool:
 

el_angel_caido

New member
Joined
May 2, 2020
Messages
8
Hello again.

Well, I already have installed and configured macOS 10.13 High Sierra:

Is there a way to change the unknown CPU for something with more sense like Catalina?

And the Audio Midi Setup works with VooodooHDA 2.9.2 just fine. It also lets you enter the speaker configuration and choose the way you want the audio output for them:

I have had to look for High Sierra versions of some applications but for now I think I leave it like this, to switch to newer versions there is always time.

It really is a shame that the stereo output doesn't work in Catalina, the dark mode and some visual add-ons are better than in High Sierra.

The webcam still does not work, neither using the macam nor the Logitech application, both close and give an error. It will have to be used in Linux or Windows.

What I have noticed is that there are times when restarting freezes and I have to hit the reset button, or it takes a long time to restart and I have no patience. When I start again, I get the message that it has been turned off incorrectly. I will have to investigate it.

And some apps I've tried crash with error, like TeamViewer adjusting microphone audio (also happened in Catalina).
I guess not everything was going to be perfect.

Regards. 😎
 

el_angel_caido

New member
Joined
May 2, 2020
Messages
8
For your CPU name take a look here, https://github.com/corpnewt/CPU-Name
It worked ... until I updated the system to the last cumulative update ... now when rebooting I always get a panic window with "the computer has restarted blah blah blah press a button" and when shutting down it restarts.
Also the CPU-Name sets some unknown SIP and does not have write permissions.

I have been reading around if it has a solution, or I have not seen or I have not known how to find anything.

Better for this topic I look in the old forum or open a new thread in the corresponding subforum.

I must say that I have abandoned the Hackintosh project on my FX-8350, I have not managed to solve the failure after the cumulative update in High Sierra, and I have tried Catalina again with OC 0.5.8 and AppleALC (in principle the chipset of Realtek ALC8887 from my board would be supported), but I got tired of trying layouts.

I add my EFI for OC 0.5.7 in response to a request by @Hlfhi 's private message.

@Hlfhi , I suspect that the GenericUSBHXCI.kext is one of the causes of the reboot and shutdown issues, especially in High Sierra (here it can also be a VoodooHDA problem, but I'm not sure), but without that kext I don't have access to the ASMedia USB 3.0 ports on my motherboard.
Change SMBios data with GenSMBIOS, fields are "empty".

If someone sees a bug or something to improve, do not hesitate to say it ... maybe I would like to try again. 😁

Regards. 😎
 

Attachments

  • OC0.5.7-FX-Bulldozer.7z
    1 MB · Views: 66
Last edited:
Top Bottom