How to get HDR working?

bullerwins

New member
Original poster
May 14, 2020
12
0
1
I have a LG Oled display and it has HDR. But when I toggle "High Dynamic Range" in display settings it doens't seem to send the HDR metadata as the display doens't switch to HDR mode and the colors are washed out. Anyone got HDR working?
 

Attachments

  • IMG_2878.jpg
    IMG_2878.jpg
    4.2 MB · Views: 28
  • IMG_6762.jpg
    IMG_6762.jpg
    5.1 MB · Views: 27

bullerwins

New member
Original poster
May 14, 2020
12
0
1
Does the tv show the 'HDR' pop-up top right when you activate it?
No, it looks like its not sending the HDR metadata and switching to HDR mode on the TV. Works well on windows if I turn HDR on the windows settings or play a HDR movie with Media Player classic+madvr
 

RyzeCooker

Active member
May 3, 2020
119
26
28
Hm, so it isn't the cable either (presuming you're dual booting?) I have an LG oled too, but I run my Ryzentosh on a regular led monitor. So can't be much use to you. :) I asked because even in HDR on LG's you have some profile tweaks available... it could've been you were in some weird light mode. Hopefully someone can help you out!
 

Mo Al

New member
Jun 8, 2020
26
0
1
Try setting the color profile manually -----> go to the advanced display preferences > hit the color tab in the center > uncheck show profiles for this display only and then select the one starting with sRGB > then go back and toggle the HDR setting in display tab and see if it switches to HDR mode
 

bullerwins

New member
Original poster
May 14, 2020
12
0
1
Try setting the color profile manually -----> go to the advanced display preferences > hit the color tab in the center > uncheck show profiles for this display only and then select the one starting with sRGB > then go back and toggle the HDR setting in display tab and see if it switches to HDR mode
Tried but it doens't toggle HDR mode on the TV. I tried the same process for every color profile that is available and its just washed out color in different ways.
 

Mo Al

New member
Jun 8, 2020
26
0
1
Tried but it doens't toggle HDR mode on the TV. I tried the same process for every color profile that is available and its just washed out color in different ways.
Try messing with the settings and options on your monitor with the button.
 

Bansaku

New member
May 3, 2020
29
4
3
I have no issue with 4K HDR content with my Samsung QLED properly registering and displaying the correct format in Windows or Big Sur, it just works. However, you will have to mess with the gamma settings on your LG manually to get the picture looking normal and not washed out. For me, I had to adjust the BT profile 1 notch (to +1) and the gamma was fixed.

Try swapping HDMI ports on your R 580 as unfortunately there is no hack or option available in Mac OS to for forcing HDR. As well load up an HDR YouTube video and see if that triggers your TV to enable HDR. Safari supports 4K HDR natively now and I must say the playback performance puts Windows to shame.
 

rajovo

Member
May 4, 2020
75
8
8
I have no issue with 4K HDR content with my Samsung QLED properly registering and displaying the correct format in Windows or Big Sur, it just works. However, you will have to mess with the gamma settings on your LG manually to get the picture looking normal and not washed out. For me, I had to adjust the BT profile 1 notch (to +1) and the gamma was fixed.

Try swapping HDMI ports on your R 580 as unfortunately there is no hack or option available in Mac OS to for forcing HDR. As well load up an HDR YouTube video and see if that triggers your TV to enable HDR. Safari supports 4K HDR natively now and I must say the playback performance puts Windows to shame.
I have no such luck with my 2018 NU8000 Samsung TV. PS4 can output HDR, so can the builtin apps but HDR from MacOS is just slog-like, grey-ish contrastless image.
 

Bansaku

New member
May 3, 2020
29
4
3
I have no such luck with my 2018 NU8000 Samsung TV. PS4 can output HDR, so can the builtin apps but HDR from MacOS is just slog-like, grey-ish contrastless image.

Not sure why you all are having issues as I literally just plugged in the HDMI cable and turned the "black level" (what Samsung calle brightness ) to 0. Like I said in my original post, you HAVE to mess with YOUR TV's settings.

My TV Model is Samsung Q6DR49 (Canadian model, Q60R is the actual class)

IMG_0133.jpgIMG_0134.jpgIMG_0135.jpg



These next photos are from a Dobly Vision 4K 60FPS HDR YouTube video. Notice how perfect it looks (ignoring the iPhone compression). Again, this is default.

1.jpg
2.jpg
3.jpg