How can I enable HDMI audio please ?

Gigamaxx

Donator
Donator
Joined
Dec 4, 2020
Messages
103
Are you using the latest kernel patches? There are 39 in the new package. The last two improve the graphics card performance, but may cause HDMI or other audio to fail. #38 is the Algrey fix PAT, #39 is Shaneee's fix PAT. It is recommended to disable one of these patches to fix audio issues.

If that's not the case and you are using older patches qty 33-34 patches you may have other issues. Are you using AppleALC.kext? is it working correctly? You could try this fix in the link below, it may help if the patch disable doesn't or if you want to configure the mobo audio correctly.

Mini Guide for AMD AppleLAC.kext custom builds.
 

melkus

New member
Joined
Nov 12, 2020
Messages
5
Are you using the latest kernel patches? There are 39 in the new package. The last two improve the graphics card performance, but may cause HDMI or other audio to fail. #38 is the Algrey fix PAT, #39 is Shaneee's fix PAT. It is recommended to disable one of these patches to fix audio issues.

If that's not the case and you are using older patches qty 33-34 patches you may have other issues. Are you using AppleALC.kext? is it working correctly? You could try this fix in the link below, it may help if the patch disable doesn't or if you want to configure the mobo audio correctly.

Mini Guide for AMD AppleLAC.kext custom builds.

Yes I am using the latest kernel patches.
I tried :
  • enable #38 (and disable #39) not working
  • enable #39 (and disable #38) not working

Thank you for this because even though It didn't fix my issue, it did help to improve my GPU performance.
I used Geekbench 5 and for my setup it's better to use #39 (30000 => 36000 !)

I am using AppleALC.kext and my audio is working correctly except when I want to use HDMI audio (the Volume bar is disabled).



Thanks for your help.
 

Gigamaxx

Donator
Donator
Joined
Dec 4, 2020
Messages
103
Yes I am using the latest kernel patches.
I tried :
  • enable #38 (and disable #39) not working
  • enable #39 (and disable #38) not working

Thank you for this because even though It didn't fix my issue, it did help to improve my GPU performance.
I used Geekbench 5 and for my setup it's better to use #39 (30000 => 36000 !)

I am using AppleALC.kext and my audio is working correctly except when I want to use HDMI audio (the Volume bar is disabled).



Thanks for your help.
That is normal with DP/HDMI audio. There is no option to adjust volume, you need to use the TV or monitor volume. As long as the audio is synched it in time that’s the best you can get.
 
Top Bottom