Plig88

New member
Joined
Feb 15, 2021
Messages
10
Hello to everyone here .. I am new to ryzentosh .. for a year now I use hackintosh high Sierra on my spare pc ( Intel x5460- 8gb ram - and gt 630 ) but I’m bored the glitches on graphics because on high sierra doesn’t support my gpu ,, so yesterday I install the high Sierra on my main pc ( ryzen 7 2700x -b450 gaming gigabyte -16 gb ram 3000hz- Vega 64 ) from xlnc usb installer .. I make fast and easy .. everything work perfect . The lan-audio- gpu run on 1080p 144hz .. but the problem is when I open for check the multicraft game I see low FPS and very high usage of cpu , it’s about 90-95%.. I search on internet and I see must install AMD VANILLA PATCH - AMD POWER GADGET KEXT and SMCAMDProccessor... the point is that I don’t know how to install... with Intel I don’t had problems so I do not try something with patches or kexs .. but now I need to learn ,,, thank you
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
565
The AMD Ryzen Powermanagement kext does not do anything in that regard.

If you want to fix gaming performance you have to switch the last two kernel patches. Disable the kernel patch algrey - mtrr_update_action - fix PAT and enable in turn the kernel patch Shaneee - mtrr_update_action - fix PAT.

If you are not very confident about doing that I'd recommend to first test the new config with an USB stick.
 

Plig88

New member
Joined
Feb 15, 2021
Messages
10
The AMD Ryzen Powermanagement kext does not do anything in that regard.

If you want to fix gaming performance you have to switch the last two kernel patches. Disable the kernel patch algrey - mtrr_update_action - fix PAT and enable in turn the kernel patch Shaneee - mtrr_update_action - fix PAT.

If you are not very confident about doing that I'd recommend to first test the new config with an USB stick.
How and from where I disable the kernel patch ? Thank you
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
565
Those are the patches you had to add to your config.plist when you built your EFI.
 

Plig88

New member
Joined
Feb 15, 2021
Messages
10
Those are the patches you had to add to your config.plist when you built your EFI.
The bootable usb I just make restore from file of xlnc.. so I don’t build it and I don’t know ...so I open the config.plist with clover configurator and disable the patches ?
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
766
Clover isn't supported nor is it propperly updated for out patches. Your install method also isn't supported.
The high CPU usage could be from the config being configured wrong or from Spotlight scanning your drives.

Also don't use my PAT patch as you've got a Nvidia GPU, it doesn't work for them.
 

Plig88

New member
Joined
Feb 15, 2021
Messages
10
Soo guys . I install Catalina 10.15.7 via opencore ...I found a easy guide and I make it fast and very easy ( for me ) ..everything work fine ,and I make direct update supemendal ( or something like that )from Mac .. but I have I question . I have amd ryzen 2700x but my Catalina on about this Mac say the cpu is Intel i5 8 cores .... it’s normal right ?

 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
766
Yes that's normal. macOS doesn't have the strings for AMD as they don't use them. It's purely cosmetic. If you run sysctl -a machdep.cpu.brand_string in Terminal you'll see your AMD CPU, for example here's mine,

Code:
[email protected] ~ % sysctl -a machdep.cpu.brand_string
machdep.cpu.brand_string: AMD Ryzen 5 5600X 6-Core Processor
 

Plig88

New member
Joined
Feb 15, 2021
Messages
10
Yes that's normal. macOS doesn't have the strings for AMD as they don't use them. It's purely cosmetic. If you run sysctl -a machdep.cpu.brand_string in Terminal you'll see your AMD CPU, for example here's mine,

Code:
[email protected] ~ % sysctl -a machdep.cpu.brand_string
machdep.cpu.brand_string: AMD Ryzen 5 5600X 6-Core Processor
Ohh thank you for that ... something last for gaming performance , I will try to do this .. I will disable -algrey - mtrr_update_action - fix PAT -... and I will disable it with proper tree ... but in config plist I don’t find a Shaneee - mtrr_update_action - fix PAT...... what can I do ?
 
Last edited:

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
766
Ohh thank you for that ... something last for gaming performance , I will try to do this .. I will disable -algrey - mtrr_update_action - fix PAT -... and I will disable it with proper tree ... but in config plist I don’t find a Shaneee - mtrr_update_action - fix PAT...... what can I do ?
Update your patches from GitHub and you’ll find it.
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
766
Download the patches.plist and open it with a plist editor. Along side it open your config. In your config delete Kernel -> Patches and then copy Kernel -> Patches from the downloaded patches.plist into your config under Kernel.
 

Plig88

New member
Joined
Feb 15, 2021
Messages
10
Download the patches.plist and open it with a plist editor. Along side it open your config. In your config delete Kernel -> Patches and then copy Kernel -> Patches from the downloaded patches.plist into your config under Kernel.
mmm its kind of easy this .. I make with txt edit. and enable/ disable the plist on proper tree....so I'm right?
 

Attachments

  • Screenshot 2021-02-19 at 3.07.21 PM.png
    Screenshot 2021-02-19 at 3.07.21 PM.png
    108.9 KB · Views: 5

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
766
No. The key stays as Enabled. You need to change the Value from True to False.
 

Plig88

New member
Joined
Feb 15, 2021
Messages
10
No. The key stays as Enabled. You need to change the Value from True to False.
thank you thank you thank you Shaneee!!!! you make my day... its worked!!!!!! my graphics run with high fps... than you again!!!!!
 
Top Bottom