Solved Help to switch from big-sur 11.1 to 11.6

glvercellone

New member
Joined
Jul 6, 2020
Messages
23
Hi everyone, I state that I am using Open Core 6.3.
I tried to update from BigSur 11.1 to 11.6 but the system hangs on reboot to upgrade.

At this point, I tried to install OC 0.7.4, but even in this way, the Update operation did not give a positive result.

I attach my EFI-OC.6.3 directory which contains all the working drivers for my computer.

Thank you to give me a hand.

Best regards!
 

Attachments

  • EFI.zip
    29.9 MB · Views: 5

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,422
Here you go. Updated to 0.7.4 and acidanthera kexts updated. Test it on a USB device first just to check.
 

Attachments

  • EFI.zip
    26 MB · Views: 11

glvercellone

New member
Joined
Jul 6, 2020
Messages
23
First of all, thanks for your reply! I saved the EFI in the USB and started it. Unfortunately, the startup didn't start!
I tried with the MACOS upgrade partition
I tried with MACOS 11.1 (the partition that booted smoothly with the old EFI).

I didn't see any differences from the 2 partitions!
Below you find the verbose-boot screen attached, I hope this helps you to show me a solution.

An error also appears when starting the OC menu from USB:
OCS: No schema for ResizeAppleGpuBars at 16 index, context <Quirks>!
Serialisation returns 1 error!





Best regards

 
Last edited:

Tora3

New member
Joined
Oct 25, 2021
Messages
2
Just the same problem with glvercellone.
According to other discussion, this may be useful. I will try this when I get home.

 
Last edited:

glvercellone

New member
Joined
Jul 6, 2020
Messages
23
Hi I checked and the EFI prepared by Shaneee contains a perfect config.plist in the parameters of my CPU as recommended by the suggested link: https://github.com/AMD-OSX/AMD_Vanilla.
The patch and parameter are aligned with the latest version of the hint in the link.
However, the system does not boot on boot!

Now I try to create a new USB stick with Monterey to the latest version which was released yesterday and after we will inform you about the results!

Create USB With Mac OS 12.0 MONTEREY
Injected in EFI partition OC 0.7.4 prepared from Shaneee.
Restarted from USB -KEy and the system blocking exactly like the BigusSur 11.6 .0 .
I Restarted the system with 11.1 & OC 0.6.3

Please some Idea?
 
Last edited:

Tora3

New member
Joined
Oct 25, 2021
Messages
2
I can also boot with 11.1 but can't boot with 11.6.
I followed the Shaneee's guide.
I could see the Opencore choosing screen(Windows, Install Mac OS Big Sur).
When I click "Install Mac OS Big Sur", it says
"your computer restarted because of a problem".
After that the computer restarts.
I wonder what should I do.
Some idea please.
 

glvercellone

New member
Joined
Jul 6, 2020
Messages
23
Solved the problem.
I'm restart from 0 with the config.plist.
I used it as a base the configuration found at this link: https://forum.amd-osx.com/index.php...ig-sur-monterey-beta-opencore-0-7-4-efi.1344/

I just updated some driver / kext and modify the number of the core in the config.plist kernel/patch (my CPU is 8 core) and finally all is started (we have only a problem with the wifi....).

Thank you all!

P.s. I changed the signature, now I'm on Monterey 12.0.1
 
Top Bottom