Help OCS: No Schema

thepensivemonk

New member
Jul 23, 2020
5
0
1
Hi, thanks for your response. Tried that site but still the issue persists. I instead recreated my opencore efi using the release version and its now solved.
Probably the best way to go. I ran into this upgrading OpenCore from 0.5.7 to 0.5.9. For several sections in the config, the term "Block" was renamed to "Delete" to make it more consistent with the term "Add" (I assume). So, for others getting this schema error and you want to save a lot of time troubleshooting your config, rebuilding from the sample config will save you a lot of time.

pm
 

5T33Z0

New member
May 12, 2020
7
1
3
Well, in OpenCore development Features are added, some are deleted and some are renamed. Since 0.5.9, the Term "Block" has been Changed to "Delete". So you need to rename that in the config under DeviceProperties.

A good practise for updating OpenCore is:

1. Download latest Release of OC Package
2. Replace BOOTx64.efi, Bootstrap.efi, the Drivers you use and OpenCore.efi files in EFI
3. Download OCConfigCompare
4. RunOCConfigCompare, Press 3 and drag in the sample.config form OC package. Next, press 4 then drag in your config from your EFI Partition and return. Press 5 to compare.
5. Add/correct/rename all the missing/wrong entries in your config, save and compare again hitting 5 until nothing is missing

You need to do this with every update. It's also good practise to have a look at the changelog each time and look for terms like "Added" "Renamed" "Deleted" or "changed". If theese appear you may have to reflect these changes in the config probably.

OT: Do you know anybody in here using his AMD built for music production?
 
Last edited: