Help finalising installation

Darkpulse

New member
Joined
Jan 9, 2022
Messages
8
Hi hackintosh lords !
I'm here to looking for help to finish my first Ryzentosh.
Until now I based myself from the AudioGod's guide, but I think now I need a little bit help.
This is not exactly the same board, I got a Gigabyte X570S PRO AX who has small differences.
The main issue I had was to get network access because this is a different Ethernet controller on mine, but after removing the kext from the EFI and add the dk.e1000=0 argument, this problem was solved.

But now, I can't finish properly the configuration, everything is working well except :
  • Wifi
  • Bluetooth
  • Fan control ( I've got the temps form the sensors kext but AMD PowerTool says there is a probleme to have access to the fan control )
  • USB Mapping

Also I think I got really mixed up with USB Mapping ( this is maybe the reason why I can't get Wifi or Bluetooth ), I tried to do it with Hackintool application but honestly, I think I had difficulties to understand cleary what I have to do ( event with the Dortania official guide ).
If someone would like to enlighten me, or at least have some ideas for my last issues.
Thanks.

PS: I attached my EFI file in case of someone want to take a look and see what mistakes I have done :eek:
 

Attachments

  • EFI_077.zip
    24 MB · Views: 3

Darkpulse

New member
Joined
Jan 9, 2022
Messages
8
Hi Shanee, thanks for your reply.
I finally finished my USB Mapping, and still no wifi and BT. But I noticed this is a new wireless chip on my board, WiFi and BT are in the AMD Wi-Fi 6E RZ608 (MT7921K).
I'm affraid there is for now, no solution for me, this motherboard is pretty new.
About the fan control, I don't understand, why AMD PowerTool had this option ? I'm pretty sure I've seen some screenshot where people have control of their fan with this tool...🧐
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,851
It does but it doesn't work on all chips and doesn't save after reboot. Setting a curve in the BIOS is a much better option.
 

Darkpulse

New member
Joined
Jan 9, 2022
Messages
8
Strange fact, since I've updated to Monterey a Bluetooth device appears in macOS ( but I can't enable it ).
Is it a good sign ? At this point do you have any advise to make it work ?

 

Darkpulse

New member
Joined
Jan 9, 2022
Messages
8
Yes I've already tried.

These kexts doesn't change anything, I can't enable bluetooth. But the side effect, when I use these kexts, system is not stable, mouse cursor is laggy etc...
I will investigate
 

Edhawk

Active member
Joined
May 2, 2020
Messages
686
Normally the X570S Aorus Pro AX MB comes fitted with an Intel Wi-Fi 6 AX200 WiFi/BT card - https://www.gigabyte.com/Motherboard/X570S-AORUS-PRO-AX-rev-10/sp#sp

The AMD Wi-Fi 6E RZ608 WiFi/BT module is a rebranded MediaTek MT7921K module (with an AMD logo on it). The MediaTek module is not supported in macOS. so while the system recognises there is a module present, there are no drivers/kexts that can be injected or loaded for this device, well not that I am aware of.

You probably need to remove the AMD WiFi card and replace it with an Intel or Apple Broadcom WiFi/BT card. As you don't want the system clashing because you have two WiFi/BT cards installed.
 
Top Bottom