Help! about MSI GODLIKE's sleep completion strategy

  • Hello Guest. Before you post check the Troubleshooting guide here, https://dortania.github.io/OpenCore-Desktop-Guide/troubleshooting/troubleshooting.html

zhaohuan325

New member
May 2, 2020
5
0
1
CPU: 3950X
Motherboard: MIS GODLIKE
Graphics card: vega64
Radiator: NZXT X73

My current EFI can basically do all the work except sleep! I am very eager to have it,
I haven't succeeded in researching for 2 months, I can't ask you to help me, thank you very much!
I'm sorry for my poor English grammar.
 

zhaohuan325

New member
May 2, 2020
5
0
1
There are very different ways sleep can be broken, please be specific.
First of all, thank you very much for replying to me.

After I clicked the sleep button, the monitor, keyboard, and mouse all turned off, but the chassis light did not turn off, and the fan continued to rotate. Now I can only turn off the computer and restart by pressing and holding the power button.

I will fully cooperate with you for any data or related settings that I need to provide. Thanks again。
 

Aluveitie

Member
May 2, 2020
111
18
18
Usually this means something is blocking Mac OS from entering sleep. Did you wait for 3 Minutes before turning off? It should automatically restart after that and show you a panic report.

You can then also check the logs with pmset -g log and check on sleep with pmset -g assertions.
Also, it might be helpful if you could post the results of pmset -g.
 

zhaohuan325

New member
May 2, 2020
5
0
1
Usually this means something is blocking Mac OS from entering sleep. Did you wait for 3 Minutes before turning off? It should automatically restart after that and show you a panic report.

You can then also check the logs with pmset -g log and check on sleep with pmset -g assertions.
Also, it might be helpful if you could post the results of pmset -g.
Yes, after waiting for about 3 minutes, it will automatically restart and provide an error report. The following is the report content

panic(cpu 0 caller 0xffffff8016291b2c): Sleep transition timed out after 180 seconds while calling power state change callbacks. Suspected bundle: com.apple.iokit.IOUSBHostFamily. Thread 0x14a39.
Failure code:: 0x00000048 00000014

Backtracing specified thread
Backtrace (CPU 0), Frame : Return Address
0xffffff83b88ab900 : 0xffffff8015c17d82
0xffffff83d20d3840 : 0xffffff8015c17568
0xffffff83d20d3860 : 0xffffff8015b39139
0xffffff83d20d3950 : 0xffffff80161f48c0
0xffffff83d20d3b00 : 0xffffff7f9690ec3c
0xffffff83d20d3c80 : 0xffffff7f973f5890
0xffffff83d20d3cf0 : 0xffffff7f97518c50
0xffffff83d20d3d40 : 0xffffff7f9690d859
0xffffff83d20d3da0 : 0xffffff8016230048
0xffffff83d20d3e00 : 0xffffff7f9690d529
0xffffff83d20d3e30 : 0xffffff8016214e04
0xffffff83d20d3ea0 : 0xffffff8016214c0a
0xffffff83d20d3ec0 : 0xffffff8015b63545
0xffffff83d20d3f40 : 0xffffff8015b63071
0xffffff83d20d3fa0 : 0xffffff8015ac713e
Kernel Extensions in backtrace:
com.apple.iokit.IOUSBHostFamily(1.2)[CC813BD5-B83C-3B83-A95E-796D87DE8F81]@0xffffff7f968f9000->0xffffff7f969f2fff
dependency: com.apple.driver.AppleBusPowerController(1.0)[DEBDD821-1472-371A-896A-BC5C19BD76D0]@0xffffff7f968df000
dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[A9FB7951-7658-34C4-9A44-0B6DBE6F7F78]@0xffffff7f968e7000
dependency: com.apple.driver.AppleUSBHostMergeProperties(1.2)[19CEF2B0-63C1-34CC-A9CD-BDF842BE5CB3]@0xffffff7f968f5000
com.apple.driver.usb.AppleUSBXHCI(1.2)[08964881-BCC5-3A07-B3CA-DF5B3512B740]@0xffffff7f973e1000->0xffffff7f97438fff
dependency: com.apple.iokit.IOACPIFamily(1.4)[9D1FF279-C4A2-3344-902F-E0B22B508689]@0xffffff7f968ac000
dependency: com.apple.iokit.IOUSBHostFamily(1.2)[CC813BD5-B83C-3B83-A95E-796D87DE8F81]@0xffffff7f968f9000
dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[A9FB7951-7658-34C4-9A44-0B6DBE6F7F78]@0xffffff7f968e7000
com.apple.driver.usb.AppleUSBXHCIPCI(1.2)[5B0343A2-9C4B-3A81-81C3-03601B394CED]@0xffffff7f97510000->0xffffff7f97544fff
dependency: com.apple.iokit.IOACPIFamily(1.4)[9D1FF279-C4A2-3344-902F-E0B22B508689]@0xffffff7f968ac000
dependency: com.apple.iokit.IOPCIFamily(2.9)[1B1F3BBB-9212-3CF9-94F8-8FEF0D3ACEC4]@0xffffff7f96531000
dependency: com.apple.iokit.IOUSBHostFamily(1.2)[CC813BD5-B83C-3B83-A95E-796D87DE8F81]@0xffffff7f968f9000
dependency: com.apple.driver.usb.AppleUSBCommon(1.0)[A9FB7951-7658-34C4-9A44-0B6DBE6F7F78]@0xffffff7f968e7000
dependency: com.apple.driver.usb.AppleUSBXHCI(1.2)[08964881-BCC5-3A07-B3CA-DF5B3512B740]@0xffffff7f973e1000

BSD process name corresponding to current thread: kernel_task
Boot args: darkwake=8

Mac OS version:
19E287

Kernel version:
Darwin Kernel Version 19.4.0: Wed Mar 4 22:28:40 PST 2020; root:xnu-6153.101.6~15/RELEASE_X86_64
Kernel UUID: AB0AA7EE-3D03-3C21-91AD-5719D79D7AF6
Kernel slide: 0x0000000015800000
Kernel text base: 0xffffff8015a00000
__HIB text base: 0xffffff8015900000
System model name: iMacPro1,1 (Mac-7BA5B2D9E42DDD94)
System shutdown begun: NO
Panic diags file available: NO (0xe00002bc)

System uptime in nanoseconds: 8183396886142
 

zhaohuan325

New member
May 2, 2020
5
0
1
Usually this means something is blocking Mac OS from entering sleep. Did you wait for 3 Minutes before turning off? It should automatically restart after that and show you a panic report.

You can then also check the logs with pmset -g log and check on sleep with pmset -g assertions.
Also, it might be helpful if you could post the results of pmset -g.

pmset -g assertions
2020-05-20 22:47:53 +0800
Assertion status system-wide:
BackgroundTask 0
ApplePushServiceTask 0
UserIsActive 1
PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
ExternalMedia 0
InternalPreventDisplaySleep 1
PreventUserIdleSystemSleep 1
NetworkClientActive 0
Listed by owning process:
pid 420(sharingd): [0x0000005100018287] 00:02:36 PreventUserIdleSystemSleep named: "Handoff"
pid 374(UserEventAgent): [0x00000078000b82d8] 00:01:57 BackgroundTask named: "com.apple.SafariBookmarksSyncAgent.XPC.ZoneSubscriptionRegistration"
Created for PID: 781.
pid 73(powerd): [0x0000000300108003] 00:02:34 InternalPreventDisplaySleep named: "com.apple.powermanagement.delayDisplayOff"
Timeout will fire in 145 secs Action=TimeoutActionTurnOff
pid 446(useractivityd): [0x000000e9000182f2] 00:00:03 PreventUserIdleSystemSleep named: "BTLEAdvertisement"
Timeout will fire in 56 secs Action=TimeoutActionTurnOff
pid 120(hidd): [0x0000003600098206] 00:00:00 UserIsActive named: "com.apple.iohideventsystem.queue.tickle serviceID:1000005e1 name:AppleUserHIDEventSe product:Varmilo Keyboard eventType:3"
Kernel Assertions: 0x4=USB
id=500 level=255 0x4=USB mod=1970/1/1 08:00 description=com.apple.usb.externaldevice.60200000 owner=USB Receiver
id=502 level=255 0x4=USB mod=1970/1/1 08:00 description=com.apple.usb.externaldevice.20700000 owner=USB3.1 Hub
id=504 level=255 0x4=USB mod=1970/1/1 08:00 description=com.apple.usb.externaldevice.20100000 owner=USB2.0 Hub
id=506 level=255 0x4=USB mod=1970/1/1 08:00 description=com.apple.usb.externaldevice.60100000 owner=Varmilo Keyboard
id=508 level=255 0x4=USB mod=1970/1/1 08:00 description=com.apple.usb.externaldevice.20140000 owner=USB Device
id=509 level=255 0x4=USB mod=1970/1/1 08:00 description=com.apple.usb.externaldevice.20400000 owner=Bluetooth USB Host Controller
id=510 level=255 0x4=USB mod=1970/1/1 08:00 description=com.apple.usb.externaldevice.20120000 owner=2.4G Keyboard Mouse
Idle sleep preventers: IODisplayWrangler
 

Aluveitie

Member
May 2, 2020
111
18
18
Looks like one of your USB devices is blocking sleep. Try entering sleep without any devices except a simple keyboard or mouse (RGB keyboards/mice can also be an issue do to integrated controllers)
 

ravenas

New member
May 6, 2020
12
1
3
Looks like one of your USB devices is blocking sleep. Try entering sleep without any devices except a simple keyboard or mouse (RGB keyboards/mice can also be an issue do to integrated controllers)
I have the same problem with 3950X, but my mobo is the MSI X570 MEG ACE. I have unplugged all USBs, and still experience the same problem.
 

Aluveitie

Member
May 2, 2020
111
18
18
Remove the port from your USB mapping and SSDT to deactivate it, if you're using it you could also try to disable wake for Bluetooth devices (Under Advanced last checkbox in Bluetooth settings).
 

ravenas

New member
May 6, 2020
12
1
3
Remove the port from your USB mapping and SSDT to deactivate it, if you're using it you could also try to disable wake for Bluetooth devices (Under Advanced last checkbox in Bluetooth settings).
I didn't map USB and SSDT. I picked up a SSDT for X570 mobos.
 

Aluveitie

Member
May 2, 2020
111
18
18
That alone works but is not enough. You need to create the USBPorts.kext with the Hackintool to get USB to work properly.