Hard Drive EFI Appears Empty but Catalina boots from it fine!

vanquish

Member
Joined
Nov 14, 2020
Messages
94
As some of you will know, I have been trying to get Wifi and Bluetooth working on my B450 I Pro Wifi board. In order to do this, I need to add some files to the EFI and update the config.plist however, on mounting the EFI there is no Boot or OC folders within it. I don't understand how this can be. I have mounted this EFI many times before and it was fine. Also if I try to mount the EFI from my second driver (clone of the boot drive) I don't see the mounted EFI on the desktop.

The problems began yesterday when I was using the cloned second drive. I could not access my boot drive because I had updated the EFI to work with an A520 motherboard. That didn't work but I have discussed that in another thread so won't go into it here.

Yesterday when I tried to update the EFI so I could get the WiFi working, I could mount it but when I deleted the existing files and then tried to past in the amended Boot and OC folders I kept getting a message that the files were too large! I have never seen that before and the files were the same size as the ones I was replacing.

I decided to restore the cloned drive to my main boot drive, which was fine and I was able to boot normally but now, as mentioned, if I mount the EFI for the main drive, the folder is empty. I did think that maybe somehow I had system files hidden but that was not the case. I just cannot see the Boot and OC folders.

If I mount the EFI from the boot drive and check its info there are obviously files in there. Although I am not sure why it seems to be formatted as MS DOS FAT32. Is that correct?




So any ideas as to what might be going on here? It seems that every time I try and do something I go one step forward and ten steps back :(
 
Top Bottom