Gigabyte X570 Aorus Master AMD 3950 OPencore 0.5.8 Catalina 10.15.5

ngocrebel

New member
May 17, 2020
2
4
3
System:

Motherboard: Gigabyte Aorus Master
CPU: AMD 3950X
AGP: Radeon Pro WX7100
RAM: 64GB Timetec Hynix CJR 3600Mhx (after returned 4 OCZ kits which is more expensive)
SDD: 3 x 1TB WD Black SN750 (1 for Mac, 1 Windows and 1 for Data)
WIfi & Bluetooth: Fenvi T919

Opencore 0.5.8, with OPenCanopy enabled, SMBIOS MacPro 7,1
After months using EFI shared from member which worked but hick up here and there. Finally I can build one myself follow the guide here: https://dortania.github.io/OpenCore-Desktop-Guide/AMD/zen.html

Work:
Audio work
Intel Gb NIC work
I disable built in bluetooth for Fenvi card work
Computer run smooth

Not work:
Sleep
Realtek 2.5Gb does not work even though the correct kext was used.

Overclock all core 4.3Ghz, IF 1867Mhz, RAM 3733Mhz @ 16,21,21,38 which much tighter than spec.
Cinebench R20 10100++ Which is little higher than when running Windows
Geekbench 5 single core same as Windows at around 1290 but multi core is >1500 point lower than Windows
Mac: https://browser.geekbench.com/v5/cpu/2189257
Win: https://browser.geekbench.com/v5/cpu/1312960

Attached EFI with flushed SMBIOS and resource folder removed. AMD Power Gadget ready, you just need download the app and run.

BIOS setting:
Fastboot: Disable
Above 4G decoding : Enable
CSM: Disable

I maybe forgot few thing
Fell free to ask questionRyzentosh.png
 

Attachments

Last edited:
  • Like
Reactions: AMDPUSH and Hummer

barrrrt

New member
May 19, 2020
29
5
3
When you use Miezes Kext for the 2.5 Gbit Lan Adapter, select manually 100Mbit first.
Acknowledge everything, then the Ethernet Adapter turns green.
When this works you can switch the Speed to 1000baseT. Acknowledge everything again.. Adapter stays green.

1591299670983.png
1591299530760.png
 

iamso78

New member
May 12, 2020
21
5
3
With Above 4G decoding : Enable

any1 else having pc wont shutdown under Win10? BIOS F20a here, havent check older BIOS.