Fix CPU Name with RestrictEvents

semimetallic

New member
Joined
Sep 7, 2021
Messages
2
Thanks for this thread. I have a 3600X in a B550 Aorus Master. One of the most stable machines I've ever had, running Big Sur. I didn't read all the way through this thread before putting a revcpu property in config.plist, or changing ProcessorType, and added a revcpuname string of "AMD Ryzen 5 3600X 3.8 GHz 6-Core Processor". Now, no matter what I change it too, it seems that this is what it says. Does it write this out to the filesystem somewhere that I could clear out?

machdep has a different variant:
Code:
machdep.cpu.brand: 0
machdep.cpu.brand_string: AMD Ryzen 5 3600XT 6-Core Processor
machdep.cpu.core_count: 6
machdep.cpu.cores_per_package: 6
 

Attachments

  • CleanShot 2021-09-07 at 14.09.27.png
    CleanShot 2021-09-07 at 14.09.27.png
    88.5 KB · Views: 10

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,419
Thanks for this thread. I have a 3600X in a B550 Aorus Master. One of the most stable machines I've ever had, running Big Sur. I didn't read all the way through this thread before putting a revcpu property in config.plist, or changing ProcessorType, and added a revcpuname string of "AMD Ryzen 5 3600X 3.8 GHz 6-Core Processor". Now, no matter what I change it too, it seems that this is what it says. Does it write this out to the filesystem somewhere that I could clear out?

machdep has a different variant:
Code:
machdep.cpu.brand: 0
machdep.cpu.brand_string: AMD Ryzen 5 3600XT 6-Core Processor
machdep.cpu.core_count: 6
machdep.cpu.cores_per_package: 6

Clear the NVRAM from the OpenCore boot picker. Should update it if you've changed it.
 

savage001

Active member
Joined
Jun 4, 2020
Messages
156
I just got a new CPU and GPU and now my CPU name will not show up.
I have a R9 5900X.
I have CPU type set to 0.
Screen Shot 2021-11-07 at 10.19.41 pm.png
Screen Shot 2021-11-07 at 10.21.59 pm.png
With the previous CPU setting the same value to 1537 worked before.
Besides 0 what other value is used for 12 cores?

EDIT:
I updated my kexts and changed CPU Type and its working now.
Screen Shot 2021-11-07 at 10.43.31 pm.png
Screen Shot 2021-11-07 at 10.44.08 pm.png
 
Last edited:
Top Bottom