Fix CPU Name with RestrictEvents

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
alright! will do, Ive tested a few things, I haven't gotten to usb map yet, however it appears putting the bluetooth firmware as higher priority on open core makes it work
Ah ok so thats no big deal then. 👍
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
after a few restarts that work around seems to only work sometimes. not 100% sure how often but less than 50%
If it’s not perfect then for sure report it.
Theres a link to the Bug report a few posts up.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
@Shaneee if he is then would that mean 1537 relates to the 5600X only? (No it can’t be thinking about it, must be an older version of the kext)
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,419
I don't think so. OpenCore sets two CPU types for AMD by default, Xeon W for 8 cores or more and the i5 for less. Without seeing the Lilu debug to see what the kext is trying to replace can't say for sure it would be the same CPU type to replace.

C++:
  if (Cpu->ThreadCount >= 8) {
    Cpu->AppleProcessorType = AppleProcessorTypeXeonW;
  } else {
    Cpu->AppleProcessorType = AppleProcessorTypeCorei5Type5;
  }
 

savage001

Active member
Joined
Jun 4, 2020
Messages
156
I’ve got the latest 1.0.2 and I see unknown on my ryzen 5 3500. What do I need to put in cpu type? 1537?


Sent from my iPhone using Tapatalk
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,419
I’ve got the latest 1.0.2 and I see unknown on my ryzen 5 3500. What do I need to put in cpu type? 1537?


Sent from my iPhone using Tapatalk

It's within the PlatformInfo > Generic section of your config.
 

savage001

Active member
Joined
Jun 4, 2020
Messages
156
It's within the PlatformInfo > Generic section of your config.

Yeah I know where to put it I was just confirming what to put in there for my cpu to display properly. Thanks.


Sent from my iPhone using Tapatalk
 

AMDPUSH

Donator
Donator
Joined
May 2, 2020
Messages
178
I don't see where i made a mistake
i am on an external SSD with bigsur 11.3.1
 

Attachments

  • Screen Shot 2021-05-05 at 09.56.50.png
    Screen Shot 2021-05-05 at 09.56.50.png
    6.5 KB · Views: 15
  • Screen Shot 2021-05-05 at 09.57.28.png
    Screen Shot 2021-05-05 at 09.57.28.png
    13 KB · Views: 15
  • Screen Shot 2021-05-05 at 10.00.57.png
    Screen Shot 2021-05-05 at 10.00.57.png
    73.1 KB · Views: 15

savage001

Active member
Joined
Jun 4, 2020
Messages
156
I don't see where i made a mistake
i am on an external SSD with bigsur 11.3.1

Where is that folder located? You only need the .kext inside your kext folder in your EFI directory and make sure it’s added to your config.plist.


Sent from my iPhone using Tapatalk
 
Top Bottom