Fix CPU Name with RestrictEvents

Moozuki

Member
Joined
May 3, 2020
Messages
95
Added kext to config.plist, no boot args used, OC 0.6.8.




Doesn't look like I can help you shed some light on why it doesn't work for you guys.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Added kext to config.plist, no boot args used, OC 0.6.8.




Doesn't look like I can help you shed some light on why it doesn't work for you guys.
Thanks for trying and Don’t worry buddy vit is trying to get to the bottom of it, Hopefully he will find the problem and fix it soon.
So far he’s discovered that RestrictEvents is seeing my 5900x as a 2 core CPU 😂
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,412
So far he’s discovered that RestrictEvents is seeing my 5900x as a 2 core CPU 😂

Based on your latest log it's now a 24 core lol

Code:
RestrictEvents       rev: @ (DBG) chosen -Core Intel Xeon W patch for 24 core CPU
 

RyzeCooker

Donator
Donator
Joined
May 3, 2020
Messages
199
I gave it a whirl while upgrading my OpenCore setup, but it still says "3,6 GHz 8-Core Intel Xeon W". I didn't add any boot arguments (used the kext Aluveitie linked). Oh well.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,412
I gave it a whirl while upgrading my OpenCore setup, but it still says "3,6 GHz 8-Core Intel Xeon W". I didn't add any boot arguments (used the kext Aluveitie linked). Oh well.

Try adding revcpu=1 and see.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
@Shaneee Ok so it’s 100% not a EFI related problem kind of thing as somebody else using my new X570-E 0.6.9 EFI posted screenshots and there CPU (5800X) is listed correctly. Looks like it’s a 6 and 12 core problem
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
@RyzeCooker Some models of Ryzen CPUs work and some don’t, That’s what it looks like to me and if you also go by the error showing in my lilu logs.
 

RyzeCooker

Donator
Donator
Joined
May 3, 2020
Messages
199
@RyzeCooker Some models of Ryzen CPUs work and some don’t, That’s what it looks like to me and if you also go by the error showing in my lilu logs.

Maybe I'm out of luck with the 3700X series? ¯\(ツ)/¯ But this kext is in more active development than the one-trick-pony MacProMemoryNotificationDisabler.kext I was using up till now, right? So who knows, somewhere down the line...
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Maybe I'm out of luck with the 3700X series? ¯\(ツ)/¯ But this kext is in more active development than the one-trick-pony MacProMemoryNotificationDisabler.kext I was using up till now, right? So who knows, somewhere down the line...
Try the latest version Bud.
Its now working for me.
 

Attachments

  • RestrictEvents-1.zip
    106.5 KB · Views: 85

RyzeCooker

Donator
Donator
Joined
May 3, 2020
Messages
199
Try the latest version Bud.
Its now working for me.

Whoo! It's working for me too! With your help with the boot issue I had a while ago - fixed by going back to HfsPlus.efi - you are fast becoming my EFI mechanic! ;) Thanks so much!
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,412
Lucky for some :ROFLMAO: It doesn't seem to like mine showing as Unknown...

Edit: There we go :D As my CPU was "Unknown" I just used the ProcessorType in OC to change it to what the kext was trying to replace.

 
Last edited:

jumper775

New member
Joined
Oct 29, 2020
Messages
3
i've noticed that that kext stops intelbluetoothinjector from enabling the intel bluetooth drivers. so there are some incompatabilities.

I have not done a usb map yet though as my motherboard seems to work just fine for all my uses without it. my bt does interface with usb so ill give that a shot.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
i've noticed that that kext stops intelbluetoothinjector from enabling the intel bluetooth drivers. so there are some incompatabilities.
Jump on to the bug report and reported that to vit please bud.
 
Last edited:

jumper775

New member
Joined
Oct 29, 2020
Messages
3
alright! will do, Ive tested a few things, I haven't gotten to usb map yet, however it appears putting the bluetooth firmware as higher priority on open core makes it work
 
Top Bottom