Fix CPU Name with RestrictEvents

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
599
You did use the snapshot build right?
 

Attachments

  • RestrictEvents-1.0.1-RELEASE.zip
    99.6 KB · Views: 8

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
599
A build of a commit that has not been released as a new version is usually called a snapshot.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
595
A build of a commit that has not been released as a new version is usually called a snapshot.
ok I understand now 👍
well that’s not it.
Are you using the latest snapshot (😂) of Lilu or anything else By any chance?
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
599
Lilu release of last month.

Do you have ProcessorType set to 0?
 
Last edited:

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
595
Il double check that in a moment but yeah I think it’s set to 0
me and shaneee are both using a 5000 series and you a 3000, This is the only thing I can think of that’s separating us 3.
i think maybe it’s time for me to speek to VIT or Fritz and ask them but I better make sure I’ve exhausted every Avenue before I do or I will get told off by them for being dumb 😂😂😂😂
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
853
I had it set to 0 and it was showing unknown. I even tried updating OC to the latest git and. I change. Tried added the force name arg as well with just =AMD without luck.
I’ll dive into the code and see if anything sticks out later on unless someone beats me to it lol
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
595
I had it set to 0 and it was showing unknown. I even tried updating OC to the latest git and. I change. Tried added the force name arg as well with just =AMD without luck.
I’ll dive into the code and see if anything sticks out later on unless someone beats me to it lol
We are both on it like a car bonnet 😂
Do you dare asking Vit about it? I’m scared too cos he gets so angry so fast…lolol
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
853
No idea why it's not working. @AudioGod what does macOS report your CPU as? If it's Unknown as well that may be the issue.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
595
@Shaneee My system is reporting my 5900x as a 12 core Intel
1619961891668.png
Im totally stumped over this one, I can’t even find anybody having the same problem as us. Like I said before it’s very frustrating and I won’t rest until I find out why. I bet it’s something really silly too. Gggrrrrrrr

Could this have something to do with it possibly?

Note: Apple CPU identifier must be <0F01> for 8 core CPUs or higher and <0601> for 2, 4, or 6 cores. This is the default in OpenCore for non-natively supported CPUs.
 

lukakeiton

New member
Joined
Jul 26, 2020
Messages
17
@Shaneee My system is reporting my 5900x as a 12 core Intel
View attachment 3008
Im totally stumped over this one, I can’t even find anybody having the same problem as us. Like I said before it’s very frustrating and I won’t rest until I find out why. I bet it’s something really silly too. Gggrrrrrrr

Could this have something to do with it possibly?

Note: Apple CPU identifier must be <0F01> for 8 core CPUs or higher and <0601> for 2, 4, or 6 cores. This is the default in OpenCore for non-natively supported CPUs.
I have the same problem! lol Not sure if celebrate or not... xD Even removing the code's part of recognizing CPUID (ProcessorType has no effect) is not working... Maybe SMCAMDProcessor.kext is the guilty
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
853
I have the same problem! lol Not sure if celebrate or not... xD Even removing the code's part of recognizing CPUID (ProcessorType has no effect) is not working... Maybe SMCAMDProcessor.kext is the guilty

Nope I’ve tried with SMCAMDProcessor disabled.
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
599
There was a fix on the kext. Though it should only make the explicit boot arg obsolete, maybe it also fixes your issues: RELEASE
 
Top Bottom