FIRST HACKINTOSH - Msi MPG B550 Gaming EDGE Wifi / RYZEN 3700x

spiderpork

New member
Joined
Jul 29, 2021
Messages
4
Hi!

my first hackintosh (dual boot with windows 10 pro) any suggestion for the Bluetooth or audio fix is welcome :)


Build Spec:

  • Cpu: AMD Ryzen 7 3700X 8-Core Processor
  • Motherboard: Msi MPG B550 Gaming EDGE Wifi
  • Ram: Corsair Vengeance 16gb 3000Mhz
  • Gpu: AMD Radeon RX 580 8GB
  • Case: Corsair iCUE 4000X
  • Nvme: Silicon Power PCIe M.2 NVMe SSD 512GB
  • SSD: Western Digital WD Green 1tb
  • WiFi-Bluetooth: Intel Wi-Fi 6 AX200
  • Sound: RealTek ALCS1200A
  • Operating Systems: Big Sur 11.5.1, Windows 10 Pro
  • Bootloader: OpenCore 0.7.1
  • SMBios: iMac Pro 1,1

ACPI:
  • SSDT-CPUR.aml
  • SSDT-EC-USBX-DESKTOP.aml

Kext:

  • AppleALC
  • AirportItlwm
  • AMDRyzenCPUPowerManagement
  • Lilu
  • lucyRTL8125Ethernet
  • virualSMC
  • WhateverGreen

bot-args: -v keepsyms=1 debug=0x100 alcid=11

What works:
Sound via HDMI
Ethernet
WiFi / Bluetooth
USB Type C, 3.0
Hardware Acceleration
AirDrop
iCloud / iMessage / FaceTime
AppleTV
Netflix
Handoff
Continuity


What doesn't works:
Bluetooth - can't connect to devices or turn it off
Audio via front 3.5 jack

 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,343
just tried with the kexts but still have the same issues
With the bluetooth kexts in the EFI do the following.
Fully shut down the system then remove the power cable from it.
wait a few minutes and then plug it back in and power back up and your Bluetooth should kick into life.
Without getting technical, Booting from windows to MacOS causes this.
A second solution if your motherboard likes it is to enable ERP and this will shut off power to all the whole system once it’s shut down but some boards do not like having this option enabled and it will break macOS from shutting down and it will restart instead.
 

spiderpork

New member
Joined
Jul 29, 2021
Messages
4
just tried both solution still have the same problem,i used a time machine backup from a real MacBook pro, maybe Is that the problem?
 
Top Bottom