Fine Tuning ASRock B450M Pro4

tony535

Member
Joined
Jul 17, 2020
Messages
45
I have a few issues I need help with, im using OC 0.6.2

1. My hack goes to sleep but when I wake it up, this is what my monitor looks like any idea how to fix this?

2. The OC guide says set Above 4G to Enable if I do that, won't boot any idea why?
 

Attachments

  • IMG_1166.jpeg
    IMG_1166.jpeg
    5.4 MB · Views: 39
  • Screen Shot 2020-10-07 at 4.31.03 PM.png
    Screen Shot 2020-10-07 at 4.31.03 PM.png
    335.2 KB · Views: 38

wild_eep

Member
Joined
May 27, 2020
Messages
72
2. The OC guide says set Above 4G to Enable if I do that, won't boot any idea why?

I have the same mobo and have the same issue if Above 4G is enabled. I don't know the reason why, but as a workaround, I have that setting disabled and added "npci=0x2000" to the boot args in config.plist.
 

tony535

Member
Joined
Jul 17, 2020
Messages
45
I have the same mobo and have the same issue if Above 4G is enabled. I don't know the reason why, but as a workaround, I have that setting disabled and added "npci=0x2000" to the boot args in config.plist.
I had npci=0x3000 I see no difference ill keep searching.
 

tony535

Member
Joined
Jul 17, 2020
Messages
45
O.C 0.6.2 Big Sur 11.0.1 Beta (20B5012d) sleep and wake is working. wake from keyboard or mouse and power button works fine. no more funny looking screen after wake all I did was update to Beta 11.0.1.
 

brendan_siow

New member
Joined
Oct 13, 2020
Messages
22
Thanks i updated to 4.20 cause mine is B450 Pro 4 but it still not working.. I might need to wait for the release then..
 

tony535

Member
Joined
Jul 17, 2020
Messages
45
Updated OC to 0.6.3
Updated Big Sur 11.0.1 Beta (20B5022a)
no issues

11/10/20 Updated Big Sur to version 11.0.1 (20B28)
OC 0.6.3 same AMD Experimental patches
no issues

11/20/20 Updated Big Sur to Version 11.1 Beta (20C5048k)
OC 0.6.3 New AMD Experimental patch
no issues
 

Attachments

  • Screen Shot 2020-11-06 at 10.26.23 AM.png
    Screen Shot 2020-11-06 at 10.26.23 AM.png
    3.8 MB · Views: 26
Last edited:

tony535

Member
Joined
Jul 17, 2020
Messages
45
updated OC to 0.6.9
Updated Big Sur to 11.4 Bata (20F5055c)

I noticed in about this Mac, Processor 3.6 GHz Unknown. That's new it use to say Intel core i5 etc.

As far as I can tell she's running fine
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
updated OC to 0.6.9
Updated Big Sur to 11.4 Bata (20F5055c)

I noticed in about this Mac, Processor 3.6 GHz Unknown. That's new it use to say Intel core i5 etc.

As far as I can tell she's running fine
Go into your config.list and change your processor type to 1537
also if you want the correct processor info to display for your cpu instead of Intel info then also add the RestrictEvents.kext. 👍
 

tony535

Member
Joined
Jul 17, 2020
Messages
45
Go into your config.list and change your processor type to 1537
also if you want the correct processor info to display for your cpu instead of Intel info then also add the RestrictEvents.kext. 👍
hi I did your suggestion now its back to 3.6 GHz 6-Core Intel Core i5. Did I miss a step?

PlatformInfo ----> ProcessorType was 0 changed to 1537
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
hi I did your suggestion now its back to 3.6 GHz 6-Core Intel Core i5. Did I miss a step?

PlatformInfo ----> ProcessorType was 0 changed to 1537
Yeah that’s right and now add the RestrictEvents.kext to your kext folder and add it to your kernel in your config.plist and then check about this Mac again.
 

tony535

Member
Joined
Jul 17, 2020
Messages
45
Yeah that’s right and now add the RestrictEvents.kext to your kext folder and add it to your kernel in your config.plist and then check about this Mac again.
1. mount my efi folder
2. added the kext into the kext folder
3. open properTree-Master open select efi then OC snapshot then OC clean snapshot kext is listed under kernel its #7 for me
PlatformInfo processor type change from 0 to 1537
4. save and reboot reset NVRAM also
still the same
 
Last edited:

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
@Shaneee We have a 3600 needing RestrictEvents V1.0.2 to work (See above posts) Whatever the reason is for it as showing as unknown in about this Mac and the 12 cores showing as 2 core cpus must be connected in some way don’t you think?
Whatever the problem is in the kernel collates to the 6 and 12 cores. The rabbit hole gets deeper. 😂
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,290
I've got an idea but it's a long shot. Not sure how I'll work it out though but I'll keep everyone updated.
 

tony535

Member
Joined
Jul 17, 2020
Messages
45
@AudioGod I Have a 3700x cpu. if I apply the above process to get the cpu name shown correctly, is there a different set of numbers I have to enter under PlatformInfo ----> Processor type?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
Top Bottom