Ethernet die after upgrade

kaayapezzuti

New member
Joined
Jan 10, 2022
Messages
3
Hello everyone, everything good?
I was using hackintosh with Big Sur, and the network worked perfectly, both WIFI and ETHERNET.

I recently installed Monterey because I bought a RX 6600 XT GPU that only works in Monterey.

But I found a problem with the network card. My motherboard is Aorus Elite Wifi x570. Before, it used a SmallTreeIntel.kext kext to work.

But now it looks like this kext doesn't work anymore.

Anyone know how to solve this Ethernet problem?

I wanted to avoid buying another card because of this since it worked perfectly before.

My motherboard is this

Observation The card seems to be recognized by the system, but it doesn't connect to the network, here are some photos to prove it
Captura de Tela 2022-01-10 às 06.54.27.png
Captura de Tela 2022-01-10 às 06.54.15.png
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
783
SmallTree does not work on Monterey, you'd have to either use Wifi or get another supported NIC. Either USB Dongle or a PCIe card would do.
 

kaayapezzuti

New member
Joined
Jan 10, 2022
Messages
3
But is it possible that in the future they will make some correction .kext for this?
I'll see a new NIC for now, but there must be a way to fix this lol

tks
SmallTree does not work on Monterey, you'd have to either use Wifi or get another supported NIC. Either USB Dongle or a PCIe card would do.
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
783
Apple changed something in the framework and the company that developed SmallTree has no interest in updating the kext or releasing the sources.
There is an alternative AppleIGB.kext, but that does not work reliable. Unless someone with experience writing network driver looks into that, there is no fix in sight.
 
Top Bottom