Dual Boot Windows & macOS

silvergraphs

New member
May 3, 2020
24
1
3
Hi guys, previously had a dual boot installation of Windows and macOS, everything worked fine at the time of boot, I select from the
BIOS, not from the OpenCore menu, which system wanted to boot, whether Windows (Windows Boot Manager) or OpenCore, but from one day to the next (I think it was with the Windows update from 1909 to 2004) my boot with opencore disappeared , there is only the Windows one. So I decided to enter the EFI partition of my disk from Windows (with Explorer ++) and copy some files that I had from my EFI partition backup where if the dual boot worked. I did it but it didn't work, OpenCore still didn't appear, so I decided to download GibMacOS and run the script to create a custom USB where I had an EFI created with OpenCore. And just replace the config.plist and my personal OpenCore folders, when using the USB it works, OpenCore appears and Windows Boot Manager also appears, the latter appears 2 times (I suppose one is from the USB and the other is from my disk). There I was able to start macOS successfully and also Windows, so I said, well why not copy all the contents of my EFI folder from my USB to my disk? I did it and it didn't work either, OpenCore doesn't appear! Windows only, what can be the problem? Should I use an application to directly clone the EFI partition? Or what do you recommend? From already thank you very much.
 

Shaneee

Administrator
Staff member
Mar 13, 2020
433
160
142
28
Scotland
amd-osx.com
You should be able to add it back in using the UEFI shell,

  • First, use map to find your devices.
  • Once you have an idea of your device, select it by typing DEVICE: replacing device with the actual device. Ex. FS0:
  • Use ls to determine the content of the device. It should contain an EFI folder. Use caution to make sure this device is not your USB stick.
  • Use bcfg boot dump to view your currently configured boot devices (you may see your USB in this list for validation).
  • Use bcfg boot add 00 FS0:\EFI\BOOT\BOOTX64.EFI OpenCoreto add an entry to your boot map.
    • 00 is the boot order ranking, 00 being the very first one, and it increments by one, 01 being the second, 02 being the third and so on.
  • Rerun the boot dump command to verify.
  • Reboot.