DRM Content Showing Red Screen

Beaker

New member
Joined
Dec 9, 2020
Messages
1
Hi,
After following the dortania DRM fix guide, I am still experiencing an error in which Netflix and Prime Video content appears as a red screen and tv+ content appears as a green screen.

Currently, I have tried both the shikivga=128 boot flag and through "injecting" shikivga into the GPU in the config.plist as per the guide to no avail.

Specs are: Ryzen 5 2600 (Does not have an iGPU), Aorus B450 M, and RX 580 (Gigabyte 8GB) and System Definition is iMacPro1,1

Any help is appreciated!
 

zhaohuan325

New member
Joined
May 2, 2020
Messages
10
It was normal when I used oc0.63 and macos11.01, and then I upgraded to oc0.64, and problems occurred after macos11.1. I changed cpu3950x to 5900x and upgraded the bios. I don’t know if it has anything to do with it. Relationship, the graphics card has always been vega64
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,615
This was fixable with Lilu before the user space patching stopped working. The dev has no interest in fixing it though. It's possible to get it working with a different SMBios. I've got a RX 560 using iMacPro1,1 and DRM content works fine.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
This was fixable with Lilu before the user space patching stopped working. The dev has no interest in fixing it though. It's possible to get it working with a different SMBios. I've got a RX 560 using iMacPro1,1 and DRM content works fine.

Interesting you should say that, Im using iMacPro1,1 too and DRM is working on everything apart from Apple+, now when I run that I get a green screen. I don't really care but it does seem that DRM is getting worst and worst..lol
Does Apple+ still work for you @Shaneee ? (It stopped working for me as of 11.1, 11.01 it works)
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,615
Interesting you should say that, Im using iMacPro1,1 too and DRM is working on everything apart from Apple+, now when I run that I get a green screen. I don't really care but it does seem that DRM is getting worst and worst..lol
Does Apple+ still work for you @Shaneee ? (It stopped working for me as of 11.1, 11.01 it works)

Apple+? I can watch AppleTV just fine. I'm currently on 11.2 Beta (20D5029f)
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Apple+? I can watch AppleTV just fine. I'm currently on 11.2 Beta (20D5029f)
Yeah AppleTV, Hmmmmm that’s strange. I have tested it via a test drive and got same results. Whats going on there then? (Maybe it’s a 11.1 problem, Il give 11.2 a bash via the test drive and see)
 

gearwhore

New member
Joined
Dec 3, 2020
Messages
9
Same boat here, DRM works for everything except AppleTV app, just get a red screen, audio works though.
OS11.1
Ryzen 5600x
Radeon 5600
opencore 64
 
Top Bottom