d4vid's Aorus Master x570 5950x 6900XT Big Sur Opencore 0.6.8

david

New member
Joined
Nov 27, 2020
Messages
15
Everything seems to work perfectly. This is my first Hackintosh after 15 years of using apple laptops only. What got me into buying an apple macbook (then macbook pro's from then on) in 2006 was a "successful" build on the first hackintoshable Mac OS X 10.4. I could install it on my PC, and I was converted straight away. It was barely usable back then, and I went buying a macbook and never turned back to PCs. Until last year, when I decided to build a Hacky. I loved building the PC itself, and the fact that I can have a monster Mac OS machine that may never even be possible to buy from Apple. And the hackintoshing now got me back to liking and using Windows again :) The circle is complete!

Build

CPU
: AMD Ryzen 9 5950X 3.4 GHz 16-Core Processor
CPU Cooler: ARCTIC Liquid Freezer II 360 56.3 CFM
Motherboard: Gigabyte X570 AORUS MASTER Rev. 1.2 ATX AM4
Memory: G.Skill Ripjaws 64 GB (2 x 32 GB) DDR4-4000 CL18 (runs @ 3733 CL16 with 1:1 infinity fabric coupling)
HDD: 2 x Western Digital Red 3 TB 3.5" 5400RPM
SSD: 2 x Samsung 970 Evo Plus 1 TB M.2-2280 NVME
Video Card: Sapphire Radeon RX 6900 XT 16 GB NITRO+ (used a 5700XT before)
Wireless: Fenvi T919 1750Mbps PCIe Desktop Wifi Card BCM94360CD (this helps using apple bluetooth keyboards during boot and in BIOS and provides a more stable experience overall compared to the onboard Intel chip's driver)
Case: Fractal Design Define R7 Dark ATX Mid Tower
Power Supply: SeaSonic PRIME Ultra Titanium 750 W 80+ Titanium Certified Fully Modular ATX
UPS: CyberPower CP1500EPFCLCD 1500VA 900W Pure Sine Wave UPS - no computer is safe without a battery
Case Fan: 6 x Noctua A14 PWM chromax.black.swap 82.52 CFM 140 mm
Monitor: Samsung Odyssey G9 49.0" 5120x1440 240 Hz (runs only @ 120Hz, no HDR)
TV: Samsung Q80T 65" 3840x2160 120 Hz TV (runs only @ 60Hz, HDR works)
Audio Interface: Onboard + RME Fireface UCX 36-Channel USB 2.0
OSes: Windows 10 pro 64bit + Mac OS Big Sur 11.4 Beta 1 + Mac OS Catalina triple boot

Sleep did not work with Catalina, this seems to be working now with Big Sur.

BIOS settings

Fast Boot: disabled
Secure Boot: disabled
Compatibility Support Module: disabled
Above 4g decoding: enabled. Did not try adding npci=0x2000 to the boot args instead, but haven't had any issues like that. Forgetting to enable this gave me the biggest challenge of the whole install, as it would cause the boot sequence to randomly freeze at different points, giving me false clues on what the issue could be.
Resizable bar support: auto. The dortania guide says this should be disabled, but I wanted to leave this enabled for windows. Haven't had any issues yet.
EHCI/XHCI Hand-off, UEFI Mode, SATA Mode: AHCI enabled as per the guide.

VMware Fusion Version 10.1.6 (12989998) worked on Catalina with bootcamp on the SSD and IOMMU enabled in the BIOS. This no longer works on Big Sur :/


 

Attachments

  • EFI - OpenCore 0.6.8 - BigSur 11.4 Beta - X570 Aorus Master.zip
    2.3 MB · Views: 86
Last edited:

slehc84

Member
Joined
Jul 5, 2020
Messages
50
Everything seems to work perfectly. This is my first Hackintosh after 15 years of using apple laptops only. What got me into buying an apple macbook (then macbook pro's from then on) in 2006 was a "successful" build on the first hackintoshable Mac OS X 10.4. I could install it on my PC, and I was converted straight away. It was barely usable back then, and I went buying a macbook and never turned back to PCs. Until last year, when I decided to build a Hacky. I loved building the PC itself, and the fact that I can have a monster Mac OS machine that may never even be possible to buy from Apple. And the hackintoshing now got me back to liking and using Windows again :) The circle is complete!

Build

CPU
: AMD Ryzen 9 5950X 3.4 GHz 16-Core Processor
CPU Cooler: ARCTIC Liquid Freezer II 360 56.3 CFM
Motherboard: Gigabyte X570 AORUS MASTER ATX AM4
Memory: G.Skill Ripjaws 64 GB (2 x 32 GB) DDR4-4000 CL18 (runs @ 3733 CL16 with 1:1 infinity fabric coupling)
HDD: 2 x Western Digital Red 3 TB 3.5" 5400RPM
SSD: 2 x Samsung 970 Evo Plus 1 TB M.2-2280 NVME
Video Card: Sapphire Radeon RX 6900 XT 16 GB NITRO+
Wireless: Fenvi T919 1750Mbps PCIe Desktop Wifi Card BCM94360CD
Case: Fractal Design Define R7 Dark ATX Mid Tower
Power Supply: SeaSonic PRIME Ultra Titanium 750 W 80+ Titanium Certified Fully Modular ATX
Case Fan: 6 x Noctua A14 PWM chromax.black.swap 82.52 CFM 140 mm
Monitor: Samsung Odyssey G9 49.0" 5120x1440 240 Hz (runs only @ 120Hz, no HDR)
TV: Samsung Q80T 65" 3840x2160 120 Hz TV (runs only @ 60Hz, HDR works)
Audio Interface: Onboard + RME Fireface UCX 36-Channel USB 2.0
OSes: Windows 10 pro 64bit + Mac OS Big Sur 11.4 Beta 1 + Mac OS Catalina triple boot




David,
great job.
Just being nosey what cpu temps do you get ? I have a Celsius S36 on my 3900X and I think its high compared to my I9-10900kf
 

david

New member
Joined
Nov 27, 2020
Messages
15
David,
great job.
Just being nosey what cpu temps do you get ? I have a Celsius S36 on my 3900X and I think its high compared to my I9-10900kf
Thank you.
what do you mean exactly regarding the temps?
idle, under heavy load, with which overclocking settings...
the 5950x can get as hot as I do not want it to be, but have fine tuned through windows so it doesnt get hotter than 82.5 under load. But i can easily get 95+ degrees celsius with heavy overclocking and even the arctic will not stop that From happening. Only a nitro cooling can max out the cpu.
haven’t tested thoroughly in mac yet with the amd cpu gadget, but it is so much faster then my macbooks i dont even feel the need to overclock it to the max (Except the memory fine-tuning and highest stable infinity fabric clock speed with 1:1 coupling)
 

batchi21

New member
Joined
Jul 14, 2020
Messages
22
That's great!! I
want to do Hackintosh with Ryzen5950x and RX6800xt now, but I am struggling because I can not install 11.4 ...
Can you show me EFI if you like?
 

slehc84

Member
Joined
Jul 5, 2020
Messages
50
Thank you.
what do you mean exactly regarding the temps?
idle, under heavy load, with which overclocking settings...
the 5950x can get as hot as I do not want it to be, but have fine tuned through windows so it doesnt get hotter than 82.5 under load. But i can easily get 95+ degrees celsius with heavy overclocking and even the arctic will not stop that From happening. Only a nitro cooling can max out the cpu.
haven’t tested thoroughly in mac yet with the amd cpu gadget, but it is so much faster then my macbooks i dont even feel the need to overclock it to the max (Except the memory fine-tuning and highest stable infinity fabric clock speed with 1:1 coupling)
David,
thanks , understand what you are saying.
I might swap mine to my Thermaltake case , it has a alpha cool extreme 280 , running into a EKWB 360 rad , into a pump reservoir and a EKWB block , this kept my I9-10900k o/c to 5.2 all cores at 65 under a heavy load , would be interesting to see what it does to a AMD.
 

slehc84

Member
Joined
Jul 5, 2020
Messages
50
That's great!! I
want to do Hackintosh with Ryzen5950x and RX6800xt now, but I am struggling because I can not install 11.4 ...
Can you show me EFI if you like?
I will try and help , but what motherboard do you use?
 

batchi21

New member
Joined
Jul 14, 2020
Messages
22
I will try and help , but what motherboard do you use?
Thank you very much.
The motherboard uses the ASUS B550.
I was able to use it without problems until 11.2, but when I start trying to install 11.4, it restarts in the middle of the apple mark.
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
623
For 11.3 and later there is a new kernel patch required, check that you have the latest set of patches.
 

slehc84

Member
Joined
Jul 5, 2020
Messages
50
Have you applied the patches as the previous person said? In the end I made a new 0.6.8 and just went through it bit by bit as per the guides?
 

batchi21

New member
Joined
Jul 14, 2020
Messages
22
The patch has been adapted, but it has not been re-created for 0.6.8, so I will try to rebuild it once. If you have any questions on that, let me ask you a question again. thank you.
 

slehc84

Member
Joined
Jul 5, 2020
Messages
50
The patch has been adapted, but it has not been re-created for 0.6.8, so I will try to rebuild it once. If you have any questions on that, let me ask you a question again. thank you.
You do not have the resize bar option switched on in the bios?
 

david

New member
Joined
Nov 27, 2020
Messages
15
That's great!! I
want to do Hackintosh with Ryzen5950x and RX6800xt now, but I am struggling because I can not install 11.4 ...
Can you show me EFI if you like?
Sure, will upload them later. I just followed a fresh reinstall of OpenCore 0.6.8 and everything related (all external drivers, AMD patches, AMD CPU power management, etc..) except for the ACPI files. I reused the same ACPI files I had for Catalina with OC 0.6.5. I didn't fully manually map the USB ports myself, and since I did the ACPI files last year and tried many options I don't quite remember which way I went with at the end. I will upload them anyway! I was so happy when the system was working, and it didn't really have any issues with it, all USB ports were working, therefore I did not want to touch it :)
 

david

New member
Joined
Nov 27, 2020
Messages
15
Thank you very much.
The motherboard uses the ASUS B550.
I was able to use it without problems until 11.2, but when I start trying to install 11.4, it restarts in the middle of the apple mark.
If you have a B550 chipset then my EFI wont be much help (i have X570), but will extend the original post with more info soon anyway and add the EFI too.
 

david

New member
Joined
Nov 27, 2020
Messages
15
David,
thanks , understand what you are saying.
I might swap mine to my Thermaltake case , it has a alpha cool extreme 280 , running into a EKWB 360 rad , into a pump reservoir and a EKWB block , this kept my I9-10900k o/c to 5.2 all cores at 65 under a heavy load , would be interesting to see what it does to a AMD.
That sounds like a good combo :) AMDs likes cooling for sure! And benefits from it...
 

david

New member
Joined
Nov 27, 2020
Messages
15
Thank you very much.
The motherboard uses the ASUS B550.
I was able to use it without problems until 11.2, but when I start trying to install 11.4, it restarts in the middle of the apple mark.
My mysterious error I struggled with for a couple of days that caused the OC boot to freeze at random points (giving me false clues all the way!) was that I haven't enabled "above 4g decoding" in the BIOS (neither I had the boot option present to replace it if the BIOS settings is off) I will check my BIOS settings too and update the original post.
 

slehc84

Member
Joined
Jul 5, 2020
Messages
50
That sounds like a good combo :) AMDs likes cooling for sure! And benefits from it...
Will let you know how the transplant goes , just waiting for my Alphacool water block for the 6800 , lets do it all in one go :)
 

batchi21

New member
Joined
Jul 14, 2020
Messages
22
My mysterious error I struggled with for a couple of days that caused the OC boot to freeze at random points (giving me false clues all the way!) was that I haven't enabled "above 4g decoding" in the BIOS (neither I had the boot option present to replace it if the BIOS settings is off) I will check my BIOS settings too and update the original post.
Thank you for your various replies. I re-created the comp for 0.6.8 and downloaded the installer again and the installation was completed successfully.
 

david

New member
Joined
Nov 27, 2020
Messages
15
That's great!! I
want to do Hackintosh with Ryzen5950x and RX6800xt now, but I am struggling because I can not install 11.4 ...
Can you show me EFI if you like?
attached the EFI to the original post
 
Top Bottom