Crashing photography apps

bojus2020

New member
Joined
Oct 15, 2020
Messages
4
Hi,

I've built a nice solid stable system based on AMD's ryzen processor. Most software installed on Catalina in the beginning had issues with crashes.

I use my system for content creation, photo-video editing. I also use Alien Skin's Exposure X5/X6 for my photo editing but every time I click start on the software it crashes. I contacted the developers but they don't support hackintosh systems, understandable. Same with Luminar 4.

Can somebody help me out here please? Any pointer's and suggestions on how to prevent this will be a great help.

I've attached a screenshot of the message I get when the software crashes. If someone could let me know how and where to get a crashlog it would be great. Thx in advance.


Hackintosh

Opencore v5.9 with Mac OS Catalina 10.15.6

System Build

  1. AMD Ryzen 9 3950X - Processor
  2. ASRock X570 Creator Motherboard
  3. G.Skill Trident Z Neo F4-3600C16D RAM
  4. Sapphire RADEON NITRO+ RX 5700 XT Graphics Card
  5. Be quiet! PURE POWER 11 600W CM Power Supply
  6. Corsair Force Series MP600 500 GB - Solid state drive
  7. PNY CS2130 - Solid state drive
 

Attachments

  • Screen Shot 2020-10-15 at 17.16.46.png
    Screen Shot 2020-10-15 at 17.16.46.png
    50 KB · Views: 10

thepensivemonk

Donator
Donator
Joined
Jul 23, 2020
Messages
36
I've built a nice solid stable system based on AMD's ryzen processor. Most software installed on Catalina in the beginning had issues with crashes.

So, I thought I would test quickly on my OC 0.6.2 and Catalina 1.15.7 and the result was pretty much identical. You need to monitor the Console.app to see the actual crash information, but it is likely similar to what I found:

Code:
Oct 15 15:08:07 Thyra Solar Service[1258]: notification user info:{
        NSApplicationBundleIdentifier = "com.Breakpad.crash_report_sender";
        NSApplicationName = "Crash Reporter";
        NSApplicationPath = "/Applications/Exposure X6.app/Contents/Frameworks/Breakpad.framework/Versions/A/Resources/crash_report_sender.app";
        NSApplicationProcessIdentifier = 2299;
        NSApplicationProcessSerialNumberHigh = 0;
        NSApplicationProcessSerialNumberLow = 548998;
        NSWorkspaceApplicationKey = <NSRunningApplication: 0x600002c10b80 (com.Breakpad.crash_report_sender - 2299) LSASN:{hi=0x0;lo=0x86086}>;
        NSWorkspaceExitStatusKey = 0;
    }
Oct 15 15:08:08 Thyra com.apple.xpc.launchd[1] (software.exposure.exposureX6.17472[2298]): Service exited with abnormal code: 1
Oct 15 15:08:08 Thyra Solar Service[1258]: notification user info:{
        NSApplicationBundleIdentifier = "software.exposure.exposureX6";
        NSApplicationName = "Exposure X6";
        NSApplicationPath = "/Applications/Exposure X6.app";
        NSApplicationProcessIdentifier = 2298;
        NSApplicationProcessSerialNumberHigh = 0;
        NSApplicationProcessSerialNumberLow = 544901;
        NSWorkspaceApplicationKey = <NSRunningApplication: 0x600002c10b80 (software.exposure.exposureX6 - 2298) LSASN:{hi=0x0;lo=0x85085}>;
        NSWorkspaceExitStatusKey = 1;

I doubt I can provide much assistance here, but I do know that image and video editing apps are tricky on AMD hackintosh as particularly the modules and plugins are assuming an Intel-based Mac system. Common Adobe programs there have been successful hacks and work arounds. I use Affinity Photo for my image editing (as my needs are not pro level) and have no issues running on AMD.

However, if the program is crashing out of the gate, it is not a good sign and likely indicating aforementioned Intel-CPU hooks. There may not be an easy fix.

pm
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
784
Out of curiosity try launching it from Terminal with this command,

Code:
MKL_DEBUG_CPU_TYPE=5 "/Applications/Exposure X6.app"
 

thepensivemonk

Donator
Donator
Joined
Jul 23, 2020
Messages
36
Out of curiosity try launching it from Terminal with this command,

Code:
MKL_DEBUG_CPU_TYPE=5 "/Applications/Exposure X6.app"

On my system, possibly because I am using zsh, I doesn't appear I can launch apps via the command line (at least not with the syntax you are quoting). Though I was interested enough to re-install the app to find out..

I dug a bit deeper, and I had to run the executable directly when using the terminal (so a bit of digging) but I got this feedback. Does not look promising. The app crashes even before any splash screen.

Code:
[email protected] MacOS % sudo MKL_DEBUG_CPU_TYPE=5 ./Exposure\ X6
Password:
2020-10-15 19:16:48.583 Exposure X6[3276:122094] [3276]
2020-10-15 19:16:48.583 Exposure X6[3276:122094] [19:16:48.583]
2020-10-15 19:16:48.583 Exposure X6[3276:122094] =============================================================================================================
2020-10-15 19:16:48.583 Exposure X6[3276:122094]
2020-10-15 19:16:48.583 Exposure X6[3276:122094] [3276]
2020-10-15 19:16:48.584 Exposure X6[3276:122094] [19:16:48.583]
2020-10-15 19:16:48.584 Exposure X6[3276:122094] 2020-10-15T19:16:48
2020-10-15 19:16:48.584 Exposure X6[3276:122094]
2020-10-15 19:16:48.584 Exposure X6[3276:122094] [3276]
2020-10-15 19:16:48.584 Exposure X6[3276:122094] [19:16:48.584]
2020-10-15 19:16:48.584 Exposure X6[3276:122094] Build 6.0.0.68
2020-10-15 19:16:48.584 Exposure X6[3276:122094]
2020-10-15 19:16:48.585 Exposure X6[3276:122094] [3276]
2020-10-15 19:16:48.585 Exposure X6[3276:122094] [19:16:48.585]
2020-10-15 19:16:48.585 Exposure X6[3276:122094] Startup
2020-10-15 19:16:48.585 Exposure X6[3276:122094]
2020-10-15 19:16:48.585 Exposure X6[3276:122094] [3276]
2020-10-15 19:16:48.585 Exposure X6[3276:122094] [19:16:48.585]
2020-10-15 19:16:48.585 Exposure X6[3276:122094] Creating StandaloneHostApplication
2020-10-15 19:16:48.585 Exposure X6[3276:122094]
Breakpad Uploader: minidump file too large to upload : 8527688

pm
 
Last edited:

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
784
Sorry I totally borked that... It should be

Code:
MKL_DEBUG_CPU_TYPE=5 /Applications/Exposure\ X6.app/Contents/MacOS/Exposure\ X6
 

thepensivemonk

Donator
Donator
Joined
Jul 23, 2020
Messages
36
Sorry I totally borked that... It should be

Code:
MKL_DEBUG_CPU_TYPE=5 /Applications/Exposure\ X6.app/Contents/MacOS/Exposure\ X6

No worries, figured it out. ;)

I get the same instant crash on my test system. Not sure about @bojus2020, but it would not surprise me if it was the same.

pm
 

bojus2020

New member
Joined
Oct 15, 2020
Messages
4
You're right this is what i get


MKL_DEBUG_CPU_TYPE=5 /Applications/Exposure\ X6.app/Contents/MacOS/Exposure\ X6


2021-01-21 17:14:38.689 Exposure X6[7088:391528] [7088]


2021-01-21 17:14:38.689 Exposure X6[7088:391528] [17:14:38.689]


2021-01-21 17:14:38.689 Exposure X6[7088:391528] =============================================================================================================


2021-01-21 17:14:38.689 Exposure X6[7088:391528]


2021-01-21 17:14:38.690 Exposure X6[7088:391528] [7088]


2021-01-21 17:14:38.690 Exposure X6[7088:391528] [17:14:38.690]


2021-01-21 17:14:38.690 Exposure X6[7088:391528] 2021-01-21T17:14:38


2021-01-21 17:14:38.690 Exposure X6[7088:391528]


2021-01-21 17:14:38.690 Exposure X6[7088:391528] [7088]


2021-01-21 17:14:38.690 Exposure X6[7088:391528] [17:14:38.690]


2021-01-21 17:14:38.690 Exposure X6[7088:391528] Build 6.0.1.100


2021-01-21 17:14:38.690 Exposure X6[7088:391528]


2021-01-21 17:14:38.691 Exposure X6[7088:391528] [7088]


2021-01-21 17:14:38.691 Exposure X6[7088:391528] [17:14:38.691]


2021-01-21 17:14:38.691 Exposure X6[7088:391528] Startup


2021-01-21 17:14:38.691 Exposure X6[7088:391528]


2021-01-21 17:14:38.692 Exposure X6[7088:391528] [7088]


2021-01-21 17:14:38.692 Exposure X6[7088:391528] [17:14:38.692]


2021-01-21 17:14:38.692 Exposure X6[7088:391528] Creating StandaloneHostApplication


2021-01-21 17:14:38.692 Exposure X6[7088:391528]


Breakpad Uploader: minidump file too large to upload : 8509064

PITYYYYYY
 

bojus2020

New member
Joined
Oct 15, 2020
Messages
4
This is turning out to be an expensive mistake. Should have just gone with an Intel CPU. I'm even considering booting into windows 10 and working the apps that way on this Ryzen build. A real pity.
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
566
You could virtualize MacOS with Qemu/KVM to run Apps without issues on AMD.
 
Top Bottom