Config.plist wrong?

Edwin

Member
Joined
Jul 25, 2021
Messages
50
Hi guys, I accidentally replaced an old config.plist with my current one (I forgot to make a copy, how stupido I can be) and now Monterey won't boot. Any thoughts/help?
Hardware: Mobo Asus Prime X470 Pro, GPU AMD R9 390, CPU Ryzen 5 3600 6-core.
Greetings from the NL
 

Attachments

  • config.plist
    53.8 KB · Views: 2

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,612
Here you go. I have no idea what was going on with your kext folder so I've removed the unnecessary kexts and added RestrictEvents into the config.
 

Attachments

  • EFI.zip
    3.8 MB · Views: 12

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,612
Replace config with this one. Forgot to check the patches and you still had the old ones :p
 

Attachments

  • config.plist.zip
    6.1 KB · Views: 12

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,612
I'm guessing your PCI path for the GPU is wrong. Try with PciRoot(0x0)/Pci(0x3,0x1)/Pci(0x0,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0) or check with gfxutil or Hackintool.
 

Edwin

Member
Joined
Jul 25, 2021
Messages
50
I'm guessing your PCI path for the GPU is wrong. Try with PciRoot(0x0)/Pci(0x3,0x1)/Pci(0x0,0x0)/Pci(0x0,0x0)/Pci(0x0,0x0) or check with gfxutil or Hackintool.
This is my location path:

PCIROOT(0)#PCI(0301)#PCI(0000)

ACPI(SB)#ACPI(PCI0)#ACPI(GPP8)#ACPI(X161)

ACPI(SB)#ACPI(USBX)#ACPI(GPP8)#ACPI(X161)
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,612
LAN won't work as SmallTreeIntel82576 isn't working on Monterey. You can use the alternative AppleIGB or AppleI2xx but it's not very reliable. The other options are native WiFi, or a USB to LAN adapter.

As for the GPU path that's not OpenCore compatible. I've made a short video on how to get it with Hackintool,

 

Edwin

Member
Joined
Jul 25, 2021
Messages
50
LAN won't work as SmallTreeIntel82576 isn't working on Monterey. You can use the alternative AppleIGB or AppleI2xx but it's not very reliable. The other options are native WiFi, or a USB to LAN adapter.

As for the GPU path that's not OpenCore compatible. I've made a short video on how to get it with Hackintool,

So, back to Big Sur maybe?
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,612
That's entirely up to you. I got a USB Type-C to 2.5GB LAN for £17.99 on Amazon. Works OOB on macOS, Windows and Linux. There's standard USB ones too if you don't have Type-C on the rear IO. Works a treat :D
 

Edwin

Member
Joined
Jul 25, 2021
Messages
50
Than it’s back to Big Sur. I have absolutely no budget/money to spend on hardware. I live from a part time salary. All the money goes to food and rent☹️ This pc I got is from a friend of mine who died a couple months ago.
 
Top Bottom