Change CPU name on Catalina

Aluveitie

Active member
May 2, 2020
453
116
43
@v0id125 In the old forums was a detailed post about this issue. In short, Apples Code has a bug where in this case it ignores localization. To fix it you'd have to modify the binary... probably not worth the effort.
 

wild_eep

Member
May 27, 2020
67
12
8
Southern California
I was able to successfully edit my CPU name, but had to do it slightly different than Shaneee's tutorial.

1. When mounting the root partition, I got the following error:

$ sudo mount -uw /
mount_apfs: volume could not be mounted: Operation not permitted
mount: / failed with 77


To overcome this, I disabled SIP by editing my EFI config.plist to change the csr-active-config setting to E7030000 in the NVRAM section.


2. My Processors.strings file was not in an XML format like in Shaneee's tutorial. So I couldn't use a text editor (Atom in my case) to edit the file. Instead, I used ProperTree.

Success!

EDIT: After this was all done, I re-enabled SIP by changing the csr-active-config setting in the config.plist back to 00000000.
 
Last edited:

Bansaku

New member
May 3, 2020
27
4
3
It'll be en_CA or just en for English Canadian.

Well, I copied over the whole damn AppleSystemInfo.framework folder over from my back-up OC system and... I still have nothing displayed under System Info.

Screen Shot 2020-06-11 at 2.06.39 AM.png

Funny thing is in OC the CPU is reported as Intel i5 3.60 GHz. I am guessing this fix only works with OC?
 

slead

Member
Jun 30, 2020
32
9
8
@Bansaku
have the same issue as you, not sure what the problem is, but the machine in itself is working perfectly.

Screenshot 2020-07-02 at 22.16.51.png
 

Aluveitie

Active member
May 2, 2020
453
116
43
@slead if it just shows the frequency Catalina will ignore the localization, it's a bug in the code. You can either patch the binary (there was a post in the old forum explaining the situation) or change the cpu type. This option was just added to the OC master, in the upcoming OC 0.6.2 you could do that.

Apple has fixed this in Big Sur by the way.
 
  • Like
Reactions: olbo