Change CPU name on Catalina

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,006
I've only tested this on 10.15.5.

zLoPyBm.png

Mount System Read/Write
Code:
sudo mount -uw /


Change language path to reflect your locale. en_GB.lproj


Create a backup and copy file to Desktop
Code:
sudo cp -Rf /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/en_GB.lproj/Processors.strings /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/en_GB.lproj/Processors.strings.backup

Code:
sudo cp -Rf /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/en_GB.lproj/Processors.strings ~/Desktop



Open file with your favorite text editor ( I used BBEdit ), Xcode won't work for this. Find the string About This Mac is currently displaying for you and change the value inside <string> </string>

For Example,
Code:
    <key>6-Core Intel Core i5</key>
    <string>AMD Ryzen 5 3600</string>



Copy the file back and check About This Mac.
Code:
sudo cp -Rf ~/Desktop/Processors.strings /System/Library/PrivateFrameworks/AppleSystemInfo.framework/Versions/A/Resources/en_GB.lproj/
 

TAM305

New member
Joined
May 29, 2020
Messages
8
Did i do something wrong it did not work for me
 

Attachments

  • Screen Shot 2020-05-28 at 11.50.20 PM.png
    Screen Shot 2020-05-28 at 11.50.20 PM.png
    1.3 MB · Views: 145

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,006
@TAM305 Was your CPU showing as an 8-Core i5? Considering it's a 6-Core CPU.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,006
And the file was copied back into place? Your file looks different to mine.

Screenshot 2020-05-29 11.45.34.png
 

TAM305

New member
Joined
May 29, 2020
Messages
8
i open it with TextMate and it change something is there any way u can zip ur file and send it to me
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,006
i open it with TextMate and it change something is there any way u can zip ur file and send it to me

Here is my file,
 

Attachments

  • Processors.strings.zip
    1 KB · Views: 30

TAM305

New member
Joined
May 29, 2020
Messages
8
I restarted added your file the name did not change how weird..... Thanks for your help
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,006
@TAM305 Did you modify it before adding it? Mine only has the 6-Core changed for the 3600.
 

TAM305

New member
Joined
May 29, 2020
Messages
8
Here is my modified file
 

Attachments

  • Processors.strings.zip
    1.1 KB · Views: 12

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,006
Hmm that should work. Not sure why it's not working for everyone. I'll try find out why.
 

jberdan

Donator
Donator
Joined
May 10, 2020
Messages
7
[QUOTE = "jberdan, message: 1456, membre: 867"]
Bonjour shaneee,
En fait, il suffit simplement de remplacer 'En_GB.lproj' par "fr.lproj" dans les lignes de commande demandées plus haut pour que cela marche sans souci en Français. Merci shaneee
 

Attachments

  • Processors.string 2.png
    Processors.string 2.png
    58.5 KB · Views: 134
Last edited:

Neal Caffrey

New member
Joined
May 4, 2020
Messages
8
I restarted added your file the name did not change how weird..... Thanks for your help

Did you changed the <key> as well? Just change the <string> and let <key> by default. Like this, it should work.

<key>8-Core Intel Core i5</key>
<string>8-Core Ryzen 7 3700X</string>
 

Virgo

New member
Joined
May 22, 2020
Messages
15
How change my CPU?
 

Attachments

  • Screen Shot 2020-06-05 at 16.41.33.png
    Screen Shot 2020-06-05 at 16.41.33.png
    125 KB · Views: 97

tuliodomingos

Member
Joined
May 2, 2020
Messages
57
meu deu esse erro
mount_apfs: o volume não pôde ser montado: operação não permitida


mount: / falhou com 77
 

tuliodomingos

Member
Joined
May 2, 2020
Messages
57
mount_apfs: o volume não pôde ser montado: operação não permitida


mount: / falhou com 77


????????
 

Troof

New member
Joined
May 12, 2020
Messages
3
Hello everyone I have a small addition. If the 'sudo mount -uw /' command says 'not permitted' do the following steps:
1. Boot into Recovery Mode
2. Open utilities
3. Open terminal
4. Type in: csrutil disable
5. Reboot
now it should work
 

tuliodomingos

Member
Joined
May 2, 2020
Messages
57
Olá pessoal, tenho uma pequena adição. Se o comando 'sudo mount -uw /' disser 'não permitido', execute as seguintes etapas:
1. Inicialize no modo de recuperação
2. Utilitários abertos
3. Terminal aberto
4. Digite: csrutil disable
5. Reinicialização
agora deve funcionar

AGORA TRABALHOU COM ESTE COMANDO QUE ME PASSOU Captura de Tela 2020-06-07 at 20.14.50.png csrutil
 
Last edited by a moderator:

Bansaku

Member
Joined
May 3, 2020
Messages
40
@Shaneee By chance could you post an un-edited Processors.strings? Before I read this post (and the one on the old forum) I had gone here and did the command. However it did not work; Instead of unknown it's now blank. I am hoping if I throw an original processors.strings back in and do the method outlined here, I could get things to work.
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,006
@Shaneee By chance could you post an un-edited Processors.strings? Before I read this post (and the one on the old forum) I had gone here and did the command. However it did not work; Instead of unknown it's now blank. I am hoping if I throw an original processors.strings back in and do the method outlined here, I could get things to work.

Which language/local?
 
Top Bottom