Certain Waves Plugins failing AU validation test in logic pro x.

gogogo757575

New member
Joined
Feb 1, 2021
Messages
2
Whats up guys, running into a problem it seems for AMD cpus when it comes to wave plugins on Logic Pro x and having them crash the AU- (Audio Units) Validation test for them to work in the daw. So i spent a long time with waves tech support today to find out that its not all waves plugins but a certain set of them that do this. which would make since that about 75 percent of my plugins worked and passed the test but all the others didn't and had the same reasons for failing. As for the list of said plugins that will crash because of this problem, i don't know fully other than the ones that i have in my own personal library.

I uploaded two pictures of the problem that seems to keep happening with them. Either it completes the test and says that it failed becuase of show reasons. or it just flat out crashes the test.

Looking to see if we can solve what is going on with the waves plugins and the AMD systems to see what is happening to cause them to freak out.

ALSO!!
Earlier in a separate forum similar to this one, an admin posted this code to be used in terminal which launches logic differently than normal and weirdly allowed 5-6 more of my plugins to be validated. as to why just them and not others, i dont know but see if this works for any of your plugins. -

MKL_DEBUG_CPU_TYPE=5 /Applications/Logic\ Pro\ X.app/Contents/MacOS/Logic\ Pro\ X
[COLOR=rgba(0, 0, 0, 0.85)][/COLOR]

 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
911
It's possible that it uses Intel only instructions similar to other applications. The second image somewhat confirms this showing "AVXMacIntel.dylib"
 

gogogo757575

New member
Joined
Feb 1, 2021
Messages
2
From what I have seen, and from talking with waves tech support, they somewhat confirmed that as well. What I’m trying to figure out is a way to figure out how to bypass this or get the software to connect and talk properly with the AMD cpu. Wether that’s in a terminal command, something in the config.pist, or something else, I don’t know enough to make that assessment.
 

Driftwood

New member
Joined
Feb 19, 2021
Messages
5
Try 6 instead.
MKL_DEBUG_CPU_TYPE=6 /Applications/Logic\ Pro\ X.app/Contents/MacOS/Logic\ Pro\ X
Most waves plugins will work but NOT these heavily Intel AVX256/512 ones :- Abbey Road Chambers, IR-L, H Reverb Plugins, AR TG, CLA Bass, CLA Echosphere, CLA Mixdown, CLA Epic, EFKramer Delay/ GT/ VC, F6 RTA, GW ToneCenctric, JJP Vocals, MannyM, Maserati, Metafilter, NxOcean Way, Ovox, PugTec, RChannel, Req 2, Schepps, Kings Microphones, Vocal Bender, Waves Tune Real-time,
 

AMDPUSH

Member
Joined
May 2, 2020
Messages
103
Hi, Nice, Then on Catalina we can install the latest Waves except these plugs just by typing this command line ?
 
Top Bottom