[Catalina 10.15.7] Bluetooth USB Dongle - CSR8510 A10 does not work

PhantomR

New member
Oct 7, 2020
1
0
1
CSR8510 A10 does not work in Catalina 10.15.7
I hae been trying to get this dongle to work on my cousin's hackintosh running a Ryzen 3700X, MSI B450-A Motherboard and a 5500XT. It is recognized in Hackintool/IoRegistryExplorer as the model I mentioned, so I guess it is not a USB problem (I tried both without USB map and with a map I made, but I might have not made it properly).
I also checked via kextstat -l | grep -i 'csr' that the Apple drivers for this CSR module have been loaded, and THEY HAVE. I checked the plist for that driver and it DOES contain this model's vendor id and product id, so I am at a loss.

I also tried using the kext here https://www.insanelymac.com/forum/topic/307181-csrapplebluetoothkext-usb-csr-injection-driver/ (no modifications) and deleting com.Apple.Bluetooth.plist from /S/L/Preferences to absolutely no success: https://apple.stackexchange.com/que...ooth-4-0-low-energy-dongle-with-mid-2011-imac

I tried making the device boot in HCI mode (I do not fully know what these modes are or how to check what mode my cousin's dongle boots in) using the method here (which is said to work for quite a few), but I just cannot edit the properties using BlueCore Suite (it says it can't find any lookup table on the device): https://www.osx86.net/topic/19695-109-bluetooth-csr8510-a10-not-recognised-as-bluetooth/?do=findComment&comment=96997

I also saw a tutorial here, but I have NO IDEA how I could sent that 'BOOT 3' command at step 2
:(
: https://www.silabs.com/community/wi...entry.html/2015/08/06/_reference_-_using-ZZy2

Any help is Greatly appreciated.

NOTE: I also posted this on InsanelyMac: https://www.insanelymac.com/forum/t...0-does-not-work/?tab=comments#comment-2739582