Can't get to 10.15.4 or newer, host=win10, ryzen 2600 / Asus TUF Gaming x570

xaphod2

New member
Joined
Nov 30, 2020
Messages
1
First off thanks a million for the amazing guide, which is impressively written. The humour, the clarity, the details all speak to someone's experience as a semi/professional writer. Love it.

I got 10.15.0 installed per the guide and got that running complete with App Store, but turns out I need to get to 10.15.4 or newer for XCode (whole reason i'm installing macOS is to run xcode).
I tried booting the Big Sur installer from ISO/DVD image that I created, but that gets stuck at the apple logo before the progress bar shows.
I tried downloading someone's newer VMDK of catalina, but it also gets stuck on apple logo... i'm guessing stuck on apple logo = AMD problem that intel owners don't have? Am new to mac/vm-on-windows.
I tried VMWare workstation 15.1, 15.5, and 16.x versions, but all have the same issue. (Yes I unlocked them all/each time)
I tried virtualbox but had even worse luck with that so went back to VMware.
I tried updating 10.15.0 to 10.15.4, that also results in the same thing -- stuck on apple logo at boot.

Can anyone tell me if it is possible to get Catalina 10.15.4 (or newer), or better yet Big Sur running on win10? How?
System is win10, ryzen 2600, Asus TUF gaming x570 wifi-plus (not pro).
 
Last edited:

macmanster

New member
Joined
Jan 23, 2021
Messages
3
Howdy! I have almost exactly the same hardware as you; Windows 10 20h2, Asus TUF Gaming X570-PLUS WIFI and a 3700X. Did you get this working?

I don't have VMware, however, I'm using the very latest version of Virtualbox v6.1. Make sure to have the Virtualbox Guest Additions installed (the ones from the website aren't the latest so the next time you startup Virtualbox it will ask to update).

These are the following settings I've used

System > Motherboard
Disable "Boot Order" > "Floppy"
Chipset "ICH9"
Enabled All "Extended Features"
4096mb RAM

System > Processor
2 CPU
Checked "Enable PAE/NX"

System > Acceleration
Unchecked "Enable Nested Paging"

Display > Screen
Video Memory 128mb

Storage > SATA
Checked "Use Host I/O Cache"

USB > Select "USB 3.0 (xHCI) Controller"

Before starting the VM run the following in a command prompt (I did it in an elevated prompt); "VM NAME" is your VM's name...

cd "C:\Program Files\Oracle\VirtualBox"
VBoxManage.exe modifyvm "VM NAME" --cpuidset 00000001 000106e5 00100800 0098e3fd bfebfbff
VBoxManage setextradata "VM NAME" "VBoxInternal/Devices/efi/0/Config/DmiSystemProduct" "MacPro7,1"
VBoxManage setextradata "VM NAME" "VBoxInternal/Devices/efi/0/Config/DmiSystemVersion" "1.0"
VBoxManage setextradata "VM NAME" "VBoxInternal/Devices/efi/0/Config/DmiBoardProduct" "Iloveapple"
VBoxManage setextradata "VM NAME" "VBoxInternal/Devices/smc/0/Config/DeviceKey" "ourhardworkbythesewordsguardedpleasedontsteal(c)AppleComputerInc"
VBoxManage setextradata "VM NAME" "VBoxInternal/Devices/smc/0/Config/GetKeyFromRealSMC" 1
VBoxManage.exe modifyvm "VM NAME" -–cpu-profile "Intel Core i7-6700K"

The following is optional

VBoxManage setextradata "VM NAME" VBoxInternal2/EfiGopMode 5
VBoxManage setextradata "VM NAME" VBoxInternal2/EfiGraphicsResolution 1920x1080

I will post my results back after attempting to update the OS from Catalina 15.0 to whatever it lets me.
 
Last edited:

macmanster

New member
Joined
Jan 23, 2021
Messages
3
#UPDATE -- I was able to update to Big Sur 11.1



However, it thinks that there's an issue with my memory

 

macmanster

New member
Joined
Jan 23, 2021
Messages
3
#UPDATE 2: DOES NOT LIKE more than 2 cpu,works with 8192mb RAM but still only see's one slot. I couldn't get it to get past this and couldn't find a way to adjust the memory slots on Virtualbox.
 
Top Bottom