Bluetooth is not working well with msi b550m mortar

joezhang3

New member
Joined
Nov 16, 2020
Messages
1
Old build:

MSI b450m mortar
Ryzen 2600x
Radeon 5700XT

New build:

MSI b550m mortar
Ryzen 5800x
Radeon 5700xt

I upgraded the OS from Catalina to Big Sur alone with upgrading the platform to the new build. Everything is working fine EXCEPT: the bluetooth.

I had a broadcom wifi+bluetooth card with the model of BCM943602CS, which works pretty fine with the old build, but after upgrading to the new build, the connectivity of bluetooth devices is intermittently. Like bluetooth headset works intermittently, bluetooth keyboard has lags etc.

What I tried:

1. Move the SSD with the Big Sur OS back to the old build. the bluetooth works fine. Which seems like this is not a OS issue.
2. Switch to the windows OS on the new build, the bluetooth works fine. Which seems like the new build is not an issue. say the motherboard/processors/bios etc.

I am using OpenCore 0.6.3. The big difference between the old build and new build I noticed is the I SSDT-CPUR which is required for b550 motherboard, based on OpenCore's instruction https://dortania.github.io/OpenCore-Install-Guide/ktext.html#desktop . No idea if it is the root cause of the issue.

Help please.
 

neux.gabux

New member
Joined
Jan 20, 2021
Messages
2
Old build:

MSI b450m mortar
Ryzen 2600x
Radeon 5700XT

New build:

MSI b550m mortar
Ryzen 5800x
Radeon 5700xt

I upgraded the OS from Catalina to Big Sur alone with upgrading the platform to the new build. Everything is working fine EXCEPT: the bluetooth.

I had a broadcom wifi+bluetooth card with the model of BCM943602CS, which works pretty fine with the old build, but after upgrading to the new build, the connectivity of bluetooth devices is intermittently. Like bluetooth headset works intermittently, bluetooth keyboard has lags etc.

What I tried:

1. Move the SSD with the Big Sur OS back to the old build. the bluetooth works fine. Which seems like this is not a OS issue.
2. Switch to the windows OS on the new build, the bluetooth works fine. Which seems like the new build is not an issue. say the motherboard/processors/bios etc.

I am using OpenCore 0.6.3. The big difference between the old build and new build I noticed is the I SSDT-CPUR which is required for b550 motherboard, based on OpenCore's instruction https://dortania.github.io/OpenCore-Install-Guide/ktext.html#desktop . No idea if it is the root cause of the issue.

Help please.
Hi @joezhang3

May I know how you make the sound works?
I have same mainboard as yours, MSI B550M Mortar with Realtek ALC1200A in it. Been work around but couldn't make it.
 

giriaashish

New member
Joined
Jul 21, 2021
Messages
1
hi @zoezhang3 could you please share the efi for b550 mortar wifi. tried other efi didnt work. once in a while my previous intel hackintosh ssd boots when i copied the efi setting for b550 but very hard to make it boot usually gets stuck in verbose mode.
thanks in advance.
 
Top Bottom