Big Sur upgrade from Catalina failing on B450 I Aorus Pro Wifi, Ryzen 2600, XFX 7870

vanquish

Member
Joined
Nov 14, 2020
Messages
113
I have been running Catalina 10.15.7 for some time now and apart from the usual things like wifi and Bluetooth not working it was ok.

However, I wanted to install a fenvi 1200M Wifi/Bluetooth card but my B450 I has no PCIE slot for it. So I bought a Gigabyte A520M DS3H and Ryzen 3600.

I tried to use the A520 with Catalina but couldn't get past black screen with the Apple logo and as far as I know there was only one other person on this forum who was using the A520 motherboard. He tried to help, with his EFI but that didn't work either and I then could not get past the Gigabyte Bios logo. Eventually, I figured that was because he was running Big Sur, not Catalina so his EFI would not work.

I decided the best way forward would be to upgrade from Catalina to Big Sur using my current B450 I and Ryzen 2600. I updated to Open Core 0.6.8 and amended to config.plist and ran the upgrade. Now I am seeing the following on boot:


IMG_3369.jpeg

Followed by:

This version of Mac OS X I not supported on this platform.

Would I be correct in thinking the SMBIOS is not correct? At the moment it is set for MacPro1,1 but should I maybe try something different?
 
Top Bottom