Big Sur 11.0.1 - MSI B450 Tomahawk Max- 3800X - MSI 5700 XT - OC 0.6.3

pulsar7377

New member
Joined
Nov 20, 2020
Messages
1
After countless hours of trying, fixing and tweaking the EFI, I was finally able to install the latest macOS Big Sur.

I have attached the EFI.

the only thing you need to do is to add your own MLB, SystemSerialNumber and SystemUUID, I would advise to use the SMBIOS iMacPro1,1 to generate those serials... I had issues with other SMBIOS.

Screen Shot 2020-11-23 at 17.18.57.png

With that EFi, I was able to install Big Sur but I had 2 issues

the first one was that after rebooting for the first time Big Sur after the install, the monitor would stay black....

The fix is in the BIOS, you have to disable the Serial Port...

The second issue was that the Apple ID was not working. "Cannot communicate with the server" Error... Since I use Photos and iCloud I needed this to work...

To fix this you need to make your ethernet card "builtin"

you have all the information on how to do it here:

https://dortania.github.io/OpenCore-Post-Install/universal/iservices.html#generate-a-new-serial

don't bother checking your serial number it will work even though your serial is not recognized by Apple.

The most important is to make your Ethernet card "Built-in"

The EFI attached already has ssd-rmne.aml in the ACPI folder and NullEthernet.kext in the Kexts folder.

They have been disabled, you can just re-enable them and add your Ethernet MAC address in the ROM field and add your PCI Root in Device Property

such as below (address for the B450 Tomahawk Max) use the one given by Hackintosh tool for your motherboard.(see link above)

Screen Shot 2020-11-23 at 17.20.15.png

The B450 tomahawk does not have Wifi so no idea if Wifi will work with your motherboard.

Before that I had Catalina installed, and it has never been perfect, the OS seemed sluggish, the mouse was laggy...

With that Big Sur installation, everything works very well, no more issue with the mouse and the all experience is much better.
 

Attachments

  • EFI.zip
    3.1 MB · Views: 88

apriliars3

New member
Joined
Nov 14, 2020
Messages
5
I have same problem ("Cannot communicate with the server" ) with my MSI MAG B550 Tomahawk on Big Sur (Catalina works perfectly). I´ll try to fix it with Hackintool.
 

albofefe

New member
Joined
May 9, 2021
Messages
1
My warmest thanks to the OP for this, this guide saved me from countless hours, I'm an absolute newbie when it comes to coding and such stuff, but your EFI saved me from all that trouble and my Hackintosh has been working very well. Thank you so much 🥺😍
 
Top Bottom