Before updating to Monterey 12.3 Beta (21E5196i)

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,851
Apple have once again changed something that affects booting macOS on non Apple Hardware. However there is a simple fix. AppleMCEReporterDisabler.kext is required again to boot as something changed with the SMC. So for the time being include this kext in your EFI/Config to boot if you plan on installing the beta. Credit to Pavo for finding this information.

Thanks,
Shaneee
 

Attachments

  • AppleMCEReporterDisabler.kext.zip
    2.9 KB · Views: 394

marinekev88

Member
Joined
Oct 23, 2021
Messages
46
Just got the notice for 12.3 Beta 3 available. Anyone pull the trigger yet??

@Shaneee to clarify on Bluetooth, are you saying you don't use Bluetooth on your main rig, or that It works OTB with your config (not using the BlueToolFixup and IntelBluetoothFirmware kexts) ? I did find that with the IntelBluetoothFirmware and BlueToolFixup kexts enabled, my system was kind of buggy
 

muscledman94

New member
Joined
Dec 26, 2020
Messages
9
Made same experience with Monterey 12.3 Beta 3. Crashing and freezing all the time went back to official 12.2.1
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,851
Just got the notice for 12.3 Beta 3 available. Anyone pull the trigger yet??

@Shaneee to clarify on Bluetooth, are you saying you don't use Bluetooth on your main rig, or that It works OTB with your config (not using the BlueToolFixup and IntelBluetoothFirmware kexts) ? I did find that with the IntelBluetoothFirmware and BlueToolFixup kexts enabled, my system was kind of buggy
BT works OTB with the adapter I use.
 

Mymlan

New member
Joined
May 3, 2021
Messages
20
Hi, there,

I update Monterey 12.3 from 12.2.x,
but GPU performance is too slow..(RX 6900XT)

Someone resolve this problem?

Shaneee - _mtrr_update_action fix PAT - 10.13/10.14/10.15/11.0/12.0 patch is True.

I have no idea.
Please give me advise!
 

RyzeCooker

Donator
Donator
Joined
May 3, 2020
Messages
245
Reading other forums, there are problems with the Radeons even with Intel processors
bad graphics performance for me too, RX 5700 XT.
Reading other forums, there are problems with the Radeons even with Intel processors

Reading experiences, I'm gonna hold off. This sounds like a 12.3.1 will probably be out soon.
 

baronerosso

Donator
Donator
Joined
Sep 29, 2020
Messages
94
It seems that changing Device Properties in OC will fix it.

Basically, the RX 5700 XT become W5700X and this would solve the problems

Someone with RX 5700 XT upgraded to 12.3 might do some testing, I just downgraded to 12.2.1
 

Attachments

  • hack 5700 config.plist
    2.9 KB · Views: 31

errevi

New member
Joined
Mar 8, 2021
Messages
5
It seems that changing Device Properties in OC will fix it.

Basically, the RX 5700 XT become W5700X and this would solve the problems

Someone with RX 5700 XT upgraded to 12.3 might do some testing, I just downgraded to 12.2.1
grazie baronerosso, tested with a powercolor red dragon rx 5700 xt but can not boot, had to go back to 'unfairgva'
 

DarkSilentSC

Member
Joined
Jun 4, 2021
Messages
65
Perhaps power supply trick maybe can fix bluetooth issue? (Turn off PC, unplug power or switch off power supply for 30 sec+, and power back on)
Can I add that MCEReporterDisabler kext for 12.2.1 prior to it without breaking boot?
 

baronerosso

Donator
Donator
Joined
Sep 29, 2020
Messages
94
grazie baronerosso, tested with a powercolor red dragon rx 5700 xt but can not boot, had to go back to 'unfairgva'
Did you edit this to fit your Device Path?

PciRoot (0x0) / Pci (0x3,0x1) / Pci (0x0,0x0) / Pci (0x0,0x0) / Pci (0x0,0x0)
 

errevi

New member
Joined
Mar 8, 2021
Messages
5
Did you edit this to fit your Device Path?

PciRoot (0x0) / Pci (0x3,0x1) / Pci (0x0,0x0) / Pci (0x0,0x0) / Pci (0x0,0x0)
no need, the device path is exactly the same, double checked and got it working cleaning a typo, my bad
thanks again!
 
Last edited:

baronerosso

Donator
Donator
Joined
Sep 29, 2020
Messages
94
I have installed 12.3 on an external hard drive and I confirm that the Device Properties hack works, at least on my hackintosh.
In this thread in the Tonymacx86 forum, there are hacks for many other NAVIs
 
Top Bottom