AudioGod's Gigabyte Aorus X570 Pro, Pro Wifi, Ultra & Master - Big Sur & Monterey Beta - OpenCore 0.7.4 EFI

Would you like me to change the EFI SMBios over to MacPro7,1 from OpenCore V0.7.0 onwards?

  • Yes change it to SMBios MacPro7,1

    Votes: 12 75.0%
  • No keep it at SMBios iMacPro1,1

    Votes: 2 12.5%
  • Have Both 7,1 and 1,1 available to download

    Votes: 2 12.5%

  • Total voters
    16
  • Poll closed .

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
758
MacOS also stores things in NVRAM, so a NVRAM reset might have some unintended side effects.
Usually it's better to work with delete keys.
 

isaiah12345

New member
Joined
Jul 10, 2021
Messages
1
I keep getting crashing issues using this EFI. I tried the bone stock one from the first post and it did not work. I tried a fresh vanilla install of Big Sur and nothing. I also reset the NVRAM before booting. The sound also keeps cutting out unless I use alcid=28, which makes me have to manually swap to headphones instead of the speakers. I also don't have any overclock enabled on either the ram, manual, or PBO. I'm not sure what to try next. I have uploaded my EFI folder. Please help.

P.S. I am using Rev1.2 of the Aorus Master and my Mac drive is a WD Blue sata ssd. And I removed my serial number from the EFI for security purposes.
 

Attachments

  • EFI.zip
    5.6 MB · Views: 3

AntarcticPL

New member
Joined
May 29, 2020
Messages
14
After days of testing, happy to post my working EFI. See signature for more details. Make sure to insert your serial, ... in the Platforminfo.
I have not enabled Wifi or Bluetooth yet, due to using Monterey and bluetooth implementation is buggy (I believe). But should be easy to add later.
Started from AudioGods EFI, but had to add driver and some kexts. Probably possible to make it a bit more clean, but this one at least works very stable!
 

Attachments

  • EFI.zip
    7.3 MB · Views: 15

6R23MeCe

New member
Joined
Jan 22, 2021
Messages
9
you have to block the bluetooths path that you extract from your IO Reg and create a SSDT to do it with. I might actually have one from my old Z390 Master EFI somewhere that you could easily correct. Il have to have a hunt around and see if I can find it.
another thing you can do thinking about it is remove the USB map for the internal Bluetooth and this should have the same effect. I say should because things don’t always work out the way you think they will…lol

and awesome that airdrop now works on the internal Wlan, That must be a recent addition.
Stick with it and see how it goes.

you have to block the bluetooths path that you extract from your IO Reg and create a SSDT to do it with. I might actually have one from my old Z390 Master EFI somewhere that you could easily correct. Il have to have a hunt around and see if I can find it.


@AudioGod May I know how exactly block out the built-in bluetooths/WLAN via SSDT? Or any doc I could refer to.

Background:


Thanks a lot!!!
 
Last edited:

6R23MeCe

New member
Joined
Jan 22, 2021
Messages
9
@6R23MeCe Disabling the integrated bluetooth is rather easy, just remove the USB port it is connected to from the USB mapping.
Thanks for it!!!

So, supposed to?
1. remove the USB port that the build-in bluetooth uses
2. generate a new USBMap.kext
3. replace the old one with the new USBMap.kext
 

svan71

Donator
Donator
Joined
Oct 24, 2020
Messages
48
Does anyone know if the Aqantia 10GbE is working in Monterey for the Aorus Extreme?
 
Last edited:

DarkSilentSC

New member
Joined
Jun 4, 2021
Messages
29
Does anyone know if the Aqantia 10GbE is working in Monterey ?
Confirmed working on Monterey with some tweaking.
 

juliantoledo

New member
Joined
Dec 18, 2020
Messages
10
I was able to install Monterey 12.0.1 with @AudioGod's EFIs and I had to replace the intel smalltree kext with this one to get Ethernet working:

I wonder if small tree will get fix or if I should get a PCIe Ethernet card (and which one?)
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,429
I was able to install Monterey 12.0.1 with @AudioGod's EFIs and I had to replace the intel smalltree kext with this one to get Ethernet working:

I wonder if small tree will get fix or if I should get a PCIe Ethernet card (and which one?)

If it's anything like previous versions it'll come and go but won't stick around for long. I got fed up of WiFi speeds and bought this, https://amzn.to/3cBfm9L
Works OOB and works a treat.
 

juliantoledo

New member
Joined
Dec 18, 2020
Messages
10
If it's anything like previous versions it'll come and go but won't stick around for long. I got fed up of WiFi speeds and bought this, https://amzn.to/3cBfm9L
Works OOB and works a treat.
Thanks! I will try one of those, as you said, it did not stick around for long.

Edit: OrderedThe usb-c adapter on amazon and yes, it works OOB, I was able to remove the old network kext!
 
Last edited:

p2mmao

New member
Joined
Jul 2, 2021
Messages
22
I am using MSI B550 Mortar WiFi+5800X, The original 11.6 system recognizes and enables two USB3.1 buses, but now 12.0.1 only recognizes and enables one USB3.1 bus, and Bluetooth is controlled by the lost USB3.1 bus, so Bluetooth WIFI can't be used, how to break it? I have already done USB customization in Windows 10, in the 11.6 , this USB customization completely normal, btw, I also lost my wifi and ethernet after upgrade
 

DarkSilentSC

New member
Joined
Jun 4, 2021
Messages
29
Has anyone ran into issue of opencore suddenly booting all on its own? Tried XhciPortLimit=true, DisableRtcChecksum=true, applying FixShutdown-USB-SSDT.dsl, compiled with my own USB XHC0 path (_SB.PCI0.GP13.XHC0) but all these won't do anything uwu

Edit -- It seems the problem is getting worse-- I cannot find PMEE entry anywhere in my DSDT when I view it from MaciASL... Where to go from here? uwu
Edit2 -- Dorthania asks me to look for _PRWs in DSDT, but I get whole bunch of entries with GPPn entries... I'm totally lost on this one
 
Last edited:
Top Bottom