AudioGod's Gigabyte Aorus X570 Pro, Pro Wifi, Ultra & Master - Big Sur & Monterey Beta - OpenCore 0.7.4 EFI

Would you like me to change the EFI SMBios over to MacPro7,1 from OpenCore V0.7.0 onwards?

  • Yes change it to SMBios MacPro7,1

    Votes: 12 75.0%
  • No keep it at SMBios iMacPro1,1

    Votes: 2 12.5%
  • Have Both 7,1 and 1,1 available to download

    Votes: 2 12.5%

  • Total voters
    16
  • Poll closed .

DarkSilentSC

New member
Joined
Jun 4, 2021
Messages
29

Alright! Got it running! Will update my Success Stories for Aorus X570 Xtreme

I still don't know why bluetooth is not working.

If SmallTree is not working, then activate Aquantia 10GbE!
 
Last edited:

Bansaku

Member
Joined
May 3, 2020
Messages
49
F33 still no dice. Boy do I regret not doing the beta sooner before lightning striked :(

I don't think it's your BIOS version that's causing the issue. BIOS setting, yes! Make sure both CSM and fTPM (if you installed Windows 11) are DISABLED in the BIOS. Setting to Optimized Defaults will enable CSM again and has bit me a couple times causing unnecessary headaches. Other than that make sure OC Ryzen patch for 12.0 is correct with the proper quirks enabled.
 

DarkSilentSC

New member
Joined
Jun 4, 2021
Messages
29
I hope 4G Encoding is also disabled. The boot argument npci=0x2000 will cause boot to get stuck. Also IntelBluetoothInjector.kext also causes this, basing off from my Aorus X570 Xtreme
 

ivan20032003

New member
Joined
May 3, 2020
Messages
2
How's the boot time for everyone? I just updated to 12.0.1 and it does boot fine.. after about 3-5 minute lol.
everything else is working fine except sidecar of course.
 

wh1406

New member
Joined
Jul 7, 2021
Messages
8
has updated to Monterey , everything works fine except bluetooth, the problem is the bluetooth stops working from wake up, but if the hackintosh boots from power on , the bluetooth works good as on Big Sur. Monterey bugs or something else ?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Message to everybody.
The other day I had a disaster at home and had a huge power surge that took out half the electronics in my house including my Computer, So many parts got burnt out that I am now totally out of action until further notice and will be unable to update the thread EFIs for a little while until I replace most the inners of my PC.
Sorry to be the bearer of bad news all but it’s to much money and to close to Christmas for me to sort out quickly so for now this is me signing out but I will return and continue trying to make things better for all as best as I can.
So sorry all but this one is out of my control.
Big Love
AG
 
Last edited:

DarkSilentSC

New member
Joined
Jun 4, 2021
Messages
29
Message to everybody.
The other day I had a disaster at home and had a huge power surge that took out half the electronics in my house including my Computer, So many parts got burnt out that I am now totally out of action until further notice and will be unable to update the thread EFIs for a little while until I replace most the inners of my PC.
Sorry to be the bearer of bad news all but it’s to much money and to close to Christmas for me to sort out quickly so for now this is me signing out but I will return and continue trying to make things better for all as best as I can.
So sorry all but this one is out of my control.
Big Love
AG
Super sucks. I'm sorry to hear that has happened to you. Best of luck with electronics recovery during this horrible time for purchasing...
 

DarkSilentSC

New member
Joined
Jun 4, 2021
Messages
29
Update-- BrcmPatchRAM has 2.6.1 available today. If you want to get Bluetooth to work again in Monterey, download BlueToolFixup from 2.6.1 version, and add that kext into OC Config.plist along with IntelBluetoothFirmware.kext and you should be good to go. Do not include IntelBluetoothInjector.kext or you will not be able to boot.
 

xellDart

New member
Joined
Oct 29, 2021
Messages
1
Hi, I install fresh Monterey build, but I cant get ethernet working... I already try SmallTree all versions but none works

My hardware:
Ryzen 5900x
Aorus x570 Elite
RX 5700xt

All is working, except ethernet.....
This adapter works Aquantia 10GbE????
 

Pabo

Member
Joined
Sep 2, 2020
Messages
30
@Pabo I’m glad you find what happened to me funny mate. Deep Dude Deep.
I'm sorry, I'm sorry. I sent the wrong smiley. I would never allow myself to make fun of you for your misfortune ... You're helping us all here. On the contrary, I'm willing to send you some money to help. I apologize again...
 

tatofuma

Member
Joined
Jan 20, 2021
Messages
41
Hi bro, what I must change on efi to work perfectly with my aorus elite? I use macpro 7.1
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Hi, I install fresh Monterey build, but I cant get ethernet working... I already try SmallTree all versions but none works

My hardware:
Ryzen 5900x
Aorus x570 Elite
RX 5700xt

All is working, except ethernet.....
This adapter works Aquantia 10GbE????
The SmallTree kext is dead under Monterey I’m afraid. A alternative is being worked on but there’s nothing fully stable to replace it with as of yet.
You can try AppleGB.kext or one of its alias but the connection using that kext tends to drop out.

Post in thread 'Internet not working on I211-AT'
https://forum.amd-osx.com/index.php?threads/internet-not-working-on-i211-at.2189/post-14215
 

misterrm

New member
Joined
Oct 27, 2021
Messages
12
Hello AudioGod! I have similar build but i use only SSDT-EC.aml that i made at my own. I wonder if i should tweak my ACPI as yours. My hackintosh is running latest Big sur stable. Could you please take a look? I am not very familiar with the ACPI's, i did it following the Dortania's guide.


Also, i currently have MSI X570A-Pro and i want to switch it to other brand in order to get Monterey working. Do you recommend yours x570 Aorus? Or you would look for other one?
 

Attachments

  • ACPI.zip
    794 bytes · Views: 0
Last edited:

wh1406

New member
Joined
Jul 7, 2021
Messages
8
Yup all spot on for your board. 👍
Hi dude

I've updated to Monterey , everything works fine except bluetooth, the bluetooth stops working from wake up, but hackintosh can not be woken up by usb mouse click. have you met this problem ? much thanks.
 
Top Bottom