AudioGod's Gigabyte Aorus X570 Pro, Pro Wifi, Ultra & Master - Big Sur & Monterey Beta - OpenCore 0.7.4 EFI

Would you like me to change the EFI SMBios over to MacPro7,1 from OpenCore V0.7.0 onwards?

  • Yes change it to SMBios MacPro7,1

    Votes: 12 75.0%
  • No keep it at SMBios iMacPro1,1

    Votes: 2 12.5%
  • Have Both 7,1 and 1,1 available to download

    Votes: 2 12.5%

  • Total voters
    16
  • Poll closed .

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,358
This is my first fully functional Ryzen Hackintosh after many many years of intel builds and when I say fully functional I mean just that.
Everything is working bar SideCar of course as there's no IGPU and I'm using SMBios iMacPro1,1 but as for everything else goes like proper sleep, Wake, All iCloud functions, Handoff, AppleWatch Unlock etc etc all works beautifully.
I have fully mapped out USB manually on all ports and there's no micro stutters or freezes or anything else strange that you can think of.


Build Spec
  • CPU: Ryzen 9 5900X
  • Motherboard: Gigabyte AORUS X570 Pro (Bios Revision - F33a)
  • RAM: Corsair Pro Vengeance 32GB DDR4 3600Mhz (Tuned)
  • Graphics: Sapphire RX 5700 XT
  • Case : Lian Li PC-O11DW Dynamic.
  • NVMe: Samsung 970 EVO 1TB & Samsung 970 EVO Plus 1TB
  • SSD: Samsung 860 EVO 1TB
  • HDD: Seagate Barracuda 1TB
  • PSU: EVGA SuperNOVA 850 G5, 80 Plus Gold 850W
  • WiFi-Bluetooth: ABWB BCM94360CS2 802.11AC WI-FI With Bluetooth 4.0 PCIe
  • Sound: Onboard & Native Instruments Audio 6
  • Cooling : Arctic Liquid Freezer II 360 AIO
  • Installed Operating Systems: Big Sur - Monterey Beta - Windows 10 Pro
  • Bootloader: OpenCore 0.7.3

IMG_4564.jpeg
ACPI SSDT's
  • SSDT-USBX (USB power tables)
  • SSDT-PLUG (CPU power management)
  • SSDT-SBRG (Correcting EC, RTC memory & IRQ conflicts)
  • SSDT-SBUS-MCHC (SMBus Support)
  • SSDT-XHC (USB rename's)

Kexts
  • Lilu
  • VirtualSMC
  • WhateverGreen
  • AppleALC
  • RestrictEvents
  • SmallTreeIntel82576
  • AMDRyzenCPUPowerManagement
  • SMCAMDProcessor
  • USBMap

What Works
Sound including the case's front headphones 3.5mm port
Ethernet PortIMG_4566.jpeg
WiFi / Bluetooth
USB Type C, 3.0 & 2.0 (All ports Mapped & Open)
AirDrop
iCloud
Hardware Acceleration
iMessages
Facetime
Sleep & Wake
Sleep and Shutdown via the Power Button
Power Nap
Handoff
Netflix on Safari browser
Continuity
Apple Watch Unlock​
What Doesn't Work
SideCar
Bios Settings
  • Enter BIOS -> Press Delete -> Enter Setup
  • Save & Exit -> Load Optimized Defaults
  • Boot -> CSM Support -> Disabled
  • Boot -> Fast boot -> Disabled
  • Boot -> Secure boot -> Disabled
  • Settings -> IO Ports -> Above 4G Decoding -> Disabled
  • Settings -> IO Ports -> USB Configuration -> Legacy USB Support -> Auto


Screenshot 2021-08-11 at 18.45.53.png

Screenshot 2020-12-08 at 23.34.26.png

Screenshot 2020-12-08 at 23.35.58.png

Screenshot 2021-02-26 at 00.47.37.png

Screen Shot 2021-01-15 at 16.34.37.png

EFI Install Notes
Using PlistEdit Pro add your details by modifying the following



IMPORTANT - PATCH INFO FOR SETTING THE CORRECT CORE COUNT FOR YOUR CPU
Core Count patch needs to be modified to boot your system. Find the three algrey - Force cpuid_cores_per_package patches and alter the Replace value only.

Changing B8000000 0000/BA000000 0000/BA000000 0090* to B8 <CoreCount> 0000 0000/BA <CoreCount> 0000 0000/BA <CoreCount> 0000 0090* substituting <CoreCount> with the hexadeciamal value matching your physical core count.

Note: The three different values reflect the patch for different versions of macOS. Be sure to change all three if you boot macOS 10.13 to macOS 12

See the table below for the values matching your CPU Core Count.

CoreCountHexadecimal
6 Core06
8 Core08
12 Core0C
16 Core10
32 Core20
So for example a 6 Core 5600X Replace value would result in these replace values, B8 06 0000 0000/BA 06 0000 0000/BA 06 0000 0090
Or a 12 Core 5900X that I have it setup as standard would result in these replace values, B8 0C 0000 0000/BA 0C 0000 0000/BA 0C 0000 0090
Screenshot 2021-08-02 at 20.32.51.png

Nvram
Important - Before booting into MacOS using the new EFI for the first time make sure you reset your Nvram. (At the bootpicker press Space to reveal the option) Try to make this a habit and do it whenever you make system changes or upgrading the EFI to a newer version etc etc.

GPU
If your not using a RX 6800 or any other Navi or Big Navi GPU then remove agdpmod=ignore from the boot arguments.

Recovery Drive
I have the Recovery Drive and ClearNVRAM option hidden as standard in OpenCanopy, To reveal the options all you have to do is press the Space Bar when you get to the BootPicker.
X570 Master
users need to add the LucyRTL8125Ethernet.kext to the kext folder and config.plist to enable the 2.5gb Ethernet port that can be downloaded from here.

Power Gadget App
The AMDRyzenCPUPowerManagement.kext has been updated and has gone from good to Amazing so make sure you download the latest version of the Power Gadget App to make the most of it.
AMD.Power.Gadget.app.zip

If you need help then feel free to get in touch and do let me know how my EFI works for you.

The EFI has now been updated to the my latest version.
Changes made include,
  • Lilu 1.5.6,
  • AppleALC 1.6.5,
  • WhateverGreen 1.5.4,
  • VirtualSMC 1.2.7,
  • RestrictEvents 1.0.5,
  • LucyRTL8125Ethernet 1.1.0,
  • SMCAMDProcessor 0.7,
  • New Universal AMD Patches Monterey 12.0 Compatible,
  • SIP Can now be toggled within OpenCanopy,
  • OpenCanopy Icons Updated,
  • OpenCore Updated to Revision 0.7.4 (Monterey Beta 8 Ready),
  • Memory Mapping is now Being done via RestrictEvents,
  • About This Mac now displays the correct AMD Processor info done via RestrictEvents,
  • Plus other minor tweaks and changes to the config.

IMPORTANT SMBIOS CHANGE - As requested by many the SMBIOS has now been switched over to MacPro7,1 if you want to continue using iMacPro1,1 then all you need todo is replace the USBMap.kext with the 1,1 version and add SSDT-XHC to your ACPI and your Config.plist, Change agdpmod=ignore into agdpmod=pikera and add your 1,1 details. I will add a 1,1 conversion kit to download incase you need it.

Make sure you sign out of all icloud services before swapping over to the 7,1 EFI and Do not try and carry across your old 1,1 details to SMBIOS 7,1. You will need to create new Personal SMBIOS Details for MacPro7,1.
If you are using your real UUID and MAC address from your motherboard then these can carry over but not the Serial Number and MLB, These will need to be regenerated.

Note - If you are using a 6 or Less Core Ryzen then go into the Config,plist and under PlatformInfo->Generic Change the ProcessorType from 0 to 1537, This will list your CPU info correctly inside About This Mac.

Note 2 - The SmallTreeIntel82576.kext is now fully working under Monterey 12.0 as of Beta 8.

Note 3 - If you are using Catalina then in the Config.plist under UEFI->APFS set the MinDate and MinVersion to -1 or Catalina will not boot.

Current EFI - OpenCore 0.7.4 (04/10/2021) SMBIOS MacPro7,1
 

Attachments

  • Gigabyte X570 Pro 1,1 Conversion Kit.zip
    5.7 KB · Views: 245
  • Gigabyte X570 Pro 7,1 074 EFI.zip
    5.7 MB · Views: 119
Last edited:

Aenterhy

New member
Joined
May 3, 2020
Messages
1
Great config, thanks for such detailed information! Using this I was able to fix my mapping issue on similar config :)
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,358
I will be updating my EFI alongside OpenCore Releases so if you’re using it be sure to check in from time to time for updates.
 

pancheesy4sheezy

New member
Joined
Jun 1, 2020
Messages
24
This is one of the best posts I've seen because it's so detailed.

Any clue if this works on a Aorus x570 Elite? I'm stuck in the efi creation process and wanna try for big sur. We have similar parts, but the motherboard.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,358
This is one of the best posts I've seen because it's so detailed.

Any clue if this works on a Aorus x570 Elite? I'm stuck in the efi creation process and wanna try for big sur. We have similar parts, but the motherboard.
Thanks for the kind words buddy.
I would say yes it will but disable the usbmap.kext to start with as the elite lacks usb-c ports so my map will be wrong but my SSDT-XHC.aml should be fine and allow full usb so yeah give it a try with the usb.kext disabled and let me know how it works for you please? :)
Also if it boots up ok then go into your energy saver and check to make sure you have power nap and start up automatically after power failure and if that’s all there then check sleep and wake and shut down and make sure there’s no long unnecessary hangs before it does the process.
 

pancheesy4sheezy

New member
Joined
Jun 1, 2020
Messages
24
I took out the usbmap.kext and edited it off the plist. that was about it. I'm not gonna lie, even with videos, tutorials, and help, I'm definitely an idiot when it comes to stuff like this on the hackintosh in general.

Don't know if it helps,

But I have:

Ryzen 5 3600X
Aorus x570 elite
Gigabyte 5700 XT
 

pancheesy4sheezy

New member
Joined
Jun 1, 2020
Messages
24
Nope...didn't add anything. I'm pretty hackintosh illiterate even though I've taken hours and hours reading guides and videos, but I do appreciate your help. Legitimately. You're like the only dude that has ever responded to anything I've ever typed with knowlege.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,358
@pancheesy4sheezy Download GenSMBIOS from here - https://github.com/corpnewt/GenSMBIOS
Then do the following,

Run GenSMBIOS, pick option 1 for downloading MacSerial and Option 3 for selecting out SMBIOS. This will give us an output similar to the following:

#######################################################
# iMacPro1,1 SMBIOS Info #
#######################################################

Type: iMacPro1,1
Serial: C02YX0TZHX87
Board Serial: C029269024NJG36CB
SmUUID: DEA17B2D-2F9F-4955-B266-A74C47678AD3



The order is Product | Serial | Board Serial (MLB)

The Type part gets copied to Generic -> SystemProductName.

The Serial part gets copied to Generic -> SystemSerialNumber.

The Board Serial part gets copied to Generic -> MLB.

The SmUUID part gets copied to Generic -> SystemUUID.

453128831_Screenshot2020-01-16at19_25_01.thumb.png.7a9beac3ccc0096941fc4a0ec07b8248.png
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,358
@pancheesy4sheezy Here you go mate,
I have entered fresh details for you and disabled the usbmap.kext.
give this a try if the steps above confuse you buddy. :)

Replace the config.plist in the EFI with this one and try the installer again.

Soon as you download it il delete the download so nobody else can use the details. :)
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,358
okay. edited! gonna test it again
Good Luck,
if it don’t work then try again using the plist I made for you in my last post.

By the way I double checked those details I created for you to make sure they are not being used by any other user and they are clean and exclusive so if you didn’t do that yourself then use my plist instead.
Clean details only really matter when your logging into iCloud.
 

pancheesy4sheezy

New member
Joined
Jun 1, 2020
Messages
24
AUDIOGOD, YOU ARE A GOD SEND.

The installer is running! I legitmately cannot thank you enough! I appreciate you responding to me and helping me when you clearly did not need to and this is after hijacking your thread. People like you are why this community is amazing!
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,358
AUDIOGOD, YOU ARE A GOD SEND.

The installer is running!
Awesome, I’m here if you need any help mate and once your booted up check the things I said to check a good few posts ago and report back.

I can probbaly sort your USB properly out for you too And make you a map for your board. (It will run fine without it too temp)

Oh and if your not already then make sure you use the bios setting I have laid out on my main post. That’s very very important.
 

pancheesy4sheezy

New member
Joined
Jun 1, 2020
Messages
24
Awesome, I’m here if you need any help mate and once your booted up check the things I said to check a good few posts ago and report back.

I can probbaly sort your USB properly out for you too And make you a map for your board. (It will run fine without it too temp)
Wow. I cannot thank you enough. It's currently installing so it'll be awhile, but WOW. My USB Map on my Catalina was trash. I have one USB-C/lightning port on my case and before I updated to 5.4 (previously on 5.2 Catalina), it was working properly then it died. I tried my hand, but I kept on bricking my computer and I got tired of destroying it so I settled.

update/edit: Installed successfully! currently trying to mount the HD to copy the EFI over. Thanks!!!
 
Last edited:
Top Bottom