AudioGod's Gigabyte Aorus X570 Pro, Pro Wifi & Ultra - Big Sur OpenCore 0.7.0 EFI

Would you like me to change the EFI SMBios over to MacPro7,1 from OpenCore V0.7.0 onwards?

  • Yes change it to SMBios MacPro7,1

    Votes: 12 75.0%
  • No keep it at SMBios iMacPro1,1

    Votes: 2 12.5%
  • Have Both 7,1 and 1,1 available to download

    Votes: 2 12.5%

  • Total voters
    16
  • Poll closed .

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
617
As far as I remember this will just not provide the Mac SMBIOS, but ACPI modifications will still be applied. But if SSDTs were written properly this is not an issue.
This would fix for example Asus Armory Crate not working properly when booting through OC.

But you can't install BootCamp on Windows anymore.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
796
@Aluveitie That’s All correct buddy.
With the above change and assuming the SSDTs are all done properly to bypass other OS then that’s OC fully bypassed for other OS. 👍
Bootcamp is a waste of time on a Hackintosh though As far as I’m concerned..lol
it works but totally pointless in my eyes and I would prefer windows and Linux to not think it’s a Mac. Infact that is essential to my job.
 
Last edited:

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
906
Bootcamp is a waste of time on a Hackintosh though As far as I’m concerned..lol

I use it for one specific reason. I use OC to boot between Windows and macOS. I don't have the OC picker enabled so my boot drive is set by the NVRAM. Just change it to Windows on macOS if I want to game and reboot to macOS when I'm done with the Bootcamp option in Windows (y)
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
796
I use it for one specific reason. I use OC to boot between Windows and macOS. I don't have the OC picker enabled so my boot drive is set by the NVRAM. Just change it to Windows on macOS if I want to game and reboot to macOS when I'm done with the Bootcamp option in Windows (y)
Fair enough but couldn’t you just use hot keys to switch OS if needed?
I can’t have OpenCore Injecting smbios info into win or Linux. that would be a disaster for my work so bypassing it is a must for me.
 

Shaneee

Administrator
Staff member
The AMD Guy
Joined
Mar 13, 2020
Messages
906
Could do yeah but it's more Apple like and I'm rarely in Windows anyway :p
 

andi

New member
Joined
Oct 5, 2020
Messages
2
Sound including the case's front headphones 3.5mm port
... but excluding Mics ( front & rear ) & rear Line in ?
I spent some Time using alc-verb to change VRef inputs ( works ) and changing boost ( Amp in step ) for pin comlpex 18 , 19 & 1a ( does not work ) what might perhaps have to do with Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: Mono
Processing caps: benign=0, ncoeff=127
As long as there is no documentation - what could be done?

BTW : MoBo Gigabyte X570 Aorus Master : using itlwm , LucyRTL8125Ethernet , IntelBluetoothFirmware & IntelBluetoothInjector ( BT Headphones work , mic in does not work ) - but external USB Mic & Video works
 
Last edited:

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
796
... but excluding Mics ( front & rear ) & rear Line in ?
I spent some Time using alc-verb to change VRef inputs ( works ) and changing boost ( Amp in step ) for pin comlpex 18 , 19 & 1a ( does not work ) what might perhaps have to do with Node 0x20 [Vendor Defined Widget] wcaps 0xf00040: Mono
Processing caps: benign=0, ncoeff=127
As long as there is no documentation - what could be done?

BTW : MoBo Gigabyte X570 Aorus Master : using itlwm , LucyRTL8125Ethernet , IntelBluetoothFirmware & IntelBluetoothInjector ( BT Headphones work , mic in does not work ) - but external USB Mic & Video works
line input doesn’t work on a Ryzen Hack using AppleALC period, (The Acidanthera Crew don't support us AMD boys to add support to it unless somebody gives them the fix already done basically) An External DAC is always the better way togo.
The only thing I use my internal audio is for sound alarts.
 
Last edited:

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
796
Please Note people, My thread is meant for people using the same setup as me or wanting to use my EFI, if you want my help with something that has nothing to do with my thread or EFI then please do not spam it asking me questions but instead start a new thread and topic and tag me in it and I will always be more then happy to help.

Same thing with private messages, Ask me if it’s ok to PM me first instead of bombarding my inbox with questions ...It can be quite overwhelming at times.

Thanks Everybody and please don’t think I’m being moody or anything like that. 👍
 

mjgha

Member
Joined
May 4, 2020
Messages
30
Oh dear,
more info needed to be able to say anything really?
system spec would be a good starting place pal?
also if your not using a Aorus pro, ultra, master or elite then this EFI and thread is not for you and I am not a free for all ask me anything guy sorry. If you want help that has nothing to do with my Thread then start a new one and message me via that buddy so as not to spam my thread with info that’s not helpful to others using my EFI.

I use the USBMap.kext to turn off certain ports within the mapping and the SSDT is the back bone and renames but if I wanted everything mapped and open then the usbmap.kext is not needed.
I will remove my post and make a new thread.. Better to straight forward indeed... Better for the community. Appreciate your reply anyhow!
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
796
I will remove my post and make a new thread.. Better to straight forward indeed... Better for the community. Appreciate your reply anyhow!
That would be awesome but no need to delete your post, it’s not a problem and thank you for being understanding. :)
 

highend

New member
Joined
May 4, 2020
Messages
7
Thank you for your hard work. I would suggest one thing. To use AMD Smart Access Memory (SAM), we need to enable 4G decoding. Please make a version with 4G decoding enabled.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
796
Thank you for your hard work. I would suggest one thing. To use AMD Smart Access Memory (SAM), we need to enable 4G decoding. Please make a version with 4G decoding enabled.
No can do,
firstly resize bar is a no no in macOS and secondly and most importantly I have above 4g disabled for a very good reason.
Gigabyte boards have a serious flaw when it’s enabled and your frame rate jumps right down to badly to leave it on.
Talk to gigabyte if you want It fixed or enable it and remove the boot argument if you don’t mind your card running at half the frame rate it normally does, (benchmarking doesn’t reveal the problem but real gaming does big time)

As it clearly states on page one of my thread that you must of missed or not read.

IMPORTANT NOTE - PLEASE DISABLE ABOVE 4G DECODING IN THE BIOS. I HAVE DISCOVERED A SERIOUS FLAW IN THE GIGABYTE BIOS EFFECTING THE GPU PERFORMANCE AND THE ONLY WAY TO FIX IT WAS TO DISABLE ABOVE 4G DECODING IN THE BIOS AND TO ADD THE BOOT ARGUMENT npci=0x2000 TO THE CONFIG.PLIST.
 
Last edited:
Top Bottom