AudioGod's Gigabyte Aorus X570 Pro, Pro Wifi & Ultra - Big Sur OpenCore 0.6.9 EFI

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
587
... first of all, thank you for the hint with space bar, it works fine, and I reversed the changes I made (HideAuxiliary and AppleDebug);
and yes, I created my installer step by step according to the oc 0.6.6 guide;
in the folder 'com.apple.recovery.boot' I have the BaseSystem.dmg (655420141) and the BaseSystem.chunklist (2560), this should be OK;
and I'm using your EFI, I removed agdpmod=pikera from the boot args and - of course - I added my SystemSerialNumber, SystemUUID, MLB and ROM ...
I think the problem is your installer bud. looking at your screenshot that’s not right and they are not even OpenCore faults.

Is this system a first time install or do you have Catalina or older installed on a separate disk? If you do then try booting into the older OS using my EFI and then just upgrade the system from within. If you using anything older then Catalina then you will need to use a older version of the ethernet kext. (That’s if you have a older version of macOS installed at all..lol)
 
Last edited:

wore

New member
Joined
Feb 13, 2021
Messages
11
... my stick is 16GB, FAT32 formatted, command
'python macrecovery.py -b Mac-E43C1C25D4880AD6 -m 00000000000000000 download'

python 3.9.1 (64bit)
macrecovery.py (14899)

what could be worng?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
587
... my stick is 16GB, FAT32 formatted, command
'python macrecovery.py -b Mac-E43C1C25D4880AD6 -m 00000000000000000 download'

python 3.9.1 (64bit)
macrecovery.py (14899)

what could be worng?
Creating a installer via windows goes wrong quiet a lot. (ive seen it time and time again with other users over at insanelyMac) It’s why it was one of the first questions I asked you.
Again looking at your screenshot, the errors being thrown up are not related to OpenCore. I don’t know what else to suggest but if I was you I would recreate the installer and try again And write that off as the problem at least. Don’t use an image, use gibMacOs to retrieve Big Sur and follow the guide.
Since i have started this thread you are the very first person who can’t get it working and that’s including people not using the Aorus Pro. With all that in mind you tell me what you think the problem is if you disagree with me bro?
 

wore

New member
Joined
Feb 13, 2021
Messages
11
... I have another SSD with Catalina (as I told you), but it's disconnected;
when connected, I'm able to boot it, but I don't want to mix it up with the desired installation of Big Sur;
and there are no older MAC OS installations on my machine;
I know that the SmallTreeIntel82576.kext is just for Catalina and Big Sur ...
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
587
... I have another SSD with Catalina (as I told you), but it's disconnected;
when connected, I'm able to boot it, but I don't want to mix it up with the desired installation of Big Sur;
and there are no older MAC OS installations on my machine;
I know that the SmallTreeIntel82576.kext is just for Catalina and Big Sur ...
If you can boot into Catalina using my EFI then you know 100% that the problem is within your Big Sur installer.
Its that’s simple bro as the OC config is the same for both.

And dude, I don’t know what you do and don’t know so I will be as clear as I can incase you didn’t know. Don’t take offence or get moody. I’m trying to help you not mock you...lol
 

wore

New member
Joined
Feb 13, 2021
Messages
11
Creating a installer via windows goes wrong quiet a lot. (ive seen it time and time again with other users over at insanelyMac) It’s why it was one of the first questions I asked you.
Again looking at your screenshot, the errors being thrown up are not related to OpenCore. I don’t know what else to suggest but if I was you I would recreate the installer and try again And write that off as the problem at least. Don’t use an image, use gibMacOs to retrieve Big Sur and follow the guide.
Since i have started this thread you are the very first person who can’t get it working and that’s including people not using the Aorus Pro. With all that in mind you tell me what you think the problem is if you disagree with me bro?
I followed the OpenCore Installation Guide 0.6.6, and the gibMacOS was no longer available after 0.6.4;
can I use this one from 0.6.4?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
587
I followed the OpenCore Installation Guide 0.6.6, and the gibMacOS was no longer available after 0.6.4;
can I use this one from 0.6.4?
I used gibmacos this morning and downloaded 11.2 and created a installer so i don’t know where you got that info from but it’s incorrect. gibmacos has nothing to do with OpenCore.
get it from here buddy.

Ah sorry I understand what you mean now....lol...yes it’s not part of OpenCore utils anymore since 0.6.4 but the standalone version is still going strong. :)
 

wore

New member
Joined
Feb 13, 2021
Messages
11
I just performed the download via gibMacOS for Big Sur 11.2:
InstallAssistant.pkg (12208832027)
what should the folder and file structure look like?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
587
I just performed the download via gibMacOS for Big Sur 11.2:
InstallAssistant.pkg (12208832027)
what should the folder and file structure look like?
I’m going crazy today sorry...your doing it in windows right? I’m thinking in macOS still....ggggrrrrr, it’s one of them days.
create your installer for big sur in Catalina. Copy the downloaded installer to cat and run it so it places the big sur installer into your apps and create your usb installer from there. Windows is a pain in the behind to make a installer for big sur and I’ve just seen that they have changed the way to do it over on the vanilla guide yet again.
 

wore

New member
Joined
Feb 13, 2021
Messages
11
I used gibmacos this morning and downloaded 11.2 and created a installer so i don’t know where you got that info from but it’s incorrect. gibmacos has nothing to do with OpenCore.
get it from here buddy.

Ah sorry I understand what you mean now....lol...yes it’s not part of OpenCore utils anymore since 0.6.4 but the standalone version is still going strong. :)
... please look at
so you will see there's no reference to gibMacOS;
but now I'll create a new installer and report to you later ...
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
587
... no idea how to create a Big Sur boot stick under Windows?
I would appreciate it so much if you could help ...
For ease plug back in your Catalina drive and create your big sur install via that. It will work 1st go and Tbh you can’t go wrong.
If I ever need to do it in windows I do it inside a virtual disk of macOS. I have done it inside windows saying that but it was totally different to the way the guide says to do it now.
 

wore

New member
Joined
Feb 13, 2021
Messages
11
For ease plug back in your Catalina drive and create your big sur install via that. It will work 1st go and Tbh you can’t go wrong.
If I ever need to do it in windows I do it inside a virtual disk of macOS. I have done it inside windows saying that but it was totally different to the way the guide says to do it now.
... but after creating the stick from within Catalina I have to swap in your EFI, am I right?
because my Catalina EFI is from early April 2020 and would not work with Big Sur I think;
at this time, I had some issues with sleep/wake and other minor problems that you solved ...
 

wore

New member
Joined
Feb 13, 2021
Messages
11
... but after creating the stick from within Catalina I have to swap in your EFI, am I right?
because my Catalina EFI is from early April 2020 and would not work with Big Sur I think;
at this time, I had some issues with sleep/wake and other minor problems that you solved ...
... and please let me know if you have any ideas about creating a Big Sur boot stick from within Windows;
I need such a procedure for those people who don't have a Mac OS yet ...
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
587
... but after creating the stick from within Catalina I have to swap in your EFI, am I right?
because my Catalina EFI is from early April 2020 and would not work with Big Sur I think;
at this time, I had some issues with sleep/wake and other minor problems that you solved ...
Yes exactly that but you should also use my EFI with your Catalina install as like I’ve said a few times to you now it’s totally cross compatible. One EFI to control them all not an Efi for cat and a different one for big sur. this is wrong.
as for windows install guides, again like I’ve already said doing it in windows is a pain to do as your working outside of the macOS environment so you need to use stuff like explorer++ and partition wizard to do it all with. The OC guide explains it best.
 

alclonky

New member
Joined
Jan 23, 2021
Messages
13
I observed that spotlight is not working after a warm boot from windows to macOS.
If I cold boot directly to macOS it works. Anyone can confirm that problem?.

Another question: Is thunderbolt working under macOS if I add an Gigabyte titan ridge add-in card?

 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
587
I observed that spotlight is not working after a warm boot from windows to macOS.
If I cold boot directly to macOS it works. Anyone can confirm that problem?.

Another question: Is thunderbolt working under macOS if I add an Gigabyte titan ridge add-in card?
I just tried spotlight under the conditions you mentioned and I’m happy to report theres no such problem over here.

Titan Ridge will work yes but just like with Intel hacks your going to need to reflash the card for it to work properly.
 

Geenopippo

New member
Joined
Feb 16, 2021
Messages
19
Hello. I have a question to ask. I have recently built and High Sierra Hack With Gigabyte Aorus Ultra X570, Ryzen 3950x and a 1080ti. Everything Works Except Wifi, Bluetooth and USB. Can I use Your Efi? With what modification? I'm noob and can't map my own USB. Thanks!
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
587
Hello. I have a question to ask. I have recently built and High Sierra Hack With Gigabyte Aorus Ultra X570, Ryzen 3950x and a 1080ti. Everything Works Except Wifi, Bluetooth and USB. Can I use Your Efi? With what modification? I'm noob and can't map my own USB. Thanks!
Hi, yes you can use my EFI with your setup but you need to add the intel kexts for wifi and bluetooth that you can get from here.

Plus you will need to change the ethernet kext to this version for High Sierra
 
Top Bottom