AudioGod's ASUS ROG STRIX X570-E GAMING - Big Sur & Monterey Beta - OpenCore 0.7.4 EFI

carrilhos

New member
Joined
May 23, 2021
Messages
6
I took your Config.plist, added my member configurations, and added the kexts.

Wi-fi turns on, and does not find any network, I already checked the antenna, and even the internal settings on the motherboard.
Bluetooh does not detect hardware.

Can I have a driver conflict? I will share my kext folder so that they can try to give me a light. Sorry, if I'm doing something stupid.

The config.plist, I got exactly yours, I just changed my serial settings.

I changed, cleaned the nvram, restarted and nothing.

This intrigues me, on the motherboard I loaded the settings informed in the post, in addition, I checked if the bluetooth and wifi are active.

Kexts folder:
 

Attachments

  • Captura de Tela 2021-05-25 às 10.39.14.png
    Captura de Tela 2021-05-25 às 10.39.14.png
    55.8 KB · Views: 6
  • Captura de Tela 2021-05-25 às 10.40.27.png
    Captura de Tela 2021-05-25 às 10.40.27.png
    14.8 KB · Views: 5
  • Captura de Tela 2021-05-25 às 10.40.38.png
    Captura de Tela 2021-05-25 às 10.40.38.png
    60.7 KB · Views: 4
  • Captura de Tela 2021-05-25 às 10.40.54.png
    Captura de Tela 2021-05-25 às 10.40.54.png
    26.9 KB · Views: 5
  • Captura de Tela 2021-05-25 às 10.46.52.png
    Captura de Tela 2021-05-25 às 10.46.52.png
    108.7 KB · Views: 5
  • Captura de Tela 2021-05-25 às 10.46.52.png
    Captura de Tela 2021-05-25 às 10.46.52.png
    108.7 KB · Views: 6
  • Captura de Tela 2021-05-25 às 10.47.52.png
    Captura de Tela 2021-05-25 às 10.47.52.png
    151.9 KB · Views: 6

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
I took your Config.plist, added my member configurations, and added the kexts.

Wi-fi turns on, and does not find any network, I already checked the antenna, and even the internal settings on the motherboard.
Bluetooh does not detect hardware.

Can I have a driver conflict? I will share my kext folder so that they can try to give me a light. Sorry, if I'm doing something stupid.

The config.plist, I got exactly yours, I just changed my serial settings.

I changed, cleaned the nvram, restarted and nothing.

This intrigues me, on the motherboard I loaded the settings informed in the post, in addition, I checked if the bluetooth and wifi are active.

Kexts folder:
it’s got nothing to do with your settings or the EFI itself or anything else you may of thought you have done.
Use heliport to connect to a WiFi spot.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
One other thing to do to get Bluetooth going is turn off the system fully and disconnect it from the mains, wait a few mins and then plug it back in and boot back up. Bouncing around from windows to macOS can break the Bluetooth firmware and that’s how you bring it back.
I don’t personally recommend using the Intel wireless as it mostly causes trouble somehow. I prefer removing it and replacing it with a native card that just works with no messing.
 

carrilhos

New member
Joined
May 23, 2021
Messages
6
About the heliport, I already got to test it, and for that reason, I had tried to use the itlwm kext. I installed it again, with the settings of the new config.plist, and I have the following message.

Regarding Bluetooth, I'm going to turn everything off and wait, to see if it returns to life.

Here in Brazil it is not so easy to find good pci-e bluetooth cards. One of the reasons for buying a motherboard with native bluetooth.

Again I thank you very much for your help.
 

Attachments

  • Captura de Tela 2021-05-25 às 12.27.51.png
    Captura de Tela 2021-05-25 às 12.27.51.png
    54.5 KB · Views: 4

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
About the heliport, I already got to test it, and for that reason, I had tried to use the itxtwm kext. I installed it again, with the settings of the new config.plist, and I have the following message.

Regarding Bluetooth, I'm going to turn everything off and wait, to see if it returns to life.

Here in Brazil it is not so easy to find good pci-e bluetooth cards. One of the reasons for buying a motherboard with native bluetooth.

Again I thank you very much for your help.
AliExoress is the only option for me here in the U.K. and it takes around 3 or 4 weeks for the card to arrive but it’s worth the wait. Can you not use them over in Brazil?

for the WiFi you could try dropping down to v1.2.0.0 instead and see if that works better for you.

Heres a link to the very card I use and from the Chinese Supplier, I’m sure they ship worldwide.
 

carrilhos

New member
Joined
May 23, 2021
Messages
6
AliExoress is the only option for me here in the U.K. and it takes around 3 or 4 weeks for the card to arrive but it’s worth the wait. Can you not use them over in Brazil?

for the WiFi you could try dropping down to v1.2.0.0 instead and see if that works better for you.

Heres a link to the very card I use and from the Chinese Supplier, I’m sure they ship worldwide.

Incredible tip to turn off the computer, I usually do not have the habit of turning off at the source, so I might never find out without your tip. Bluetooth and wifi worked.

I have problems with the bluetooth microphone, this problem occurs for those who use native card?

I will buy this card through Aliexpress, here it takes around 60 days to arrive. Any board tips so that we can solve the problem of the internal microphone, or do you think it is possible to fix this in the next versions?

I am researching a lot on the subject I found a user on this forum reporting some changes for compatibility with Supreme FXS1220A


Have you tried configurations related to this?

For now, thank you very much, my experience with hackintosh has been incredible.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Incredible tip to turn off the computer, I usually do not have the habit of turning off at the source, so I might never find out without your tip. Bluetooth and wifi worked.

I have problems with the bluetooth microphone, this problem occurs for those who use native card?

I will buy this card through Aliexpress, here it takes around 60 days to arrive. Any board tips so that we can solve the problem of the internal microphone, or do you think it is possible to fix this in the next versions?

I am researching a lot on the subject I found a user on this forum reporting some changes for compatibility with Supreme FXS1220A


Have you tried configurations related to this?

For now, thank you very much, my experience with hackintosh has been incredible.
It’s nothing but the Bluetooth connection not being great due to the Intel kext. You could try logging the problem with the devs of the kext and see if they can fix it but otherwise i really don’t know other then you can actually run the Bluetooth without the kexts and some people find it works better that way.
Try it and see if it helps,
go into the Config.plist and under Kernel->Add find the bluetooth kexts (4 and 5 I think) and set enabled to no, save and restart and try your bluetooth mic again.
 
Last edited:

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
@carrilhos The problem with the internal mic input is the kext being used just doesn't work for anybody wanting to use a mic input on a AMD build regardless of what board and CPU you are using.. There’s two options to get around it.

1, you can replace the AppleALC kext with VoodooHDA but at the expense of a noticeable drop in sound quality.
2, Use a External SoundCard or DAC.

Option 2 is by far the best option as the VoodooHDA kext is just to much of a dip in sound quality for my liking.
 

Aganar

New member
Joined
Jun 26, 2020
Messages
9
Hello realy nice work, but can you tell me
How you bypassed OpenCore when booting into any OS other then MacOS so Windows and Linux won’t see your PC as a MAC?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Hello realy nice work, but can you tell me
How you bypassed OpenCore when booting into any OS other then MacOS so Windows and Linux won’t see your PC as a MAC?
Go into the Config.plist and set the following.
  • Kernel -> Quirks -> CustomSMBIOSGuid -> True
  • PlatformInfo -> UpdateSMBIOSMode -> Custom
Plus make sure your SSDTs are all set to work in MacOS only and you’re covered.
It’s not 100% bypassed as booter quirks can still have an effect but it’s as good as you can get it and windows and Linux won’t see your SMBIOS info anymore.
 

dannymak

Member
Joined
Sep 8, 2020
Messages
32
Im happy i have a same motherboard as you, Thank you.(y)
I have similar spec, but i have AMD 6900XT reference card, should i add agdpmod=ignore in boot arug?
 

carrilhos

New member
Joined
May 23, 2021
Messages
6
@carrilhos The problem with the internal mic input is the kext being used just doesn't work for anybody wanting to use a mic input on a AMD build regardless of what board and CPU you are using.. There’s two options to get around it.

1, you can replace the AppleALC kext with VoodooHDA but at the expense of a noticeable drop in sound quality.
2, Use a External SoundCard or DAC.

Option 2 is by far the best option as the VoodooHDA kext is just to much of a dip in sound quality for my liking.

Solved the sound and bt problems, I will buy the external cards, but unfortunately before thinking about making a hackintosh I had already bought a nvm-e gen 4 that arrived today. And the XPG Gamming S70 brand.

It happens that when trying to format a drive, in the disk utility it restarts. Probably some configuration I need to do to get around this, can you help me?

I changed settings on the motherboard to gen4, gen3, auto, but the error persists, I've been researching NvmeFix.Kext, but I don't know if this is a solution.

I have a gen3 disk, and as I showed you earlier, an installation went perfectly.

Does this case have a solution?
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
758
Hard to say without knowing the exact model. My Corsair Gen4 NVMe is working without any issues.
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
758
That one is using a InnoGrit IG5236 controller, could not find any references relating to running them under MacOS.

You could check if there is a firmware upgrade available. Certain Samsung drivers would not work without an upgrade on MacOS.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
Im happy i have a same motherboard as you, Thank you.(y)
I have similar spec, but i have AMD 6900XT reference card, should i add agdpmod=ignore in boot arug?
If you are using my EFI then agdpmod=ignore is already in the boot arguments.
 

Aganar

New member
Joined
Jun 26, 2020
Messages
9
Go into the Config.plist and set the following.
  • Kernel -> Quirks -> CustomSMBIOSGuid -> True
  • PlatformInfo -> UpdateSMBIOSMode -> Custom
Plus make sure your SSDTs are all set to work in MacOS only and you’re covered.
It’s not 100% bypassed as booter quirks can still have an effect but it’s as good as you can get it and windows and Linux won’t see your SMBIOS info anymore.
Thank you very much
 

AMDPUSH

Donator
Donator
Joined
May 2, 2020
Messages
178
WIFI v2.0.0. alpha
I tried it, it is better, i don't know for the realibility
at least it can detect the network

 
Last edited:

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,386
WIFI v2.0.0. alpha
I tried it, it is better, i don't know for the realibility
at least it can detect the network

I gave up on the Intel wireless kexts a while ago now, I hate the size of them and the problems they always have. It’s just so much easier to spend £35 on a BCM94360NG and swap that puppy around. Then you have airdrop, Apple Watch unlock, and everything else with no kext or messing around needed.
 

AMDPUSH

Donator
Donator
Joined
May 2, 2020
Messages
178
I gave up on the Intel wireless kexts a while ago now, I hate the size of them and the problems they always have. It’s just so much easier to spend £35 on a BCM94360NG and swap that puppy around. Then you have airdrop, Apple Watch unlock, and everything else with no kext or messing around needed.
When i came back to Catalina from Big sur the Wifi was disable and even blocked the previous kext. as i haven't the same kext for Catalina...the system even freeze, and even after the reboot the wifi was deaded. perhaps i have to put the same new WIFI kext in the Catalina EFI.
 
Top Bottom