AudioGod's ASUS ROG STRIX X570-E GAMING - Big Sur & Monterey Beta - OpenCore 0.7.4 EFI

Squizzy

New member
Joined
Jun 24, 2020
Messages
10
Good luck buddy.
ok. followed dortania this time with big sur installation. havent installed bluetooth and wifi yet, but sleep (biggest issue last time) looks like it is fixed. it recovers from sleep and no fans at fullspeed :) is there anything i should test now? bluetooth and wifi is necessary for continous feature, right?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
ok. followed dortania this time with big sur installation. havent installed bluetooth and wifi yet, but sleep (biggest issue last time) looks like it is fixed. it recovers from sleep and no fans at fullspeed :) is there anything i should test now? bluetooth and wifi is necessary for continous feature, right?
If it works and feels good and benchmarks look right then just enjoy it my friend. :)
What wireless card do you intend on using?
 

lukakeiton

Member
Joined
Jul 26, 2020
Messages
31
@AudioGod Hi again! what about m2 nvme 4.0? I haven't set this option, as you do, on bios and everything is working properly. I recently have bough a samsung 980 PRO 2 tb, it should work as 4.0, shouldn't it?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
@AudioGod Hi again! what about m2 nvme 4.0? I haven't set this option, as you do, on bios and everything is working properly. I recently have bough a samsung 980 PRO 2 tb, it should work as 4.0, shouldn't it?
I leave my m2 slots on auto and have ran a 980 pro on my board without realising and it was fine.
you can even leave pcie slots all on auto too and it’s fine with a Navi/big Navi as long as you use ignore instead of pikera.
Some cards don’t like it so in the guide I mark the slots to be set at gen3 but it’s purely me just playing it safe for other users.
 

lukakeiton

Member
Joined
Jul 26, 2020
Messages
31
I leave my m2 slots on auto and have ran a 980 pro on my board without realising and it was fine.
you can even leave pcie slots all on auto too and it’s fine with a Navi/big Navi as long as you use ignore instead of pikera.
Some cards don’t like it so in the guide I mark the slots to be set at gen3 but it’s purely me just playing it safe for other users.
So, If I understand correctly, there is no need to set m2 to 3.0. Have you run a speed test?

I am planning to buy one big navi gc.

Lol 🤣
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
So, If I understand correctly, there is no need to set m2 to 3.0. Have you run a speed test?

I am planning to buy one big navi gc.

Lol 🤣
It will just default to gen3 if left on auto. Don’t quote me but to this day I don’t beleave there’s any gen 4 support on macOS. Speeds will feel and perform the same.

Im waiting to get my hands on a 6800xt myself but the prices the Manufactures are asking are just to stupid. Even after a trade discount it’s still nearly double what it should cost. I’ve started hassling AMD like a did with Asus in the hope that to shut me up they give me 6800xt at normal price or for free…lol.
Its been nearly 2 weeks of me asking every other day and no luck yet. 😂😂
 

lukakeiton

Member
Joined
Jul 26, 2020
Messages
31
With this software I can control leds from AIO water cooler. Not as I expected but this is a begging.

 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
With this software I can control leds from AIO water cooler. Not as I expected but this is a begging.

OMG talk about old skool apps…lol…does that still work with Big Sur?
It’s like 9 years old.…..Oh hold on it was updated in 2018, Blimey 🤣
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
Well... maybe samsung 980 pro 2tb at pcie 4.0 working properly impress you? 🤣
That does impress me yes. You saying benchmarks in big sur are showing 4.0 speeds for the 980 pro then?
Thats awesome if that is indeed the case. 👏
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
@Cosmin You need to make a couple of simple changes to use the EFI with your board.
in the config.plist under Booter->Quirks change DevirtualizeMmio to Yes and SetupVirtualMap to No
Also you might want to disable the USBMap.kext for now as I’m sure it won’t be the same but il double check that for you now and confirm.

Update - Yep disable the USBMap.Kext from the config.plist aswell.
 

Cosmin

Member
Joined
Aug 7, 2020
Messages
30
@Cosmin You need to make a couple of simple changes to use the EFI with your board.
in the config.plist under Booter->Quirks change DevirtualizeMmio to Yes and SetupVirtualMap to No
Also you might want to disable the USBMap.kext for now as I’m sure it won’t be the same but il double check that for you now and confirm.

Update - Yep disable the USBMap.Kext from the config.plist aswell.
Thanks, but my install stucks at 12 min remaining time on the graphicall install stage: it restarts itself, and I have no new item in OC boot items other than install mac os big sur....
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
Thanks, but my install stucks at 12 min remaining time on the graphicall install stage: it restarts itself, and I have no new item in OC boot items other than install mac os big sur....
Is that with the above settings changed?
Also did you format the disk to APFS?
Once the install process starts and it restarts did you leave it and see what happens and if you did did it just boot back to the first welcome page at install?
 

carrilhos

New member
Joined
May 23, 2021
Messages
6
Hi people.
I am using this EFI and it is sensational, I even managed to migrate to the bigsur 11.5 version.

I temporarily solved the problem of the internal microphone with an external sound card, simple.

But, I still couldn't get the Asus Strix E-Gamming's native Bluetooth and Wifi to work.

I downloaded the drivers as described, but I still find it difficult to make the correct configuration for them to work.

Can you help me by informing if I need to change any flag in the bootargs or even remove some configuration of the current EFI for native BT and WIfi to work?

Thank you very much in advance.

.Captura de Tela 2021-05-25 às 07.54.49.png
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,335
@carrilhos Add your SMBIOS details to the new config.plist I have attached to this post and then Replace your Config.plist with the new one. I have added the kexts needed for the intel wireless to the kernel and all you need to do is download the kexts and add them to your Kext folder inside the EFI.

WiFI Kext - AirportItlwm_v1.3.0_stable_BigSur.kext.zip
BlueTooth Kexts - IntelBluetooth.zip

Let me know if that works for you buddy?
Good Luck. :)
 

Attachments

  • Config.plist.zip
    7 KB · Views: 7
Top Bottom