Audio Interface Stuttering with Ryzen 3200G

juneloon

New member
Original poster
Aug 8, 2020
2
1
3
Hey everyone. I'm having issues with my Komplete Audio 6 audio interface on my OpenCore 0.6.0 Ryzen 3200G Mojave build.

Description of the issue:
The audio interface's output is crackly and stutters all the time, but not always with the same intensity. Sometimes there are only a few stutters per minute, but most of the time it's constant crackling.

Some things to get out of the way first:
  • My system audio is working fine with the AppleALC kext. The issue lies with my USB powered audio interface.
  • The interface works fine on my Windows 10 installation, and it works fine when plugged into a genuine MacBook Pro, so it's not an issue with the interface itself.
  • The interface used to work flawlessly on my old hackintosh build, which ran Mojave on Clover with an Intel 4670k CPU and Gigabyte H87-HD3 motherboard. That motherboard gave out recently, so for better or for worse I chose to make a Ryzen build (specs are in my signature).
My EFI folder's current state:
  • ACPI contains SSDT-EC-USBX.aml (made by me - renames XHC1 to SHCI).
  • Drivers contains HfsPlus and OpenRuntime.
  • Kexts contains AppleALC, Lilu, RealtekRTL8111, USB-Map (made by me), VirtualSMC and WhateverGreen.
  • config.plist is set up following the basic OpenCore guide for Ryzen + adjustments for FileVault.
  • boot-args: keepsyms=1 debug=0x100 alcid=1 npci=0x2000
Things I've tried:
  • I tried manual USB mapping, following the Dortania OpenCore guide. I took the 'long route' all the way through - making my own SSDT-EC-USBX and USB Map kext. It was a success, but made no difference to my audio issue.
  • I tried plugging the interface into different USB ports. The crackling kind of 'switched' to random levels of intensity as I went through each port, but all had the issue.
  • I tried using a powered USB hub.
  • I tried turning off 'serial port' (?) in my BIOS settings.
  • I tried GenericUSBXHCI.kext, XLNCUSBFix.kext and AMDTscSync.kext.
  • The SMBIOS I am using is iMac14,2 - I was recommended that one on the OpenCore guide due to my Nvidia card. However I have also tried the iMacPro1,1 and the issue is still there. I could try others.
  • I tried sleeping the system and waking it again.
  • There is a brief section in the OpenCore post-install guide called 'Fixing USB Power', which provides an AML file. It didn't mention anything about AMD but I tried it for the heck of it & it didn't do anything.
  • I tried changing the sample rate of the interface in Audio MIDI Setup to 44.1KHz and 48KHz.
  • I tried installing old Komplete Audio 6 OS X drivers from the Native Instruments website, but the installation fails.
  • I tried booting with Clover with roughly equivalent settings - same.
Things I've heard:
  • I saw a reddit post where someone suggested adjusting the voltages of my USB ports in the BIOS settings, but I don't think my BIOS has such settings.
  • I saw someone suggest the issue is that the CPU is one of the Ryzen 'G' series, which has known issues with audio, but most of the people I saw with those audio issues were having system audio issues, and one of the solutions people were giving was to get an audio interface like I already have. So I'm very unclear on that. If it's the 3200G, I could try to return it and get a 3100 (or something else?) but I would have to act soon.
Any ideas? I really appreciate any help or further suggestions - anything. I'm really determined to find a solution if possible.

Thank you
 
Last edited:

ardweebno

New member
Aug 14, 2020
21
5
3
For what it is worth, I have been having almost the exact same problem, but my equipment is a bit different.

CPU : Ryzen 5 3600
M/B : ASRock X570 Taichi (bios 3.20)
Sound : Focusrite Scarlett 4i4 3rd gen
EFI. : OpenCore 0.5.7 (setup per Dortania guide)

Symptoms: While booted into Catalina (10.15.6), any given USB sound device may work for a few seconds or a few minutes, but eventually each interface will output progressively worse audio, sounding something like 8-bit chiptune music at a very low bitrate. If given long enough, the output just stops. Also, while this is going on, there are a ton of log messages in the system console from the kernel talking about output sound interface unable to keep, as well as eventual coreaudio bus resets. Sometimes I can simply unplug the interface and then reconnect it, and the audio will clean up for a little while, but it always fails eventually.

Here is where it gets interesting. While chasing an unrelated bluetooth issue, I read on another forum that the BT issue was having were experienced by others after they upgraded macOS from 10.15.0 to 10.15.1. Since BT uses the USB bus for data, I thought this might be related to the USB sound problems I am having. So, I stuff in a new drive, used the same EFI folder for Catalina and installed Mojave (10.14.6). Now my USB problems are gone. No more crackles, no more random bus resets, no lockups.

TL;DR: USB ports were garbage under Catalina. Used the same EFI for a bare metal Catalina build, USB ports no work.



Disregard this message. After using the system for a few more hours, the audio drops came back. :(
 
Last edited:

PeeJay

New member
May 11, 2020
1
0
1
I have the same stuttering issue with one of my usb audio interfaces, which is of my own design. I've never spent the time to debug it properly but it seems to be a quirk with how mac os uses the isosynchronous endpoints in the usb stack. I don't know if it's "wrong" as such, but it's definitely different from windows and linux which both work normally.
TLDR: It's likely not fixable without new firmware, find another usb interface!