AsRock X570 Creator Ryzen 9 3900X RX6900XT LG Ultrafine 5K 2x Thunderbolt 3 Opencore 0.7.1 Working

tony7711

New member
Joined
Nov 22, 2020
Messages
1
Thanks @AudioGod , @CaseySJ , @iGPU for your kind help!

my OC 0.5.8 EFI can not upgrade to newer Big Sur from 11.0.1; and my RX6900XT will not turn on with OC 0.5.8; by inspired by Audiogod's great work; I modified his ASUS ROG STRIX X570-E GAMING EFI with my old Opencore 0.5.8 EFI that CaseySJ and iGPU helped me on the SSDTs. This combined OC 0.7.1 makes everything work and I am now on Big Sur 11.4 (upgrade successfully from Software Update of System Preferences)

Build Spec
  • CPU: AMD Ryzen 9 3900X
  • Motherboard: AsRock X570 Creator
  • Graphics: amd RX 6900 XT
  • NVMe: Corsair Force Series MP600 2TB Gen4 PCIe X4
  • PSU: Corsair RMX Series RM850x 80 Plus Gold Fully Modular ATX Power Supply
  • WiFi-Bluetooth: Fenvi T919
  • Sound: Onboard Audio and Speakers on LG Ultrafine 5K
  • Operating Systems: Big Sur, Windows 10 Pro
  • Bootloader: OpenCore 0.7.1
  • SMBios MacPro7,1
What Works
2xOnborad Thunderbolt 3 !!!
LG Ultra 5K and Pro Display XDR working perfectly on TB3 port, using 6900XT two DP out to motherboard, monitor TB3 connect to mother board TB3 port.

Sound including the case's front headphones 3.5mm port, Most Importan
Sound/speakers/Camera on LG Ultrafine 5K (Need to be cold start. LG 5K Speakers/Camera not working when restart the computer)
USB-C Ports on back of LG 5K (Need to be cold start. LG 5K USB-C not working when restart the computer)
Ethernet Ports 10Gb on board.
WiFi / Bluetooth
USB Type C, 3.0 & 2.0 (All ports Mapped & Open)
Sleep & Wake
Sleep and Shutdown via the Power Button
Power Nap
Hardware Acceleration
AirDrop
iCloud
iMessages
FaceTime
AppleTV


What Doesn't Work
Sidecar
LG 5K or Pro Display XDR not working directly connent 6900XT USB-C port.

Almost perfect for me. Thanks again for all friends here!

If you happened to have the same MB and was struggled a little; please download and fill-in all your UUID info. If you see any error or mistake I have, or you have any better suggestion, please also let me know.

My reference, thanks Audiogod!
 

Attachments

  • AsRockX570CreatorPost.zip
    4.4 MB · Views: 45
Last edited:

Hackingway

New member
Joined
Jun 8, 2021
Messages
16
Thanks @AudioGod , @CaseySJ , @iGPU for your kind help!

I modified Audiogod's ASUS ROG STRIX X570-E GAMING EFI with my old Opencore 0.5.8 EFI that CaseySJ and iGPU helped me on the SSDTs to make 2 on board TB3 working. But my OC 0.5.8 EFI can not upgrade to newer Big Sur from 11.0.1. This combined OC 0.7.1 make everything working and I am now on Big Sur 11.4

Build Spec
  • CPU: AMD Ryzen 9 3900X
  • Motherboard: AsRock X570 Creator
  • Graphics: amd RX 6900 XT
  • NVMe: Corsair Force Series MP600 2TB Gen4 PCIe X4
  • PSU: Corsair RMX Series RM850x 80 Plus Gold Fully Modular ATX Power Supply
  • WiFi-Bluetooth: Fenvi T919
  • Sound: Onboard Audio and Speakers on LG Ultrafine 5K
  • Operating Systems: Big Sur, Windows 10 Pro
  • Bootloader: OpenCore 0.7.1
  • SMBios MacPro7,1
What Works
2xOnborad Thunderbolt 3 !!!
LG Ultra 5K and Pro Display XDR working perfectly on TB3 port, using 6900XT two DP out to motherboard, monitor TB3 connect to mother board TB3 port.

Sound including the case's front headphones 3.5mm port, Most Importan
Sound/speakers/Camera on LG Ultrafine 5K (Need to be cold start. Restart LG 5K Speakers not working)
USB-C Ports on back of LG 5K (Need to be cold start. Restart LG 5K Speakers not working)
Ethernet Ports 10Gb on board.
WiFi / Bluetooth
USB Type C, 3.0 & 2.0 (All ports Mapped & Open)
Sleep & Wake
Sleep and Shutdown via the Power Button
Power Nap
Hardware Acceleration
AirDrop
iCloud
iMessages
FaceTime
AppleTV


What Doesn't Work
Sidecar
LG 5K or Pro Display XDR not working directly connent 6900XT USB-C port.

Almost perfect for me. Thanks again for all friends here!

If you happened to have the same MB and was struggled a little; please download and fill-in all your UUID info. If you see any error or mistake I have, or you have any better suggestion, please also let me know.

My reference, thanks Audiogod!
Hi,

I have a ASUS Pro WS X570. I have been using AudioGod's EFI and most things are fine but I think my USB speed is not correct and the Machine is sluggish after a wake. I want to build my own environment. Can you point me to some guide or video I can learn from. I know the Opencore Vanila guide but I guess one needs to build an environment specific for one's mother board.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,344
Hi,

I have a ASUS Pro WS X570. I have been using AudioGod's EFI and most things are fine but I think my USB speed is not correct and the Machine is sluggish after a wake. I want to build my own environment. Can you point me to some guide or video I can learn from. I know the Opencore Vanila guide but I guess one needs to build an environment specific for one's mother board.
When using my Efi with anything other then what I made it for or what I recommend using it with, things like the USBMap will have to be created by yourself otherwise like you are seeing Usb will not be right.
As for the sluggish side of life, that’s got zero to do with a EFI 99.9% of the time buddy.

For your USB Mapping the easy way.
 
Last edited:

Hackingway

New member
Joined
Jun 8, 2021
Messages
16
When using my Efi with anything other then what I made it for or what I recommend using it with, things like the USBMap will have to be created by yourself otherwise like you are seeing Usb will not be right.
As for the sluggish side of life, that’s got zero to do with a EFI 99.9% of the time buddy.

For your USB Mapping the easy way.
Hey @AudioGod thanks. I understand. I removed the USBMap kext from the EFI and from the config.plist and it wakes better. Now I have to figure out how to manufacture my own USB Map I guess. More learning :). Being a novice, I could not figure it out, but slowly... or maybe will just buy a MacPro if the wife agrees !
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,344
Hey @AudioGod thanks. I understand. I removed the USBMap kext from the EFI and from the config.plist and it wakes better. Now I have to figure out how to manufacture my own USB Map I guess. More learning :). Being a novice, I could not figure it out, but slowly... or maybe will just buy a MacPro if the wife agrees !
Use the App I sent you via the link to do your USB Mapping. It’s very easy to use. Full instructions on how to use it can be found on the GitHub. :)
 

Kalbey

New member
Joined
Oct 5, 2021
Messages
2
@tony7711 @AudioGod thank you for the help provided.

@tony7711 Ive been working on it for 1-2 months and infact just last week finished a build based on your success. Asrock creator 570 and amd 5950x/rtx 3070. Everything is fully functional as tested on Normal hdmi.

Im using an APPLE XDR DISPLAY and connected GPU DP to MOBO DP. With a thunderbolt out from MOBO. But can’t seem to get any signal on the XDR. Can you please help me understand on downloading UUID or changing any settings in pc. Or any steps I am missing. I’m not quite as advanced with the deeper pc science as this was my first ever build.
 

Kalbey

New member
Joined
Oct 5, 2021
Messages
2
I’m running windows 10 not boot camp.. just looking to connect the xdr monitor
 
Top Bottom