AsRock B550M Pro4, Ryzen 5 3600, can't install.

binkman71

New member
Aug 23, 2020
2
0
1
Hi all! First time posting, been reading for awhile though.

Decided to try my hand at building a Ryzen based Hackintosh with OpenCore 0.6. Built the bootable USB stick from a MacBook Pro with the latest Catalina install (10.15.6) from the App Store. Built my EFI and Config.plist following the various guides, and utilizing SSDTime (and others) on the machine in question through a Windows install. Built everything on the MacBook on the USB stick, ran the Config.plist through the sanity checker website at slowgeek.com, and so forth.

On the system in question, I boot to the USB, choose to install Catalina, get walls of text scrolling by, and then it just stops. Often at different places. Sometimes I get to "Mac system successfully initialized" other times it stops before that, for example: "VirtualSMC efend: @ auto" (though it has stopped on other messages as well). But then it just never proceeds any further. I even attempted to look at the log files OpenCore wrote out the USB stick, but I can't seem to interpret most of what is there.

I've made sure ot include the required SSDT-CPUR.aml for the B500 chipset. I've tried swapping out SSDT-EC-USBX-DESKTOP.aml for the individual files SSDT-EC.aml and SSDT-USBX.aml, to no avail. If I use the individual file or the two files makes no difference. I've double checked all the Config.plist settings, and the sanity checker says it is all fine. I applied the patches mentioned in the OpenCore install guide for my third generation Ryzen CPU. Did I miss something?

The hardware:

AsRock B550M Pro4 updated to BIOS v1.20 (Realtek ethernet)
AMD Ryzen 5 3600 Matisse CPU (not overclocked)
Corsair Vengence RGB Pro 32GB (2x16GB) DDR4-3200 RAM
Crucial P1 1TB NVME PCIe3x4 SSD

Any assistance greatly appreciated!
 

Potato007

Member
Aug 16, 2020
31
7
8
hi, does restart / shutdown work for you without the need to turn off the PSU? I have a very similar MB > ASrock B550M ITX/AC
 

PLOPZA

New member
Sep 15, 2020
1
0
1
Hiya, I also have:

AsRock B550M Pro4 updated to BIOS v1.20 (Realtek ethernet)
AMD Ryzen 5 3600 Matisse CPU (not overclocked)
G.SKILL Aegis 32GB (2 x 16GB) ddr4-3200
msi 5500xt 8gb gpu
Silicon Power 1TB NVMe

Same issue with shutdown/restart as well as wake from sleep
 

Hbg1968

Member
Aug 18, 2020
61
5
8
Australia
Same issue with shutdown/restart as well as wake from sleep
There are known issues with sleep/hibernation and AMD CPU's. There is further info here

For AMD:

Fret not, for their is still hope for you as well! AMDRyzenCPUPowerManagement.kext can add power management to Ryzen based CPUs. Installation and usage is explained on the repo's README.md -
I have installed this, however I have not found anything to do with Sleep yet.

I just set mine to never sleep and just shut it down at night, like we all used to with Windows 95 etc.
 
  • Like
Reactions: PLOPZA