AMD ryzen 5 4600h?

electrowizard

New member
Joined
Feb 7, 2021
Messages
17
I tried macOS Mojave, Catalina, bigSur installers on both clover and OC but non of them worked...
Many people with similar laptop cpu told me that it's time waste and it's impossible to boot macOS on Ryzen 5 4600h laptops...
So don't waste your time and patience...
And thanks all for help...
You guys are awesome...
I'll put my efi here if I'm able to boot...
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,429
@electrowizard Please try boot with this EFI. I'm not expecting it to work but it's a debug build. Let it try boot the isntaller then boot back to Windows and upload the log file now located in your EFI partition.
 

Attachments

  • EFI_DEBUG.zip
    1.3 MB · Views: 33

electrowizard

New member
Joined
Feb 7, 2021
Messages
17
@electrowizard Please try boot with this EFI. I'm not expecting it to work but it's a debug build. Let it try boot the isntaller then boot back to Windows and upload the log file now located in your EFI partition.
Log file
 

Attachments

  • opencore-2021-02-08-220633.txt
    256 KB · Views: 21
Last edited:

misache

New member
Joined
May 23, 2020
Messages
3
Ai plaga grafica integrata [vega], vezi in bios daca merge activata doar placa video dedicata altfel nu faci nimic
(...)
 

Shaneee

The AMD Guy
Staff member
Administrator
Joined
Mar 13, 2020
Messages
1,429

Ashro22

New member
Joined
Aug 29, 2021
Messages
1
Hi, I'm also struggling with AMD Zyzen 5 4600h, just wanted to know if you managed to make progress ??
Thanks in advance for your answer
 

Middleman

Member
Joined
Jan 29, 2021
Messages
60
Anyone with success on ryzem 5 4000 series laptops ?
I've MSI Bravo 15 with ryzen 5 4600h and Radeon 5500m GPU
GPU is supported...
I thought to let you know, you may like to try this EFI that I've created.
I have an Atari VCS which has a Ryzen APU that I use this build to boot both
Big Sur and Monterey with. The AMD kernel build is already present.
I've also added the RX5500's device-id into the Device Properties section,
and enabled a RX5500 SSDT aml in the ACPI section, so it should work. Just
remember to repopulate the PlatformInfo section with your SMBIOS,
system serial and UUID values.

You may also like to make sure your BIOS settings match the following
before booting:

Boot Configuration > Fast Recovery > Off
Peripheral Configuration > Trust Platform Module > Disabled
ACPI Table/Features Control > HPET Support > Disabled
CPU Related Setting > SVM Support > Enabled, SVM Lock > Disabled, SMM Code Lock > Disabled
Above 4GB MMIO > Enabled
H2OUve Configuration > Disabled
Boot > USB Boot > Enabled, EFI Device First > Enabled
Boot Type > Dual Boot Type
AMD PBS > Discrete GPU's Audio > Keep HW Default Setting
 

Attachments

  • EFI.zip
    21.6 MB · Views: 86

funkyman

New member
Joined
Mar 27, 2021
Messages
4
@electrowizard Please try boot with this EFI. I'm not expecting it to work but it's a debug build. Let it try boot the isntaller then boot back to Windows and upload the log file now located in your EFI partition.
Hi Shaneee.I've tried your EFI_DEBUG installing High Sierra and I stucked on message : ACPI Error: 1 table load failures,15 successful (20160930/tbxfload-342)

I've created bootable USB in my other hackintosh by createinstallmedia command and added your EFI_DEBUG.

My laptop specs:

Computer: LENOVO IdeaPad Gaming 3 15ARH05
CPU: AMD Ryzen 5 4600H (Renoir, RN-A1)
3000 MHz (30.00x100.0) @ 3992 MHz (40.00x99.8)
Motherboard: LENOVO LNVNB161216
BIOS: FCCN16WW, 01/05/2021
Chipset: AMD Promontory/Bixby FCH
Memory: 8192 MBytes @ 1597 MHz, 22-22-22-52
- 4096 MB PC25600 DDR4 SDRAM - Samsung M471A5244CB0-CWE
- 4096 MB PC25600 DDR4 SDRAM - Samsung M471A5244CB0-CWE
Graphics: NVIDIA GeForce GTX 1650 (TU117M) [Lenovo]
NVIDIA GeForce GTX 1650, 4096 MB GDDR6 SDRAM
Graphics: AMD Radeon (Renoir) [Lenovo]
AMD Radeon Vega, 512 MB DDR4 SDRAM
Drive: SAMSUNG MZALQ256HAJD-000L2, 250.1 GB, NVMe
Sound: NVIDIA, Device ID: 10FA
Sound: AMD Raven/Renoir/Van Gogh/Cezanne/Rembrandt - Audio Processor - HD Audio Controller
Network: RealTek Semiconductor RTL8168/8111 PCI-E Gigabit Ethernet NIC
Network: RealTek Semiconductor, Device ID: C822
OS: Microsoft Windows 10 Home (x64) Build 19042.1165 (20H2)
 
Last edited:

Naphtha

New member
Joined
Sep 11, 2021
Messages
1
No way to get a working config.plist for this GPU? I'm trying from yesterday to let start the installation, but i have always the same error like for the others user. The problem is the integrated Vega GPU or the CPU ? i have an 5600m discrete too, any possibility to disable the Vega and let works only the 5600m for make an hackintosh?
 

svet6ma

New member
Joined
Oct 10, 2021
Messages
2
Greeting you. I'm also very interested, and want to try macos.
Ryzen 5 4600H/ GTX 1650

It would be very helpful if someone who has experience tried to get this work. And tutorials also appreciated. Let me know if something achieved.
(Email Removed for Privacy Concerns)
 
Last edited by a moderator:

svet6ma

New member
Joined
Oct 10, 2021
Messages
2
I thought to let you know, you may like to try this EFI that I've created.
I have an Atari VCS which has a Ryzen APU that I use this build to boot both
Big Sur and Monterey with. The AMD kernel build is already present.
I've also added the RX5500's device-id into the Device Properties section,
and enabled a RX5500 SSDT aml in the ACPI section, so it should work. Just
remember to repopulate the PlatformInfo section with your SMBIOS,
system serial and UUID values.

You may also like to make sure your BIOS settings match the following
before booting:

Boot Configuration > Fast Recovery > Off
Peripheral Configuration > Trust Platform Module > Disabled
ACPI Table/Features Control > HPET Support > Disabled
CPU Related Setting > SVM Support > Enabled, SVM Lock > Disabled, SMM Code Lock > Disabled
Above 4GB MMIO > Enabled
H2OUve Configuration > Disabled
Boot > USB Boot > Enabled, EFI Device First > Enabled
Boot Type > Dual Boot Type
AMD PBS > Discrete GPU's Audio > Keep HW Default Setting
Is there any tutorials and would it work for GTX1650 - also?
 
Top Bottom