AMD PowergadgetPowerManagement app permissions

henkiew

New member
Joined
Jun 23, 2020
Messages
6
Hi,

I have question about the AMD PowergadgetPowerManagement app

According to the developer the fan speed settings are rembered after a reboot, but I can not seem to get this working, I have the app in my login items, but when going to the fan menu I always have to give the app permission to change. After that it works ok. Is there a way to avoid this message?

I am using the 0.6.6 release.

Screenshot 2021-02-25 at 13.07.09.png
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
566
As far as I know the fan speeds are not persisted. Simplest way to achieve this is setting the desired values in the BIOS.
 

henkiew

New member
Joined
Jun 23, 2020
Messages
6
As far as I know the fan speeds are not persisted. Simplest way to achieve this is setting the desired values in the BIOS.
OK. Look at my question to the developer here.

'This have been implemented in recent versions. Automatic adjustment is enabled by default"
And do you get the same message? Because I can not seem find anything about this.

And the BIOS setting on my Gigabyte is not followed. (quiet mode on gigabyte x570). I use the latest version of opencore
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
566
Automatic power adjustment, which does down clock the CPU, has been enabled by default. That has nothing to do with controlling the fans.
 

henkiew

New member
Joined
Jun 23, 2020
Messages
6
Automatic power adjustment, which does down clock the CPU, has been enabled by default. That has nothing to do with controlling the fans.
OK. That's my bad then. So do you think that's impossible? I can imagine i am not the only one who thinks thats an issue.
I will maybe do a feature request for that. Just remember the last used fanspeeds and restore them at startup.
And what about the popup doe you think I can get rid of that also?
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
566
You can deactivate the popup by adding -amdpnopchk to the boot-args.

I think most set up a fan curve in the BIOS because you can do that based on temperature, having fans running quieter when not needed. With the Power Gadget you can just set a fixed fan speed which is only helpful in some edge cases.
 

henkiew

New member
Joined
Jun 23, 2020
Messages
6
You can deactivate the popup by adding -amdpnopchk to the boot-args.

I think most set up a fan curve in the BIOS because you can do that based on temperature, having fans running quieter when not needed. With the Power Gadget you can just set a fixed fan speed which is only helpful in some edge ca
Great tip thanks will try that.
As stated before when using hackintosh I get fully blowing fans even with my BIOS setting set to quiet its like pushing the take off button or in my "case" using the auto button. Its been like that forever so I thought that was a common opencore problem. With my fan setting by hand my CPU temperature almost never reaches 80 degrees Celsius. So I'm very happy I can do that. when I boot from my second (windows disk) everything is working as expected. I think I will order some Noctua fans to eliminate the noise even more. I am using my machine mainly for music production (logic pro).
 

Aluveitie

Donator
Donator
Joined
May 2, 2020
Messages
566
Weird, first time I hear about such issues. On both my X570 boards fan controlling by BIOS worked fine too.
 

henkiew

New member
Joined
Jun 23, 2020
Messages
6
Weird, first time I hear about such issues. On both my X570 boards fan controlling by BIOS worked fine too.
Well thanks again for your help. The switch is working. The explanation was on the github page. I never thought about starting it as root user. Maybe now I can automate this with a keyboard macro (y).
 
Top Bottom