All drives show up as external

  • Hello Guest. Before you post check the Troubleshooting guide here, Dortania Troubleshooting
  • Hello Guest, although it is possible to install Big Sur on AMD with our experimental patches. We won't provide support until Apple release the final build.

FatDad

New member
Jul 18, 2020
14
2
3
Anyone have this happen where all drives show up as external. It is something simple, yet its driving me crazy. I even reformatted the drive and reinstalled Big Sur and still shows up as external. Maybe is something in the config file?!
 

Attachments

wild_eep

Member
May 27, 2020
36
7
8
I don't know if my solution will help with ALL your drives, but a few weeks ago, my NVMe drive showed up as external drives. I was able to find a fix on reddit and wrote a post showing what I did here.
 
  • Like
Reactions: agent2

FatDad

New member
Jul 18, 2020
14
2
3
All I need now is to get the boot chime to work. I can’t for the life of me to figure out the proper way!


Sent from my iPhone using Tapatalk
 

agent2

Member
May 3, 2020
52
15
8
Somewhere over the Rainbow
I don't know if my solution will help with ALL your drives, but a few weeks ago, my NVMe drive showed up as external drives. I was able to find a fix on reddit and wrote a post showing what I did here.
Yeah I didn't try that method (maybe because I'm lazy or didn't have the time) I'll give it a shot but the kext solution worked a charm.
I don't know what else changes when I set externaldiskicons=true (don't want to mess up any other drive displaying or so) so my question is if there are any side effects to any of the two methods above because if there are none I will go throught hurdle and just change the config.plist and remove the kext.

UPDATE: So I used the reddit version as that one is the one where the EFI doesn't get so cluttered (I have a million kexts). It worked perfectly even without changing /kernel/quirks/externaldiskicon=true.
But what I didn't notice is that you are running Big Sur so that could have changed much more and only requires the little config.plist change!
So people on Catalina shouldn't be preaching what works for them as OC 0.6.0 and macOS 11 are a completely different scenario!
 
Last edited: