5800x B550i Aorus Pro AX at 11.5.2

Kirk

New member
Joined
Aug 17, 2021
Messages
6
CPU: 5800x
Motherboard: B550i Aorus Pro AX
Graphic Card: Radeon Pro W5500
WIFI & Bluetooth: BCM94352Z
Memery: 32G * 2 3200M Kingston Fury
Nvme: Sumsung 980 Pro 500G for Hackintosh; Kingston KC2500 500G for Win 10
Ver: macOS Big Sur 11.5.2

Successfully installed Big Sur 11.5.2 last night. Looks most functions are worked well such as airdrop and wifi as well as the 5800x. But the problems I found are:

Sidecar will have a black-screen when connect to my iPad. --- Does it caused by lack of an iGPU?
When the system goes into hibernating, the screen got black but the power and fan in the system are still working. Wake-up function well I feel. ---Does it caused by lack of some SSDT patches?

For the SSDTs, I download the SSDT-CPUR and SSDT-USBX from the OpenCore guide, and the EC part was made by SSDTTime from Windows 10.


Does anyone have the same problems with me? Attached is my EFI folder, hope it would help to some friends.
 

Attachments

  • EFI.zip
    23.7 MB · Views: 3

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,231
SideCar does not work with a iPad or anything else unless you are using a Intel cpu with a igpu So on a AMD hackintosh there’s no fix for it at this moment in time.

For your sleep not working mapping your USB ports should fix it.
Best and easiest way to map your ports is by using USBToolBox and if you can do it in Windows as it’s all Automatic if done inside there.
Instructions can be found on the GitHub.
 

Kirk

New member
Joined
Aug 17, 2021
Messages
6
SideCar does not work with a iPad or anything else unless you are using a Intel cpu with a igpu So on a AMD hackintosh there’s no fix for it at this moment in time.

For your sleep not working mapping your USB ports should fix it.
Best and easiest way to map your ports is by using USBToolBox and if you can do it in Windows as it’s all Automatic if done inside there.
Instructions can be found on the GitHub.
Thank you for your reply!

I followed the instructions on the link you sent. But after i reboot the system, the process become so slow (for i changed to OC release mode and can't see the log) and all usb ports have gone, even Bluetooth has gone as well... It's so wired, why would this happen?
 

Kirk

New member
Joined
Aug 17, 2021
Messages
6
I restore to the previous config.plist. And deleted all intel wireless kext files and updated config.plist the which I forgot to modify them with the BCM94352Z wireless card. Looks this BCM card requires no kexts and works well.

So, the only thing that caused loss all usbs ports is the file just generate. Should I remove the SSDT-USBX from ACPI folder to use this new kext?
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,231
I restore to the previous config.plist. And deleted all intel wireless kext files and updated config.plist the which I forgot to modify them with the BCM94352Z wireless card. Looks this BCM card requires no kexts and works well.

So, the only thing that caused loss all usbs ports is the file just generate. Should I remove the SSDT-USBX from ACPI folder to use this new kext?
No you need USBX to set the correct power states to the USB ports.
 

AudioGod

Guru
Guru
Joined
Nov 7, 2020
Messages
1,231
You must of mapped the ports wrong if nothings showing up after you enable your usbmap.kext
 
Top Bottom