Search results

  1. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    @mind hi, yes, PTXH ports are recognized by the system and working correctly without any patches. I'm also using a hub and all usb2.0 as well as usb3.0 ports are activated properly. Do you have exactly the same motherboard model? Here is a screenshot of my Hackintool / IORegistryExplorer for PTXH:
  2. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    minor update: bluetooth via Asus USB-BT400 (worked oob) added BIOS settings for thunderbolt benchmark results for Logic Pro X benchmark project: 136 tracks @ 64 samples / 48 kHz
  3. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    @leesurone I'm glad to know, this also worked for your motherboard. In my case, freezes were sporadic and very seldom when I left default auto settings for ESPI and I2C. Sometimes system could work stable like for a whole day and sometimes a freeze would occur just after a few minutes of use...
  4. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    @Geph0rce it must be in BIOS (advanced mode) under Settings -> AMD CBS -> FCH Common Options
  5. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    @dangthaison91 may be you could try this minimal installer EFI with a new installer USB according to this installer-guide. Also there seems to be another version of SSDT-CPUR for Ryzen 9 CPUs. May be you could try that as well..
  6. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    @dangthaison91: your config.plist seems to have a problem, try to change the following settings (marked red): Also make sure, that all your kexts are properly loaded (the format that you are using seems to be different). You could use the ProperTree tool to automatically generate settings for...
  7. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    @blackduck08 : make sure, that the lan is activated in BIOS, does ethernet work on Windows? If it is not working, you could try to use a USB ethernet adapter or try to make installer with complete MacOS image according to this guide, so that no download is required (however you would need a...
  8. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    @Potato007: I don't know, I haven't tried any VM software on this system yet... @sesewolf: Windows boots notably slower with CSM disabled, so I left it enabled. I haven't notice any problems by doing so (at least with my GPU).
  9. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    @blackduck08: you could check the name of your ethernet device in installer's network utility. in your case the name could be e.g. 'en1' instead of 'en0'. Just open the network utility, the ethernet device should be listed there. It'll be inactive and can be activated then via console.
  10. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    On this board sleep seems to be working fine with SSDT-SBUS-MCHC. Yes, I left PTXH controller untouched, as it was working well without any mapping (at least for my usb devices). All PTXH ports were also indicated correctly in the Hackintool / IORegistryExplorer.
  11. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    Hi, I'm not sure for SSDT-SBUS-MCHC and SSDT-HPET, since your DSDT might be different. You should check whether '_SB.PCI0.D02C' and 'HPET' devices are existing on your board. SSDT-CPUR, SSDT-PLUG, and SSDT-EC-USBX should be fine.
  12. A

    Frequent freezes and occasional kernel panics

    Try to deactivate the serial bus (ESPI, I2C) in your BIOS. This solved for me a lot of stability problems like random freezes.
  13. A

    Catalina 10.15.6 | Gigabyte B550 Aorus Pro | Ryzen 7 3700X | RX 5700 XT | 32 GB 3200 CL16 | Thunderbolt 3 via AIC | Bluetooth USB-BT400

    Update 15.09.2020: upgrade to OpenCore v0.6.1 Notes: sleep works fine without any additional patches / USB port mapping thunderbolt 3 connectivity via a PCIe add-in card GC-Titan Ridge rev. 2.0 (modified firmware 'NVM23-Elias64Fr') HW: PCIe x4 slot is required (had to uninstall the second...
  14. A

    B550 Gigabyte Aorus Pro (Bios: F14c) | Ryzen 7 3700X | Sapphire RX5500 XT incl. Performance Enhanced SSDT| OC 0.7.4-Release

    Thank you for sharing your experience. Injecting USB mappings via a kext actually works fine (made a silly copy/paste mistake on activating the usb mapping kext in config.plist). I managed to get sleep/wake working stable. I don't use any usb controller renaming/disabling via a SSDT, only the...
  15. A

    B550 Gigabyte Aorus Pro (Bios: F14c) | Ryzen 7 3700X | Sapphire RX5500 XT incl. Performance Enhanced SSDT| OC 0.7.4-Release

    The official dortania usb mapping guide didn't work for me (couldn't manage to inject usb mappings via a kext), so I decided to create a SSDT patch. The port mapping seems to be working, although I don’t have any bluetooth device. I use the attached SSDT along with the SSDT-EC-USBX.aml (and...
  16. A

    B550 Gigabyte Aorus Pro (Bios: F14c) | Ryzen 7 3700X | Sapphire RX5500 XT incl. Performance Enhanced SSDT| OC 0.7.4-Release

    Thank you for your example, but the device path of XHC0 (\_SB.PCI0.GPP1.XHC0) seems to be wrong. Shouldn't it rather be \_SB.PCI0.GP13.XHC0 ? I'm also trying to map USB ports via a kext, but this doesn't seem to be working at all.
Top Bottom